File qbittorrent.spec of Package qbittorrent
#
# spec file for package qbittorrent
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2014 Mariusz Fik <fisiu@opensuse.org>.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: qbittorrent
Version: 4.0.4
Release: 0
Summary: A BitTorrent client in Qt
License: GPL-2.0+
Group: Productivity/Networking/File-Sharing
URL: https://www.qbittorrent.org
Source: https://downloads.sf.net/%{name}/%{name}-%{version}.tar.xz
Source1: https://downloads.sf.net/%{name}/%{name}-%{version}.tar.xz.asc
Source2: %{name}.keyring
BuildRequires: cmake
%if 0%{?suse_version} > 1320
BuildRequires: libboost_system-devel
%else
BuildRequires: boost-devel
%endif
BuildRequires: fdupes
BuildRequires: hicolor-icon-theme
BuildRequires: libqt5-linguist-devel >= 5.5.1
BuildRequires: pkgconfig
%if 0%{?suse_version} < 1320
BuildRequires: update-desktop-files
%endif
BuildRequires: pkgconfig(Qt5Concurrent) >= 5.5.1
BuildRequires: pkgconfig(Qt5Core) >= 5.5.1
BuildRequires: pkgconfig(Qt5DBus) >= 5.5.1
BuildRequires: pkgconfig(Qt5Gui) >= 5.5.1
BuildRequires: pkgconfig(Qt5Network) >= 5.5.1
BuildRequires: pkgconfig(Qt5Svg) >= 5.5.1
BuildRequires: pkgconfig(Qt5Widgets) >= 5.5.1
BuildRequires: pkgconfig(Qt5Xml) >= 5.5.1
BuildRequires: pkgconfig(libtorrent-rasterbar) >= 1.1.4
BuildRequires: pkgconfig(systemd)
# For geolocalisation.
Requires: GeoIP
Recommends: python
# For search engines.
Recommends: python3
%requires_ge libtorrent-rasterbar9
%description
qBittorrent is a bittorrent client programmed in C++ and Qt that
uses libtorrent-rasterbar.
It has a streaming-like function to let users download and play video
files, supports Unicode and has a bandwith scheduler.
%package nox
Summary: A BitTorrent client in Qt, CLI version
Group: Productivity/Networking/File-Sharing
%{systemd_requires}
%description nox
qBittorrent is a bittorrent client programmed in C++ and Qt that
uses libtorrent-rasterbar. This subpackage contains a command-line
version.
%prep
%setup -q
%build
for ui in nox gui; do
[[ "$ui" == nox ]] && ui_opt='-DGUI=OFF' || ui_opt=
%cmake \
$ui_opt \
-DSYSTEMD=ON
make %{?_smp_mflags}
cd ..
mv build build.$ui
done
%install
for ui in nox gui; do
mv build.$ui build
%cmake_install
mv build build.$ui
done
mkdir -p %{buildroot}%{_sbindir}/
ln -sf %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}-nox
%fdupes %{buildroot}%{_datadir}/
%if 0%{?suse_version} < 1320
%post
%desktop_database_post
%icon_theme_cache_post
%postun
%desktop_database_postun
%icon_theme_cache_postun
%endif
%preun nox
%service_del_preun %{name}-nox@.service
%pre nox
%service_add_pre %{name}-nox@.service
%postun nox
%service_del_postun %{name}-nox@.service
%post nox
%service_add_post %{name}-nox@.service
%files
%doc AUTHORS Changelog README.md TODO
%license COPYING
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.png
%{_datadir}/icons/hicolor/*/status/%{name}-tray.png
%{_datadir}/icons/hicolor/scalable/status/%{name}-tray*.svg
%dir %{_datadir}/appdata/
%{_datadir}/appdata/%{name}.appdata.xml
%{_mandir}/man?/%{name}.?%{?ext_man}
%files nox
%doc AUTHORS Changelog README.md TODO
%license COPYING
%{_bindir}/%{name}-nox
%{_sbindir}/rc%{name}-nox
%{_unitdir}/%{name}-nox@.service
%{_mandir}/man?/%{name}-nox.?%{?ext_man}
%changelog