File latte-dock.spec of Package latte-git
#
# spec file for package latte-dock
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2017 Smith AR <audoban@openmailbox.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://github.com/psifidotos/Latte-Dock/issues
#
%define kf5_version 5.38.0
Name: latte-dock
Version: 999.git
Release: 0
Summary: Task manager
License: GPL-2.0+
Group: System/GUI/KDE
Url: https://github.com/psifidotos/Latte-Dock
Source: latte-dock-%{version}.tar.gz
BuildRequires: fdupes
BuildRequires: pkgconfig
BuildRequires: cmake(KF5Plasma) >= %{kf5_version}
BuildRequires: cmake(KF5PlasmaQuick) >= %{kf5_version}
BuildRequires: cmake(KF5Activities) >= %{kf5_version}
BuildRequires: cmake(KF5CoreAddons) >= %{kf5_version}
BuildRequires: cmake(KF5GuiAddons) >= %{kf5_version}
BuildRequires: cmake(KF5DBusAddons) >= %{kf5_version}
BuildRequires: cmake(KF5Declarative) >= %{kf5_version}
BuildRequires: cmake(KF5Wayland) >= %{kf5_version}
BuildRequires: cmake(KF5Package) >= %{kf5_version}
BuildRequires: cmake(KF5XmlGui) >= %{kf5_version}
BuildRequires: cmake(KF5IconThemes) >= %{kf5_version}
BuildRequires: cmake(KF5I18n) >= %{kf5_version}
BuildRequires: cmake(KF5Notifications) >= %{kf5_version}
BuildRequires: cmake(KF5Archive) >= %{kf5_version}
BuildRequires: cmake(KF5GlobalAccel) >= %{kf5_version}
BuildRequires: cmake(KF5Crash) >= %{kf5_version}
BuildRequires: cmake(KF5WindowSystem) >= %{kf5_version}
BuildRequires: cmake(KF5NewStuff) >= %{kf5_version}
BuildRequires: cmake(KF5SysGuard)
BuildRequires: cmake(KF5KIO)
BuildRequires: cmake(KF5Kirigami2)
BuildRequires: cmake(Qt5X11Extras) >= 5.7.0
BuildRequires: pkgconfig(xcb)
BuildRequires: pkgconfig(xcb-util)
BuildRequires: libSM-devel
BuildRequires: pkgconfig(zlib)
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?is_opensuse}
BuildRequires: update-desktop-files
%endif
Recommends: applet-latte-spacer
Recommends: applet-latte-separator
Recommends: kwinscript-window-colors
Recommends: latte-indicator-unity
%description
Latte is a dock based on plasma frameworks that provides an elegant
and intuitive experience for your tasks and plasmoids.
%prep
%setup -q
sed -i -E 's/(set\(VERSION )(.*?)(\))/\1%{version}\3/' CMakeLists.txt
%build
%cmake_kf5 -d build -- -DKDE_L10N_AUTO_TRANSLATIONS=OFF -DENABLE_MAKE_UNIQUE=OFF -DCMAKE_BUILD_TYPE=Release ..
%make_jobs
%install
%kf5_makeinstall -C build
%if 0%{?is_opensuse}
%suse_update_desktop_file -r org.kde.%{name} Utility DesktopUtility
%endif
%fdupes -s %{buildroot}
%files
%defattr(-,root,root)
%doc README.md
%doc COPYING.LIB
%{_kf5_bindir}/%{name}
%{_kf5_plasmadir}/
%{_kf5_qmldir}/
%{_kf5_servicesdir}/
%{_kf5_servicetypesdir}/latte-indicator.desktop
%{_kf5_sharedir}/dbus-1/interfaces/
%{_kf5_sharedir}/latte
%{_kf5_notifydir}/
%{_kf5_iconsdir}/
%{_kf5_sharedir}/metainfo/
%{_kf5_applicationsdir}/org.kde.%{name}.desktop
%if 0%{?suse_version} > 1500
%{_kf5_knsrcfilesdir}/
%else
%{_kf5_sharedir}/knsrcfiles/latte-indicators.knsrc
%{_kf5_sharedir}/knsrcfiles/latte-layouts.knsrc
%endif
%{_kf5_plugindir}/
#/usr/lib/debug/
#%#{_kf5_sharedir}/kwin/
#%#{_kf5_sharedir}/kwin/scripts
#%#{_kf5_sharedir}/kwin/scripts/activatelattelaunchermenu/
%changelog