File libArcus.spec of Package libArcus
#
# spec file for package CuraEngine
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define soname 3
Name: libArcus
Version: 2.5.0
Release: 0
Summary: 3D printer control software
License: AGPL-3.0
Group: BLAH
Url: http://github.com/Ultimaker/%name
Source: https://github.com/Ultimaker/%name/archive/%{version}/%name-%{version}.tar.xz
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: pkgconfig(libprotobuf-c)
BuildRequires: protobuf-c
BuildRequires: protobuf-devel
BuildRequires: python3-sip-devel
%description
Communication library between internal components for Ultimaker software
%package -n %name%soname
Summary: 3D printer control software
Group: Development/Libraries/C and C++
%description -n %name%soname
Communication library between internal components for Ultimaker software
%package devel
Summary: Header files for libArcus
Group: Development/Libraries/C and C++
Requires: libArcus%{soname} = %{version}
Requires: pkgconfig(libprotobuf-c)
Requires: protobuf-devel
Requires: python3-sip-devel
%description devel
%prep
%setup -q
%build
%cmake
make %{?_smp_mflags}
%install
cd build
%make_install
#install -Dm0644 %{SOURCE1} %{buildroot}%{_mandir}/man1/CuraEngine.1
%post -n %name%{soname} -p /sbin/ldconfig
%postun -n %name%{soname} -p /sbin/ldconfig
%files devel
%defattr(-,root,root,-)
%doc TODO.md
/usr/include/Arcus
%_libdir/cmake/Arcus
%_libdir/libArcus.so
%files -n %name%soname
%defattr(-,root,root,-)
%doc LICENSE README.md
%{python3_sitelib}/Arcus.so
%_libdir/libArcus.so.*