File saltbundlepy-pyinotify.spec of Package saltbundlepy-pyinotify

#
# spec file for package saltbundlepy-pyinotify
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

Name:           saltbundlepy-pyinotify
Version:        0.9.6
Release:        0
Summary:        Python module for watching filesystems changes
License:        MIT
Group:          Development/Libraries/Python
URL:            http://github.com/seb-m/pyinotify
Source:         https://files.pythonhosted.org/packages/source/p/pyinotify/pyinotify-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module devel >= 3.10}
BuildRequires:  %{saltbundlepy_module setuptools}
BuildRequires:  saltbundlepy-rpm-macros
BuildArch:      noarch
Requires:       saltbundlepy-base
Requires(post):   update-alternatives
Requires(postun):  update-alternatives
%python_subpackages

%description
pyinotify is a Python module for watching filesystems changes. By its design
pyinotify can be used for any kind of fs monitoring.

pyinotify relies on a recent Linux Kernel feature (merged in kernel 2.6.13)
called inotify. inotify is an event-driven notifier, its notifications are
exported from kernel space to user space. The raw interface of inotify is
compounded of three system calls. pyinotify binds these system calls and
provides an implementation on top of them offering a generic and abstract way
to use inotify with Python. Pyinotify doesn't requires much detailed knowledge
of inotify. Moreover, it only needs few statements for initializing, watching,
handling (eventually trough a new separate thread), and processing events
notifications through subclassing. The only things to know is the path of items
to watch, the kind of events to monitor and the actions to execute on these
notifications.

%prep
%setup -q -n pyinotify-%{version}
sed -i '/^#!/ d' python3/pyinotify.py

%build
%python_build

%install
%python_install

%files %{python_files}
%defattr(-,root,root)
%doc ACKS COPYING README.md
%doc old/ChangeLog old/NEWS
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by