File python-nose.spec of Package python-nose

#norootforbuild
#
%define real_name nose
#
#
Name:           python-%{real_name}
Group:          Development/Libraries/Python
Version:        0.11.1
Release:        0
License:        LGPLv2.1+
Summary:        nose extends unittest to make testing easier
Autoreqprov:    on
Source:         %{real_name}-%{version}.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-setuptools
Url:            http://babel.edgewall.org/
%{py_requires}
%define py_vers %(%{__python} -c 'import sys; print int(10*float(sys.version[:3]))')
%if %{?suse_version: %{suse_version} > 1110} %{!?suse_version:1}
BuildArch: noarch
%else
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(True)")}
%endif

%description
nose extends the test loading and running features of unittest, making it easier to write, find and run tests.

By default, nose will run tests in files or directories under the current working directory whose names include "test" or "Test" at a word boundary (like "test_this" or "functional_test" or "TestClass" but not "libtest"). Test output is similar to that of unittest, but also includes captured stdout output from failing tests, for easy print-style debugging.

These features, and many more, are customizable through the use of plugins. Plugins included with nose provide support for doctest, code coverage and profiling, flexible attribute-based test selection, output capture and more. More information about writing plugins may be found on in the nose API documentation, here: http://somethingaboutorange.com/mrl/projects/nose/

%prep
%setup -n %{real_name}-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT --record-rpm=INSTALLED_FILES

%clean
rm -rf $RPM_BUILD_ROOT

%files -f INSTALLED_FILES
%defattr(-,root,root)
%doc AUTHORS CHANGELOG doc examples lgpl.txt NEWS README.txt

%changelog

* Sun Nov 22 2009 - Ciaran Farrell <cfarrell1980@gmail.com> - 0.11.1
- Initial build for tg21

  
openSUSE Build Service is sponsored by