File uad-ng.spec of Package uad-ng
#
# spec file for package uad-ng
#
# Copyright (c) 2024, 2025 Boian Berberov
# Copyright (c) 2024 mantarimay
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define full_name universal-android-debloater-next-generation
Name: uad-ng
Version: 1.1.0
Release: 1%{?dist}
Group: Hardware/Mobile
Summary: Cross-platform GUI written in Rust using ADB to debloat non-rooted Android devices
License: GPL-3.0-or-later
URL: https://github.com/Universal-Debloater-Alliance/%{full_name}
Source0: %{url}/archive/refs/tags/v%{version}.tar.gz
Source1: vendor.tar.zst
%if 0%{?suse_version}
# BUG: OOMs on i586
# BuildRequires: memory-constraints
BuildRequires: cargo-packaging
%endif
%if 0%{?fedora} || 0%{?rhel} == 9 || 0%{?mageia}
BuildRequires: cargo-rpm-macros >= 24
%endif
Requires: android-tools
%description
Cross-platform GUI written in Rust using ADB to debloat non-rooted Android devices
%prep
# Run before setup so it does not clobber the vendor tarball
%if 0%{?fedora} || 0%{?rhel_version} || 0%{?centos_version} || 0%{?mageia}
%cargo_prep
%endif
%setup -q -n %{full_name}-%{version} -a 1
%build
# %%if 0%%{?suse_version}
# # BUG: OOMs on i586
# %%ifarch %%ix86
# # OBS memory-constraints settings
# # NOTE: must be set before any use of %%{jobs}
# %%limit_build -m 44000
# true
# %%endif
# %%endif
%{cargo_build} --no-default-features --features wgpu,no-self-update
%check
%{cargo_test}
%install
%{cargo_install}
%files
%license LICENSE
%{_bindir}/%{name}
%changelog