File gambas2.spec of Package gambas2

#
# spec file for package gambas2
#
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:           gambas2
Summary:        Runtime Environment for Gambas
Url:            http://gambas.sourceforge.net/
License:        GPL-2.0
Group:          Development/Tools/IDE
Version:        2.24.0
Release:        1
Vendor:         openSUSE-Education
BuildRequires:  SDL-devel SDL_image SDL_gfx-devel curl-devel gtk2-devel kdelibs3-devel
BuildRequires:  mysql-devel openldap2-devel 
%if %suse_version <= 1510
%if 0%{?sle_version} <= 150100
BuildRequires:  postgresql-devel 
%endif
%endif
%if %suse_version < 1550
BuildRequires:  orbit2-devel
%endif
BuildRequires:  sqlite-devel unixODBC-devel
BuildRequires:  glibc-devel libstdc++-devel gcc-c++ libtool
BuildRequires:  libjpeg-devel libpng-devel librsvg-devel
BuildRequires:  Mesa-devel zlib-devel 
BuildRequires:  libxslt-devel glib2-devel
BuildRequires:  pcre-devel 
%if %suse_version < 1500
BuildRequires:  poppler-devel sqlite2-devel
%endif
BuildRequires:  sqlite3-devel
BuildRequires:  fontconfig-devel freetype2-devel cairo-devel pango-devel 
BuildRequires:  pkgconfig(atk) qt3-devel gettext-devel
BuildRequires:  gcc-fortran
%if %suse_version < 1600
BuildRequires:  xorg-x11-devel
%endif
%if 0%{?sle_version} <= 150200
BuildRequires:  omniORB-devel
%endif
BuildRequires:  xorg-x11-proto-devel
BuildRequires:  libffi-devel
BuildRequires:  SDL_mixer-devel
BuildRequires:  SDL_image-devel 
BuildRequires:  fdupes
%if %suse_version > 1140
BuildRequires:  libv4l-devel
%endif
Source0:        gambas2-%{version}.tar.bz2
Source2:        %{name}.desktop
Source3:        %{name}.png
Source4:        x-gambas.desktop
Patch1:         gambas-2.4.1-mime_translation.patch
Patch2:         gambas-poppler-0.20.x.patch
Patch3:         gambas2-configure-fixes.patch
Patch4:         gambas2-remove-unused-symbols.patch
Patch5:         gambas2-newc++.patch
Patch6:         gambas2-gzclose.patch
Patch7:         gambas2-deprecate-update-desktop-files.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define         infodir %{_datadir}/gambas/info
%define         kdedir  /opt/kde3

%description 
Gambas is a free development environment based on a Basic interpreter
with object extensions, like Visual Basic(tm) (but it is NOT a clone!).
With Gambas, you can quickly design your program GUI, access MySQL or
PostgreSQL databases, control KDE applications with DCOP, translate
your program into many languages, create network applications easily,
build RPMs of your apps automatically, and so on... You have to install
the necessary components

Gambas is still in development, but already useful for smaller projects.
The IDE itself is written in Gambas-BASIC. The source can be used reviewed
as an example application in the /usr/share/gambas/examples directory.
Documentation is also in that directory.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package ide
Summary:        The Gambas Development Enviroment
Group:          Development/Tools/IDE
Requires:       gettext-tools
Requires:       rpm
Requires:       gzip
Requires:       tar
Requires:       %{name}-runtime
Requires:       %{name}-devel
Requires:       %{name}
Recommends:     %{name}-script
Recommends:     %{name}-gb-compress
Recommends:     %{name}-gb-compress-zlib
Recommends:     %{name}-gb-compress-bzlib2
Recommends:     %{name}-gb-db
Recommends:     %{name}-gb-settings
Recommends:     %{name}-gb-db-sqlite
Recommends:     %{name}-gb-db-sqlite3
Recommends:     %{name}-gb-db-mysql
Recommends:     %{name}-gb-db-postgresql
Recommends:     %{name}-gb-db-odbc
Recommends:     %{name}-gb-net
Recommends:     %{name}-gb-net-curl
Recommends:     %{name}-gb-qt
Recommends:     %{name}-gb-qt-ext
Recommends:     %{name}-gb-qt-kde
Recommends:     %{name}-gb-qt-kde-html
Recommends:     %{name}-gb-form
Recommends:     %{name}-gb-sdl
Recommends:     %{name}-gb-vb
Recommends:     %{name}-gb-xml
Recommends:     %{name}-gb-crypt
Recommends:     %{name}-gb-gtk
Recommends:     %{name}-gb-gtk-ext
Recommends:     %{name}-gb-gtk-svg
Recommends:     %{name}-gb-opengl
Recommends:     %{name}-gb-pcre
Recommends:     %{name}-gb-v4l
Recommends:     %{name}-gb-info
Recommends:     %{name}-gb-pdf
Recommends:     %{name}-gb-image
Recommends:     %{name}-gb-net-smtp
Recommends:     %{name}-gb-db-form
Recommends:     %{name}-gb-form-mdi
Recommends:     %{name}-gb-form-dialog
Recommends:     %{name}-gb-chart
Recommends:     %{name}-gb-desktop
Recommends:     %{name}-gb-web
Recommends:     %{name}-gb-report
Recommends:     %{name}-gb-option
Recommends:     %{name}-gb-gui
Recommends:     %{name}-gb-corba

%description ide
This package includes the complete Gambas Development Environment, with the
database manager, and the help files.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package runtime
Summary:        The Gambas runtime
Group:          Development/Tools/IDE
Requires:       glibc, gcc, gcc-c++

%description runtime
This package includes the Gambas interpreter needed to run Gambas applications.

It contains:

    * The interpreter: gbx2.
    * The symbolic link on gbx2: gbr2.
    * The internal component description: gb.component, gb.info and gb.list.
    * The readme files, TODO files, and so on.
    * The gb.debug component: gb.debug.info, gb.debug.list, gb.debug.component, gb.debug.so.*, gb.debug.la.
    * The gb.eval component: gb.eval.info, gb.eval.list, gb.eval.component, gb.eval.so.*, gb.eval.la.
    * The gb.draw component: gb.draw.info, gb.draw.list, gb.draw.component, gb.draw.so.*, gb.draw.la.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package devel
Summary:        The Gambas devel package
Group:          Development/Tools/IDE
Requires:       %{name}-runtime 

%description devel
This package includes all tools needed to compile Gambas projects without 
having to install the complete development environment.

It contains:

    * The compiler: gbc2.
    * The archiver: gba2.
    * The informer: gbi2.

Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package script
Summary:        Program that allows to write script files in Gambas
Group:          Development/Tools/IDE
Requires:       %{name}-runtime %{name}-devel
PreReq:         shared-mime-info
Provides:       /usr/bin/gbx2

%description script
This package includes the scripter program that allows to write script files in Gambas.

It contains:

    * The scripter: gbs2.gambas.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-compress
Summary:        A compression component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       zlib
%if 0%{suse_version} > 1020
Requires:       libbz2-1
%else
Requires:       bzip2
%endif


%description gb-compress
This component allows you to compress/uncompress data or files with
the bzip2 and zip algorithms.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-compress-zlib
Summary:        The zlib compression component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-compress

%description gb-compress-zlib
This component allows you to compress/uncompress data or files with
the zlib algorithms.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-compress-bzlib2
Summary:        The bzlib2 compression component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-compress

%description gb-compress-bzlib2
This component allows you to compress/uncompress data or files with
the bzlib2 algorithms.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-db
Summary:        The database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-db
This component allows you to access many databases management systems,
provided that you install the needed driver packages.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-settings
Summary:        Application settings management
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-settings
This component allows you to read and write settings with your 
application.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>

%if %suse_version < 1500
%package gb-db-sqlite
Summary:        The sqlite driver for the Gambas database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db
Requires:       sqlite2

%description gb-db-sqlite
This component allows you to access sqlite databases.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>
%endif

%package gb-db-sqlite3
Summary:        The sqlite driver for the Gambas database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db
Requires:       sqlite3

%description gb-db-sqlite3
This component allows you to access sqlite v 3.x databases.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-db-mysql
Summary:        The MySQL driver for the Gambas database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db
Requires:       mysql

%description gb-db-mysql
This component allows you to access MySQL databases.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>

%if %suse_version <= 1510
%if 0%{?sle_version} <= 150100
%package gb-db-postgresql
Summary:        The postgresql driver for the Gambas database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db
Requires:       postgresql

%description gb-db-postgresql
This component allows you to access postgresql databases.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>
    
%endif
%endif

%package gb-db-odbc
Summary:        The unixODBC driver for the Gambas database component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db
Requires:       unixODBC

%description gb-db-odbc
This component allows you to access to a database thru unixODBC driver.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-net
Summary:        The networking component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-net
This component allows you to use TCP/IP and UDP sockets, and to access
any serial ports.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-net-curl
Summary:        The advanced networking component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       curl

%description gb-net-curl
This component allows your programs to easily become FTP or HTTP clients.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-qt
Summary:        The Qt GUI component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       qt3 >= 3.2

%description gb-qt
This package includes the Gambas QT GUI component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-qt-ext
Summary:        The extended Qt GUI component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-qt

%description gb-qt-ext
This component includes somme uncommon QT controls.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-qt-kde
Summary:        The KDE component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-gui
Requires:       %{name}-gb-qt
Recommends:       fam
Requires:       kdebase3 >= 3.1

%description gb-qt-kde
This component transforms your QT application in a KDE application, and
allows you to pilot any other KDE application with the DCOP protocol.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-qt-kde-html
Summary:        The KHTML component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-qt-kde

%description gb-qt-kde-html
This component allows you to use the Web Browser widget included in KDE


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-form
Summary:        The control component for both GTK+ and qt
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-form
This component contain some control elements to be used in both gtk+ and qt
components.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-sdl
Summary:        The SDL component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       SDL_mixer
Requires:       libvorbis
Requires:       libogg
Provides:       %{name}-gb-sdl-image  = %{version}-%{release}
Provides:       %{name}-gb-sdl-opengl = %{version}-%{release}

%description gb-sdl
This component use only the sound part of the SDL library. It allows you to
simultaneously play many sounds and a music stored in a file.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-vb
Summary:        The Visual Basic(tm) compatibility component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-vb
This component aims at including some functions that imitate the behaviour
of Visual Basic(tm) functions. Use it only if you try to port some VB
projects.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-xml
Summary:        The Gambas XML components based on the libxml and libxslt libraries
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-xml
These components brings the power of the libxml and libxslt libraries to
Gambas.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-crypt
Summary:        The Crypto component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-crypt
This component allows an easy use of some crypt utilities, as md5.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>

%package gb-gtk
Summary:        The GTK GUI component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-gui
Requires:       gtk2  >= 2.6.8

%description gb-gtk
This package includes the Gambas GTK GUI component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-gtk-ext
Summary:        The GTK extension component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-gtk

%description gb-gtk-ext
This package includes the Gambas GTK extension component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-gtk-svg
Summary:        The GTK SVG component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-gtk
#Requires:       libsvg
#Requires:       librsvg

%description gb-gtk-svg
This package includes the Gambas SVG GTK component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>

%package gb-opengl
Summary:        The opengl component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-opengl
This package includes the Gambas opengl component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-pcre
Summary:        The pcre component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       pcre

%description gb-pcre
This package includes the Gambas pcre component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-v4l
Summary:        The v4l component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       v4l-tools

%description gb-v4l
This package includes the Gambas v4l component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-info
Summary:        The information component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-info
This component aims at providing all needed information about installed
components: classes, symbols, events, controls, properties, and so on.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%if 0%{?suse_version} < 1500
%package gb-pdf
Summary:        The pdf component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-pdf
This component permits the manipulation of pdf documents.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>
%endif

%package gb-image
Summary:        The image component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-image
This component permits the manipulation of some image objects .


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-net-smtp
Summary:        The smtp component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-net

%description gb-net-smtp
Allows to send mails, with attachments, by using the SMTP protocol.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-db-form
Summary:        The data bound control component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-db

%description gb-db-form
Provides some data bound controls, i.e. controls that can display and edit
database records automatically. Note that it is highly experimental!.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-form-mdi
Summary:        Implements the Workspace control
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-form

%description gb-form-mdi
This component implements the new Workspace control.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-form-dialog
Summary:        Implements the Dialog Class
Group:          Development/Tools/IDE
Requires:       %{name}-runtime
Requires:       %{name}-gb-form

%description gb-form-dialog
This component implements Dialog Class


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-chart
Summary:        The chart component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-chart
This is the component that draws charts .


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-desktop
Summary:        The desktop component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-desktop
This is a component that provides an access to the Portland project xdg utilities


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-web
Summary:        The CGI web component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-web
This is a component for making CGI web applications, with an ASP-like interface.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-report
Summary:        The Gambas report designer component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-report
This is the Gambas report designer component.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-option
Summary:        The C getopt() interface component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-option
This is the inteface to C getopt() function.


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>


%package gb-gui
Summary:        The qt/gtk loader component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-gui
This is the component that just loads gb.qt if you are running KDE or 
gb.gtk in the other cases. It will make your application more 
desktop-friendly!


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>

%if 0%{?sle_version} <= 150200
%package gb-corba
Summary:        The corba component
Group:          Development/Tools/IDE
Requires:       %{name}-runtime

%description gb-corba
This is the CORBA component.
It will make your application more desktop-friendly!


Authors:
--------
    Benoît Minisini <gambas@users.sourceforge.net>
%endif

%prep
%setup -q
%patch -P 1 -p1
%patch -P 2 -p3
%patch -P 3 -p1
%patch -P 4 -p1
%if 0%{?suse_version} > 1600
%patch -P 5 -p1
%endif
sed -i 's/\x01//g' gb.db.sqlite3/src/main.cpp
%if %suse_version > 1140
sed -i 's|linux/videodev.h|libv4l1-videodev.h|g' gb.v4l/src/CWebcam.h
sed -i 's|linux/videodev.h|libv4l1-videodev.h|g' gb.v4l/configure.ac
#sed -i 's|linux/videodev.h|libv4l1-videodev.h|g' gb.v4l/configure
%endif
%patch -P 6 -p1
%patch -P 7 -p1

%build
#rm -rf main/m4
#rm -rf m4
#autoreconf -fi
./reconf-all
# needed, or libtool does not create shared libs
export AM_CFLAGS="%optflags -Wno-narrowing -Wno-error=return-type -fcommon -no-pie"
export AM_CXXFLAGS="%optflags -fpermissive -Wno-narrowing -Wno-error=return-type -fcommon -no-pie"

%configure \
  --enable-kde \
  --with-bzlib2-libraries=%_libdir \
  --with-zlib-libraries=%_libdir \
  --with-sqlite-libraries=%_libdir \
  --with-sql-libraries=%_libdir \
  --with-kde-libraries=/opt/kde3/%_lib \
  --with-kde-includes=/opt/kde3/include \
  --with-qt-libraries=/usr/lib/qt3/%_lib \
  --with-qt-includes=/usr/lib/qt3/include \
  --with-pgsql-includes=/usr/include/pgsql/ \
  --with-pgsql-libraries=%_libdir \
  --with-mysql-includes=/usr/include/mysql/ \
  --with-mysql-libraries=%_libdir \
  --enable-optimization \
  --enable-shared


%install
install -D -m644 %{S:3} %{buildroot}%{_datadir}/pixmaps/gambas2.png
install -D -m644 %{S:2} %{buildroot}%{_datadir}/applications/gambas2.desktop
%makeinstall
find %{buildroot}%{_datadir}/gambas2/examples/Printing/Printing/Images -name "*.png" | xargs chmod 644
rm -rf %{buildroot}%{_prefix}/lib/control/.xvpics
#
# fix the included buildroot path
for i in $(find %{buildroot}%{_datadir}/gambas2/examples/ -type f); do
    perl -pi -e "s|%{buildroot}||g" $i
done
#
# gb.la, gb.so, gb.so.0 and gb.so.0.0.0 do not need to be distributed. 
# They are temporary files used for generating gb.info and gb.list only.
find %{buildroot} -type f -name gb.la -exec rm {} \;
if [ -f %{buildroot}/%{_libdir}/gambas2/gb.so ]; then
    rm -v %{buildroot}/%{_libdir}/gambas2/gb.so*
fi
#
# install mime type files
install -Dm644 app/mime/application-x-gambasscript.xml %{buildroot}%{_datadir}/mime/application/x-gambasscript.xml
install -m644  app/mime/application-x-gambasscript.png %{buildroot}%{_datadir}/pixmaps/x-gambasscript.png
install -Dm644 %{SOURCE4} %{buildroot}%{kdedir}/share/mimelnk/application/x-gambas.desktop
#
# save discspace, create softlinks
%fdupes %buildroot

install -d %{buildroot}/usr/share/gambas2/help/help/image/help/image
install -d %{buildroot}/usr/share/gambas2/help/help/img/help/img

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%post script
if [ -x usr/bin/update-mime-database ]; then
    usr/bin/update-mime-database usr/share/mime >/dev/null
fi

%postun script
if [ -x usr/bin/update-mime-database ]; then
    usr/bin/update-mime-database usr/share/mime >/dev/null
fi

%files
%defattr(-, root, root, 0755)
%{_bindir}/gambas2
%{_bindir}/gambas2-database-manager*
%{_bindir}/gambas2.gambas

%files ide
%defattr(-, root, root)
%doc README

%files runtime
%defattr(-, root, root, 0755)
%doc README.svn-commit COPYING ChangeLog  
%dir %{_libdir}/gambas2
%dir %{_datadir}/gambas2
%dir %{_datadir}/gambas2/info
%{_bindir}/gbx2
%{_bindir}/gbr2
%{_libdir}/gambas2/gb.component
%{_datadir}/gambas2/info/gb.info
%{_datadir}/gambas2/info/gb.list
%{_datadir}/applications/gambas2.desktop
%{_datadir}/pixmaps/gambas2.png
%{_libdir}/gambas2/gb.debug.*
%{_datadir}/gambas2/info/gb.debug.*
%{_libdir}/gambas2/gb.eval.*
%{_datadir}/gambas2/info/gb.eval.*
%{_libdir}/gambas2/gb.draw.*

%files devel
%defattr(-, root, root, 0755)
%{_bindir}/gbc2
%{_bindir}/gba2
%{_bindir}/gbi2
%{_datadir}/gambas2/help
%{_datadir}/gambas2/examples

%files script
%defattr(-, root, root)
%dir %{_datadir}/mime/application
%dir %{kdedir}
%dir %{kdedir}/share
%dir %{kdedir}/share/mimelnk
%dir %{kdedir}/share/mimelnk/application
%{_bindir}/gbs2*
%{_bindir}/gbw2*
%{_datadir}/mime/application/*
%{_datadir}/pixmaps/x-gambasscript.png
%{kdedir}/share/mimelnk/application/x-gambas.desktop

%files gb-compress
%defattr(-,root,root)
%{_libdir}/gambas2/gb.compress.la*
%{_libdir}/gambas2/gb.compress.so*
%{_libdir}/gambas2/gb.compress.component
%{_datadir}/gambas2/info/gb.compress.*

%files gb-db
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.la
%{_libdir}/gambas2/gb.db.so*
%{_libdir}/gambas2/gb.db.component
%{_datadir}/gambas2/info/gb.db.info
%{_datadir}/gambas2/info/gb.db.list

%files gb-db-mysql
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.mysql.*

%if %suse_version <= 1510
%if 0%{?sle_version} <= 150100
%files gb-db-postgresql
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.postgresql.*
%endif
%endif

%if %suse_version < 1500
%files gb-db-sqlite
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.sqlite2.*
%endif

%files gb-net
%defattr(-,root,root)
%{_libdir}/gambas2/gb.net.la
%{_libdir}/gambas2/gb.net.so*
%{_libdir}/gambas2/gb.net.component
%{_datadir}/gambas2/info/gb.net.info
%{_datadir}/gambas2/info/gb.net.list

%files gb-net-curl
%defattr(-,root,root)
%{_libdir}/gambas2/gb.net.curl.la
%{_libdir}/gambas2/gb.net.curl.so*
%{_libdir}/gambas2/gb.net.curl.component
%{_datadir}/gambas2/info/gb.net.curl.info
%{_datadir}/gambas2/info/gb.net.curl.list

%files gb-qt
%defattr(-,root,root)
%{_libdir}/gambas2/gb.qt.la
%{_libdir}/gambas2/gb.qt.so*
%{_libdir}/gambas2/gb.qt.component
%{_libdir}/gambas2/gb.qt.gambas
%{_datadir}/gambas2/info/gb.qt.info
%{_datadir}/gambas2/info/gb.qt.list

%files gb-qt-ext
%defattr(-,root,root)
%{_libdir}/gambas2/gb.qt.ext.la
%{_libdir}/gambas2/gb.qt.ext.so*
%{_libdir}/gambas2/gb.qt.ext.component
%{_datadir}/gambas2/info/gb.qt.ext.info
%{_datadir}/gambas2/info/gb.qt.ext.list

%files gb-qt-kde
%defattr(-,root,root)
%{_libdir}/gambas2/gb.qt.kde.la
%{_libdir}/gambas2/gb.qt.kde.so*
%{_libdir}/gambas2/gb.qt.kde.component
%{_datadir}/gambas2/info/gb.qt.kde.info
%{_datadir}/gambas2/info/gb.qt.kde.list

%files gb-qt-kde-html
%defattr(-,root,root)
%{_libdir}/gambas2/gb.qt.kde.html.la
%{_libdir}/gambas2/gb.qt.kde.html.so*
%{_libdir}/gambas2/gb.qt.kde.html.component
%{_datadir}/gambas2/info/gb.qt.kde.html.info
%{_datadir}/gambas2/info/gb.qt.kde.html.list

%files gb-form
%defattr(-,root,root)
%{_libdir}/gambas2/gb.form.component
%{_libdir}/gambas2/gb.form.gambas
%{_datadir}/gambas2/info/gb.form.info
%{_datadir}/gambas2/info/gb.form.list

%files gb-form-mdi
%defattr(-,root,root)
%{_libdir}/gambas2/gb.form.mdi.*
%{_datadir}/gambas2/info/gb.form.mdi.info
%{_datadir}/gambas2/info/gb.form.mdi.list

%files gb-form-dialog
%defattr(-,root,root)
%{_libdir}/gambas2/gb.form.dialog.*
%{_datadir}/gambas2/info/gb.form.dialog.info
%{_datadir}/gambas2/info/gb.form.dialog.list

%files gb-settings
%defattr(-, root, root, 0755)
%{_libdir}/gambas2/gb.settings.*
%{_datadir}/gambas2/info/gb.settings.info
%{_datadir}/gambas2/info/gb.settings.list

%files gb-sdl
%defattr(-,root,root)
%{_libdir}/gambas2/gb.sdl.la
%{_libdir}/gambas2/gb.sdl.so*
%{_libdir}/gambas2/gb.sdl.component
%if 0%{?suse_version} <= 1600
%{_datadir}/gambas2/info/gb.sdl.info
%{_datadir}/gambas2/info/gb.sdl.list
%endif
%{_datadir}/gambas2/info/gb.sdl.sound.info
%{_datadir}/gambas2/info/gb.sdl.sound.list

%files gb-vb
%defattr(-,root,root)
%{_libdir}/gambas2/gb.vb.la
%{_libdir}/gambas2/gb.vb.so*
%{_libdir}/gambas2/gb.vb.component
%{_datadir}/gambas2/info/gb.vb.info
%{_datadir}/gambas2/info/gb.vb.list

%files gb-xml
%defattr(-,root,root)
%{_libdir}/gambas2/gb.xml.*
%{_datadir}/gambas2/info/gb.xml.*

%files gb-crypt
%defattr(-,root,root)
%{_libdir}/gambas2/gb.crypt.*
%{_datadir}/gambas2/info/gb.crypt.*

%files gb-db-odbc
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.odbc.*

%files gb-db-sqlite3
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.sqlite3.*

%files gb-gtk
%defattr(-,root,root)
%{_libdir}/gambas2/gb.gtk.la
%{_libdir}/gambas2/gb.gtk.so*
%{_libdir}/gambas2/gb.gtk.component
%{_libdir}/gambas2/gb.gtk.gambas
%{_datadir}/gambas2/info/gb.gtk.info
%{_datadir}/gambas2/info/gb.gtk.list

%files gb-gtk-ext
%defattr(-,root,root)
%{_libdir}/gambas2/gb.gtk.ext.*
%{_datadir}/gambas2/info/gb.gtk.ext.info
%{_datadir}/gambas2/info/gb.gtk.ext.list

%files gb-gtk-svg
%defattr(-,root,root)
%{_libdir}/gambas2/gb.gtk.svg.*
%{_datadir}/gambas2/info/gb.gtk.svg.info
%{_datadir}/gambas2/info/gb.gtk.svg.list

%if %suse_version < 1500
%files gb-pdf
%defattr(-,root,root)
%{_libdir}/gambas2/gb.pdf.*
%{_datadir}/gambas2/info/gb.pdf.*
%endif

%files gb-opengl
%defattr(-,root,root)
%{_libdir}/gambas2/gb.opengl.*
%{_libdir}/gambas2/gb.qt.opengl.*
%{_datadir}/gambas2/info/gb.opengl.*
%{_datadir}/gambas2/info/gb.qt.opengl.*

%files gb-pcre
%defattr(-,root,root)
%{_libdir}/gambas2/gb.pcre.*
%{_datadir}/gambas2/info/gb.pcre.*

%files gb-v4l
%defattr(-,root,root)
%{_libdir}/gambas2/gb.v4l.*
%{_datadir}/gambas2/info/gb.v4l.*

%files gb-compress-zlib
%defattr(-,root,root)
%{_libdir}/gambas2/gb.compress.zlib.la*
%{_libdir}/gambas2/gb.compress.zlib.so*

%files gb-compress-bzlib2
%defattr(-,root,root)
%{_libdir}/gambas2/gb.compress.bzlib2.la*
%{_libdir}/gambas2/gb.compress.bzlib2.so*

%files gb-info
%defattr(-,root,root)
%{_libdir}/gambas2/gb.info.*
%{_datadir}/gambas2/info/gb.info.*

%files gb-image
%defattr(-,root,root)
%{_libdir}/gambas2/gb.image.la*
%{_libdir}/gambas2/gb.image.so*
%{_libdir}/gambas2/gb.image.component
%{_datadir}/gambas2/info/gb.image.info
%{_datadir}/gambas2/info/gb.image.list

%files gb-net-smtp
%defattr(-,root,root)
%{_libdir}/gambas2/gb.net.smtp.la
%{_libdir}/gambas2/gb.net.smtp.so*
%{_libdir}/gambas2/gb.net.smtp.component
%{_datadir}/gambas2/info/gb.net.smtp.info
%{_datadir}/gambas2/info/gb.net.smtp.list

%files gb-db-form
%defattr(-,root,root)
%{_libdir}/gambas2/gb.db.form.*
%{_datadir}/gambas2/info/gb.db.form.info
%{_datadir}/gambas2/info/gb.db.form.list

%files gb-chart
%defattr(-,root,root)
%{_libdir}/gambas2/gb.chart.*
%{_datadir}/gambas2/info/gb.chart.info
%{_datadir}/gambas2/info/gb.chart.list

%files gb-desktop
%defattr(-,root,root)
%{_libdir}/gambas2/gb.desktop.*
%{_datadir}/gambas2/info/gb.desktop.info
%{_datadir}/gambas2/info/gb.desktop.list

%files gb-web
%defattr(-,root,root)
%{_libdir}/gambas2/gb.web.*
%{_datadir}/gambas2/info/gb.web.info
%{_datadir}/gambas2/info/gb.web.list

%files gb-report
%defattr(-,root,root)
%{_libdir}/gambas2/gb.report.*
%{_datadir}/gambas2/info/gb.report.info
%{_datadir}/gambas2/info/gb.report.list

%files gb-option
%defattr(-,root,root)
%{_libdir}/gambas2/gb.option.*
%{_datadir}/gambas2/info/gb.option.info
%{_datadir}/gambas2/info/gb.option.list

%files gb-gui
%defattr(-,root,root)
%{_libdir}/gambas2/gb.gui.*
%{_datadir}/gambas2/info/gb.gui.info
%{_datadir}/gambas2/info/gb.gui.list

%if 0%{?sle_version} <= 150200
%files gb-corba
%defattr(-,root,root)
%{_libdir}/gambas2/gb.corba.la*
%{_libdir}/gambas2/gb.corba.so*
%{_libdir}/gambas2/gb.corba.component
%{_datadir}/gambas2/info/gb.corba.info
%{_datadir}/gambas2/info/gb.corba.list
%endif

%changelog
openSUSE Build Service is sponsored by