File supervisor.spec of Package supervisor
#
# spec file for package supervisor
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
%if 0%{?suse_version} > 1500
%bcond_without tests
%else
%bcond_with tests
%endif
Name: supervisor
Version: 4.1.0
Release: 0
Summary: A system for controlling process state under UNIX
License: SUSE-Repoze
Group: Development/Languages/Python
URL: http://supervisord.org/
Source: https://files.pythonhosted.org/packages/source/s/supervisor/supervisor-%{version}.tar.gz
Source2: supervisord.conf
Source3: supervisord.service
Source4: supervisord-tmpfiles.conf
BuildRequires: fdupes
%if %{with tests}
BuildRequires: python3-mock >= 0.5.0
BuildRequires: python3-pytest
%endif
BuildRequires: python3-rpm-macros
BuildRequires: python3-setuptools
Requires: python3-setuptools
Suggests: python3-cElementTree >= 1.0.2
BuildArch: noarch
%{?systemd_requires}
%description
Supervisor is a client/server system that allows its users to
control a number of processes on UNIX-like operating systems.
%prep
%setup -q
sed -i 's|#!<<PYTHON>>|#!%{_bindir}/python3|g' supervisor/tests/fixtures/unkillable_spew.py supervisor/tests/fixtures/spew.py
find . -name '*.py' -exec sed -i "s|#!%{_bindir}/env python|#!%{_bindir}/python3|g" {} \;
%build
%python3_build
%install
%python3_install
install -d %{buildroot}%{_sbindir}
install -d %{buildroot}%{_sysconfdir}/supervisord.d
install -D -m 0644 %{SOURCE4} %{buildroot}/%{_tmpfilesdir}/supervisord.conf
install -D -m 0644 %{SOURCE3} %{buildroot}%{_unitdir}/supervisord.service
install -d -m 0750 %{buildroot}%{_localstatedir}/log/supervisord/
install -m 0660 %{SOURCE2} %{buildroot}%{_sysconfdir}/
install -d %{buildroot}%{_sbindir}/
ln -s service %{buildroot}%{_sbindir}/rcsupervisord
%fdupes %{buildroot}%{python_sitelib}/
%pre
%service_add_pre supervisord.service
%post
%service_add_post supervisord.service
%tmpfiles_create %{_tmpfilesdir}/supervisord.conf
%preun
%service_del_preun supervisord.service
%postun
%service_del_postun supervisord.service
%if %{with tests}
%check
# [ 13s] > self.assertEqual(sock.listen_backlog, socket.SOMAXCONN)
# [ 13s] E AssertionError: 128 != 4096
# somaxconn have changed recently, as far as I remember
sed -i '/self.assertEqual(sock.listen_backlog, socket.SOMAXCONN)/d' supervisor/tests/test_socket_manager.py
pytest
%endif
%files
%license LICENSES.txt COPYRIGHT.txt
%doc README.rst CHANGES.rst
%{_bindir}/echo_supervisord_conf
%{_bindir}/pidproxy
%{_bindir}/supervisorctl
%{_bindir}/supervisord
%{python3_sitelib}/supervisor/
%{python3_sitelib}/supervisor-%{version}*-info/
%{_tmpfilesdir}/supervisord.conf
%{_unitdir}/supervisord.service
%{_sbindir}/rcsupervisord
%config(noreplace) %{_sysconfdir}/supervisord.conf
%dir %{_sysconfdir}/supervisord.d
%dir %attr(750,root,root) %{_localstatedir}/log/supervisord
%changelog