File python-django-pyscss.spec of Package python-django-pyscss
#
# spec file for package python-django-pyscss
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-django-pyscss
Version: 2.0.2
Release: 0
Summary: Makes it easier to use PySCSS in Django
License: BSD-2-Clause
Group: Development/Languages/Python
Url: https://github.com/fusionbox/django-pyscss
Source: https://pypi.python.org/packages/source/d/django-pyscss/django-pyscss-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-pyScss >= 1.2.0
BuildRequires: python-setuptools
Requires: python-django >= 1.4
Requires: python-pathlib
Requires: python-pyScss >= 1.3.4
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
This app smooths over a lot of things when dealing with pyScss in Django. It
- Overwrites the import system to use Django's staticfiles app. This way you
can import SCSS files from any app (or any file that's findable by the
STATICFILES_FINDERS) with no hassle.
- Configures pyScss to work with the staticfiles app for it's image functions
(e.g. inline-image and sprite-map).
- It provides a django-compressor precompile filter class so that you can
easily use pyScss with django-compressor without having to bust out to the
shell. This has the added benefit of removing the need to configure pyScss
through its command-line arguments AND makes it possible for the exceptions
and warnings that pyScss emits to bubble up to your process so that you can
actually know what's going on.
%prep
%setup -q -n django-pyscss-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc README.rst LICENSE
%{python_sitelib}/*
%changelog