File python-neutron-lib.spec of Package python-neutron-lib
#
# spec file for package python-neutron-lib
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global sname neutron-lib
Name: python-neutron-lib
Version: 1.18.0
Release: 0
Summary: OpenStack Neutron library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/developer/neutron-lib/
Source0: https://files.pythonhosted.org/packages/source/n/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-SQLAlchemy >= 1.0.10
BuildRequires: python-debtcollector
BuildRequires: python-devel
BuildRequires: python-fixtures
BuildRequires: python-keystoneauth1 >= 3.4.0
BuildRequires: python-os-api-ref
BuildRequires: python-oslo.concurrency >= 3.26.0
BuildRequires: python-oslo.config >= 5.2.0
BuildRequires: python-oslo.context >= 2.19.2
BuildRequires: python-oslo.db >= 4.27.0
BuildRequires: python-oslo.i18n >= 3.15.3
BuildRequires: python-oslo.log >= 3.36.0
BuildRequires: python-oslo.messaging >= 5.29.0
BuildRequires: python-oslo.policy >= 1.30.0
BuildRequires: python-oslo.service >= 1.24.0
BuildRequires: python-oslo.utils >= 3.33.0
BuildRequires: python-oslotest
BuildRequires: python-osprofiler >= 1.4.0
BuildRequires: python-pbr >= 2.0.0
BuildRequires: python-pecan >= 1.0.0
BuildRequires: python-pep8
BuildRequires: python-python-subunit
BuildRequires: python-setuptools
BuildRequires: python-stestr
BuildRequires: python-testrepository
BuildRequires: python-testresources
BuildRequires: python-testscenarios
BuildRequires: python-testtools
BuildRequires: python-weakrefmethod >= 1.0.2
Requires: python-SQLAlchemy >= 1.0.10
Requires: python-debtcollector
Requires: python-keystoneauth1 >= 3.4.0
Requires: python-oslo.concurrency >= 3.26.0
Requires: python-oslo.config >= 5.2.0
Requires: python-oslo.context >= 2.19.2
Requires: python-oslo.db >= 4.27.0
Requires: python-oslo.i18n >= 3.15.3
Requires: python-oslo.log >= 3.36.0
Requires: python-oslo.messaging >= 5.29.0
Requires: python-oslo.policy >= 1.30.0
Requires: python-oslo.service >= 1.24.0
Requires: python-oslo.utils >= 3.33.0
BuildArch: noarch
%description
OpenStack Neutron library shared by all Neutron sub-projects.
%package doc
Summary: OpenStack Neutron library documentation
Group: Documentation/HTML
BuildRequires: python-Sphinx
BuildRequires: python-openstackdocstheme
BuildRequires: python-reno
%description doc
OpenStack Neutron library shared by all Neutron sub-projects.
%prep
%autosetup -n neutron-lib-%{version}
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%build
%{py2_build}
%install
%{py2_install}
# Build HTML docs and man page
PBR_VERSION=%{version} sphinx-build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
rm -rf .testrepository
stestr init
stestr run
%files
%license LICENSE
%doc README.rst
%{python2_sitelib}/neutron_lib
%{python2_sitelib}/neutron_lib*egg-info
%files doc
%doc doc/build/html
%license LICENSE
%changelog