File python-path.py.spec of Package python-path.py

#
# spec file for package python-path.py
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-path.py
Version:        10.3.1
Release:        0
Summary:        A module wrapper for os.path
License:        MIT
Group:          Development/Languages/Python
Url:            https://github.com/jaraco/path.py
Source:         https://files.pythonhosted.org/packages/source/p/path.py/path.py-%{version}.tar.gz
BuildRequires:  %{python_module base}
BuildRequires:  %{python_module pytest-runner >= 2.6}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module setuptools_scm}
BuildRequires:  %{python_module setuptools}
BuildRequires:  python-rpm-macros
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%python_subpackages

%description
The path.py package implements a path objects as first-class
entities, allowing common operations on files to be invoked
on those path objects directly.

%prep
%setup -q -n path.py-%{version}
rm -rf path.py.egg-info

%build
%python_build

%install
%python_install

%check
# need to set locale to avoid UnicodeEncodeError
export LANG=en_US.UTF-8
%python_exec %{_bindir}/py.test build/lib

%files %{python_files}
%defattr(-,root,root,-)
%doc CHANGES.rst README.rst
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by