File python-pyroute2.spec of Package python-pyroute2
#
# spec file for package python-pyroute2
#
# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-pyroute2
Version: 0.5.2
Release: 0
Summary: Python Netlink library
License: GPL-2.0-or-later OR Apache-2.0
Group: Development/Languages/Python
Url: https://github.com/svinota/pyroute2
Source: https://files.pythonhosted.org/packages/source/p/pyroute2/pyroute2-%{version}.tar.gz
BuildRequires: %{python_module devel}
BuildRequires: python-rpm-macros
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
Pyroute2 is a pure Python **netlink** and Linux **network configuration**
library. It requires only Python stdlib, no 3rd party libraries.
Later it can change, but the deps tree will remain as simple, as
it is possible.
The library provides several modules:
* Netlink protocol implementations (RTNetlink, TaskStats, etc)
* **rtnl**, network settings --- addresses, routes, traffic controls
* **nl80211** --- wireless functions API (work in progress)
* **nfnetlink** --- netfilter API: **ipset** (work in progress), ...
* **ipq** --- simplest userspace packet filtering, iptables QUEUE target
* **taskstats** --- extended process statistics
* Simple netlink socket object, that can be used in poll/select
* Network configuration module IPRoute provides API that in some
way resembles ip/tc functionality
* IPDB is an async transactional database of Linux network settings
%prep
%setup -q -n pyroute2-%{version}
%build
%python_build
%install
%python_install
%files %{python_files}
%defattr(-,root,root,-)
%doc README.make.md README.packages.md README.md LICENSE.Apache.v2 CHANGELOG.md LICENSE.GPL.v2 README.license.md
%{python_sitelib}/*
%changelog