File python-senlinclient.spec of Package python-senlinclient
#
# spec file for package python-senlinclient
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global sname python-senlinclient
Name: python-senlinclient
Version: 1.8.0
Release: 0
Summary: Python API and CLI for OpenStack Senlin
License: Apache-2.0
Group: Development/Languages/Python
URL: https://launchpad.net/%{sname}
Source0: https://files.pythonhosted.org/packages/source/p/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-Babel >= 2.3.4
BuildRequires: python-PrettyTable >= 0.7.2
BuildRequires: python-PyYAML >= 3.12
BuildRequires: python-appdirs
BuildRequires: python-devel
BuildRequires: python-fixtures
BuildRequires: python-heatclient >= 1.10.0
BuildRequires: python-jsonschema
BuildRequires: python-mock
BuildRequires: python-openstackclient
BuildRequires: python-openstacksdk >= 0.11.2
BuildRequires: python-os-testr
BuildRequires: python-osc-lib >= 1.8.0
BuildRequires: python-oslo.i18n >= 3.15.3
BuildRequires: python-oslo.serialization >= 2.18.0
BuildRequires: python-oslo.utils >= 3.33.0
BuildRequires: python-oslotest
BuildRequires: python-pbr >= 2.0.0
BuildRequires: python-python-subunit
BuildRequires: python-requests >= 2.14.2
BuildRequires: python-requests-mock
BuildRequires: python-stestr
BuildRequires: python-testtools
Requires: python-PrettyTable >= 0.7.2
Requires: python-PyYAML >= 3.12
Requires: python-appdirs
Requires: python-heatclient >= 1.10.0
Requires: python-jsonschema
Requires: python-keystoneauth1 >= 3.4.0
Requires: python-openstackclient
Requires: python-openstacksdk >= 0.11.2
Requires: python-osc-lib >= 1.8.0
Requires: python-oslo.i18n >= 3.15.3
Requires: python-oslo.serialization >= 2.18.0
Requires: python-oslo.utils >= 3.33.0
Requires: python-pbr >= 2.0.0
Requires: python-requests >= 2.14.2
Requires: python-six >= 1.10.0
BuildArch: noarch
%description
OpenStack Clustering service Provisioning API Client Library
This is a client for the OpenStack Senlin API.
It provides a Python API (the senlinclient module).
%package doc
Summary: Documentation for OpenStack Senlin API Client
Group: Documentation/HTML
BuildRequires: python-Sphinx
BuildRequires: python-openstackdocstheme
BuildRequires: python-reno
%description doc
This is a client for the OpenStack Senlin API.
It implements 100% of the OpenStack Senlin API. This package contains
auto-generated documentation.
%prep
%autosetup -n %{sname}-%{version}
%py_req_cleanup
%build
%{py2_build}
%{__python2} setup.py build_sphinx
PBR_VERSION=%version sphinx-build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py2_install}
%check
stestr run
%files
%license LICENSE
%doc README.rst
%{python2_sitelib}/senlinclient
%{python2_sitelib}/*.egg-info
%files doc
%license LICENSE
%doc doc/build/html
%changelog