File python-urllib3.spec of Package python-urllib3

#
# spec file for package python-urllib3
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define oldpython python
Name:           python-urllib3
Version:        1.23
Release:        0
Summary:        HTTP library with thread-safe connection pooling, file post, and more
License:        MIT
Group:          Development/Languages/Python
URL:            http://urllib3.readthedocs.org/
Source:         https://files.pythonhosted.org/packages/source/u/urllib3/urllib3-%{version}.tar.gz
# PATCH-FIX-UPSTREAM -- tornado 5.x support for tests
Patch1:         1414.patch
# PATCH-FEATURE-UPSTREAM -- use set_default_verify_paths() if no certificate path is supplied
# should be removed in the future, see SR#437853
Patch2:         urllib3-ssl-default-context.patch
# PATCH-FIX-OPENSUSE -- do not use unsupported SSLv3 in tests
Patch3:         urllib3-test-ssl-drop-sslv3.patch
# PATCH-FIX-UPSTREAM python-urllib3-recent-date.patch gh#shazow/urllib3#1303, boo#1074247 dimstar@opensuse.org -- Fix test suite, use correct date
Patch4:         python-urllib3-recent-date.patch
# PATCH-FIX-UPSTREAM urllib3-disallow-control-chars-in-http-urls.patch, boo#1129071 -- Disallow control chars in http URLs
Patch5:         urllib3-disallow-control-chars-in-http-urls.patch
# PATCH-FIX-UPSTREAM boo#1132900 --  Don't load system certs unless there were no CA certs or
# SSLContext object specified manually.
Patch6:         urllib3-cve-2019-11324.patch
BuildRequires:  %{python_module PySocks}
BuildRequires:  %{python_module mock >= 1.3.0}
BuildRequires:  %{python_module psutil}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module tornado >= 4.2.1}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
#!BuildIgnore:  python-requests
BuildArch:      noarch
Requires:       python-six
%if 0%{?suse_version} >= 1000 || 0%{?fedora_version} >= 24
Recommends:     ca-certificates-mozilla
Recommends:     python-cryptography
Recommends:     python-idna
Recommends:     python-ndg-httpsclient
Recommends:     python-pyOpenSSL
%endif
# for SSL module on older distros
BuildRequires:  %{oldpython}
BuildRequires:  python2-ipaddress
%ifpython2
Requires:       python-ipaddress
%endif
%python_subpackages

%description
Highlights

- Re-use the same socket connection for multiple requests
  (HTTPConnectionPool and HTTPSConnectionPool)
  (with optional client-side certificate verification).
- File posting (encode_multipart_formdata).
- Built-in redirection and retries (optional).
- Supports gzip and deflate decoding.
- Thread-safe and sanity-safe.
- Works with AppEngine, gevent, and eventlib.
- Tested on Python 2.6+ and Python 3.3+, 100% unit test coverage.
- Small and easy to understand codebase perfect for extending and building upon.
  For a more comprehensive solution, have a look at
  Requests which is also powered by urllib3.

%prep
%setup -q -n urllib3-%{version}
%patch1 -p1
%patch2 -p1
%if %(python3 -c "import ssl; print(hasattr(ssl,'PROTOCOL_TLSv1_2'))") == "True"
%patch3 -p1
%endif
%patch4 -p1
%patch5 -p1
%patch6 -p1
find . -type f -exec chmod a-x '{}' \;

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check

skiplist='not test_select_interrupt_exception and not test_selector_error and not timeout and not test_request_host_header_ignores_fqdn_dot and not test_dotted_fqdn'
case $(uname -m) in
ppc*)
skiplist="$skiplist and not test_select_timing and not test_select_multiple_interrupts_with_event and not test_interrupt_wait_for_read_with_event and not test_select_interrupt_with_event";;
esac

# we have patch to fix source address errors in python and raise different
# error than urllib3 expects in its tests
skiplist="$skiplist and not test_source_address_error"

rm -rf build
# pretend to be TRAVIS (this triggers timing tolerance)
export TRAVIS=1
%{python_expand PYTHONPATH="%{buildroot}%{$python_sitelib}" py.test-%$python_bin_suffix \
                --ignore=test/appengine \
                --ignore=test/with_dummyserver/test_proxy_poolmanager.py \
                --ignore=test/with_dummyserver/test_poolmanager.py \
                -k "${skiplist}" \
                urllib3 test}

%files %{python_files}
%license LICENSE.txt
%doc CHANGES.rst CONTRIBUTORS.txt README.rst
%{python_sitelib}/urllib3
%{python_sitelib}/urllib3-%{version}-py*.egg-info

%changelog
openSUSE Build Service is sponsored by