File blender.spec of Package blender

#
# spec file for package blender
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define collada 1
%define wplayer 1
%define documentation 0

# Use rpmbuild -D 'DISTRIBUTABLE 0' to build original code.
%define DISTRIBUTABLE 1

Name:           blender
Version:        2.69
Release:        0
%define _version 2.69
Summary:        A 3D Modelling And Rendering Package
License:        GPL-2.0+
Group:          Productivity/Graphics/3D Editors
Url:            http://www.blender.org/
# http://download.blender.org/source/
Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
Source2:        geeko.blend
Source3:        geeko.README
Source4:        blender-sample
Source6:        blender.xpm
Source7:        x-blend.desktop
Source8:        blender-getversion.py
# Fixed and refreshed for 2.67b.
Patch0:         blender-2.64a-fix-locale-files-path.patch
# Refreshed for 2.67b
Patch1:         blender-2.58-python_include.patch
BuildRequires:  gettext-tools
%if 0%{?suse_version} > 1210
BuildRequires:  libGLw-devel
%else
BuildRequires:  MesaGLw-devel
%endif
BuildRequires:  libexpat-devel
BuildRequires:  pkg-config
BuildRequires:  python3-devel
BuildRequires:  update-desktop-files
BuildRequires:  xorg-x11
%if %documentation == 1
Recommends:     blender-doc
%endif
# libquicktime-devel
BuildRequires:  OpenEXR-devel
BuildRequires:  SDL-devel
BuildRequires:  boost-devel
BuildRequires:  cmake
BuildRequires:  desktop-file-utils
BuildRequires:  doxygen
BuildRequires:  epydoc
BuildRequires:  fdupes
BuildRequires:  fftw3-devel
BuildRequires:  gcc-c++
BuildRequires:  glew-devel
BuildRequires:  graphviz
BuildRequires:  help2man
BuildRequires:  hicolor-icon-theme
BuildRequires:  jack-audio-connection-kit-devel
BuildRequires:  libao-devel
BuildRequires:  libdrm-devel
BuildRequires:  libjpeg-devel
BuildRequires:  liblcms-devel
BuildRequires:  libpng-devel
BuildRequires:  libsamplerate-devel
BuildRequires:  libsndfile-devel
BuildRequires:  libspnav-devel
BuildRequires:  libtiff-devel
BuildRequires:  libtool
BuildRequires:  libvorbis-devel
BuildRequires:  lzo-devel
BuildRequires:  openal-soft-devel
BuildRequires:  openssl-devel
BuildRequires:  pcre-devel
BuildRequires:  perl-Text-Iconv
BuildRequires:  ruby
BuildRequires:  ruby-devel
BuildRequires:  shared-mime-info
BuildRequires:  xorg-x11-devel
BuildRequires:  xz
BuildRequires:  xz-devel
BuildRequires:  yasm
BuildRequires:  yasm-devel
BuildRequires:  pkgconfig(glu)
BuildRequires:  pkgconfig(libxml-2.0)
%if 0%{?collada} == 1
BuildRequires:  openCOLLADA-devel >= svn838
%endif
BuildRequires:  graphviz
BuildRequires:  liblcms-devel
# See bnc#713346
Requires:       libspnav
Requires:       python3-xml
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Blender is a 3D modelling and rendering package. It is the in-house
software of a high quality animation studio, Blender has proven to
be an extremely fast and versatile design instrument. The software
has a personal touch, offering a unique approach to the world of
Three Dimensions. Use Blender to create TV commercials, to make
technical visualizations, business graphics, to do some morphing,
or design user interfaces. You can easy build and manage complex
environments. The renderer is versatile and extremely fast. All
basic animation principles (curves & keys) are well implemented.It
includes tools for modeling, sculpting, texturing (painting,
node-based shader materials, or UV mapped), UV mapping, rigging and
constraints, weight painting, particle systems, simulation (fluids,
physics, and soft body dynamics and an external crowd simulator),
rendering, node-based compositing, and non linear video editing,
as well as an integrated game engine for real-time interactive 3D
and game creation and playback with cross-platform compatibility.

%if %documentation == 1
%package doc
Summary:        Documentation for blender
Group:          Documentation
BuildArch:      noarch

%description doc
Being the in-house software of a high quality animation studio, Blender
has proven to be an extremely fast and versatile design instrument. The
software has a personal touch, offering a unique approach to the world
of Three Dimensions. Use Blender to create TV commercials, to make
technical visualizations, business graphics, to do some morphing, or
design user interfaces.
This package includes API documentation and example plugin programs.
%endif

%lang_package

%prep
%setup -q
%patch0
%patch1

%if %DISTRIBUTABLE == 1
rm -rf release/scripts/presets/ffmpeg
%endif

# binreloc is not a part of fedora
rm -rf extern/ffmpeg
rm -rf extern/fftw
rm -rf extern/glew
rm -rf extern/libmp3lame
rm -rf extern/libopenjpeg
rm -rf extern/libredcode
rm -rf extern/ode
rm -rf extern/x264
rm -rf extern/xvidcore
rm -rf extern/qhull
rm -rf extern/make
rm -rf extern/verse

%build
mkdir -p Build && pushd Build
cmake ../ -DBUILD_SHARED_LIBS:BOOL=off \
      -DWITH_FFTW3:BOOL=on \
      -DWITH_JACK:BOOL=on \
      -DWITH_CODEC_SNDFILE:BOOL=on \
      -DWITH_IMAGE_OPENJPEG:BOOL=off \
      -DWITH_OPENCOLLADA:BOOL=on \
      -DWITH_PYTHON:BOOL=on \
      -DWITH_PYTHON_INSTALL:BOOL=off \
      -DWITH_GAMEENGINE:BOOL=ON \
      -DWITH_BF_3DMOUSE:BOOL=ON \
      -DWITH_CYCLES:BOOL=OFF \
      -DWITH_PLAYER:BOOL=on \
      -DWITH_INSTALL_PORTABLE:BOOL=OFF \
      -DWITH_BUILTIN_GLEW:BOOL=OFF \
%ifnarch x86_64
      -DSUPPORT_SSE2_BUILD=false \
%endif
      -DWITH_MOD_OCEANSIM:BOOL=OFF \
%if 0%{?suse_version} > 1220 || 0%{?sles_version}
      -DPYTHON_VERSION=3.3 \
      -DPYTHON_LIBPATH=/usr/lib \
      -DPYTHON_LIBRARY=python3.3m \
      -DPYTHON_INCLUDE_DIRS=/usr/include/python3.3m \
%endif
      -DCMAKE_VERBOSE_MAKEFILE=on \
      -DCMAKE_C_FLAGS="$RPM_OPT_FLAGS" \
      -DCMAKE_CXX_FLAGS="$RPM_OPT_FLAGS" \
      -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix}

make %{?_smp_mflags}
popd

%if %documentation == 1
# Build documentation
pushd doc/doxygen
doxygen -u Doxyfile
doxygen Doxyfile
popd
mv doc/doxygen/html doc/
rm -rf doc/doxygen
%endif

%install
export blender_version=$(grep BLENDER_VERSION source/blender/blenkernel/BKE_blender.h | tr -dc 0-9)
export blender_version=$(expr $blender_version / 100).$(expr $blender_version % 100)
%define rlversion %(echo $blender_version)
echo "release version = $blender_version"
echo "rlversion is %{?rlversion}"

# make install
pushd Build
%make_install
popd

# Remove folder, it's not supposed to be installed here.
rm -rf %{buildroot}%{_datadir}/%{name}/%{_version}/datafiles/fonts

# Factory is now of the opinion that every /usr/bin file needs a man page,
%if %wplayer == 1
# Generate man page with help2man
pushd %{buildroot}%{_mandir}/man1
cp -v %{buildroot}%{_bindir}/blenderplayer ./
help2man \
	--version-string="%{version}" \
	--help-option="-h" -n "a utility for previewing .blend files" \
	-s 1 -m "User Commands" -S "Stichting Blender Foundation" -N -o blenderplayer.1 ./'blenderplayer -h ""'
rm blenderplayer
popd
#cp -v %%{SOURCE5} %%{buildroot}%%{_mandir}/man1
%endif

# Fix any .py files with shebangs and wrong permissions.
if test -z `find %{buildroot} -name *.py -perm 0644 -print0|xargs -0r grep -l '#!'`; \
then break;
else chmod -f 0755 `find %{buildroot} -name *.py -perm 0644 -print0|xargs -0r grep -l '#!'`; \
fi

# Copy text files to correct place.
mkdir -p %{buildroot}%{_docdir}/%{name}
cp -v    %{buildroot}%{_datadir}/doc/blender/* %{buildroot}%{_docdir}/%{name}/
rm -rf %{buildroot}%{_datadir}/doc/blender
# install blender sample.
install -D -m 0644 %{SOURCE2} %{buildroot}%{_docdir}/%{name}/
install -D -m 0644 %{SOURCE3} %{buildroot}%{_docdir}/%{name}/
install -D -m 0755 %{SOURCE4} %{buildroot}%{_bindir}/

%if 1 == 1
# Add more icons.
mkdir -p %{buildroot}%{_datadir}/pixmaps/
pushd %{buildroot}%{_datadir}/pixmaps/
ln -s ../icons/hicolor/32x32/apps/blender.png blender.png
popd

# Install s6=blender.xpm and s11=v-2.55
install -D -m 0644 %{SOURCE6} %{buildroot}%{_datadir}/pixmaps/

ln -s ../icons/hicolor/scalable/apps/blender.svg %{buildroot}%{_datadir}/pixmaps
%endif

# Install s6=blender.xpm
install -D -m 0644 %{SOURCE6} %{buildroot}%{_datadir}/pixmaps/

%if 0%{?sles_version}
%suse_update_desktop_file -i -n -G "Blender Template" x-blend
%suse_update_desktop_file -i -n blender
%else

# Install blender template desktop file.
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE7}

# Validate blender.desktop
desktop-file-validate %{buildroot}%{_datadir}/applications/blender.desktop
%endif

if test -z `find %{buildroot}%{_docdir}/%{name} -name *.py -perm 0755 -print0|xargs -0r grep -l '#!'`; \
then break;
else chmod -f 0644 `find %{buildroot}%{_docdir}/%{name} -name *.py -perm 0755 -print0|xargs -0r grep -l '#!'`; \
fi

%fdupes %{buildroot}%{_datadir}/%{name}/%{_version}/scripts/

%find_lang %{name} %{?no_lang_C}
rm -rf %{buildroot}%{_datadir}/locale/languages

%post
update-desktop-database &> /dev/null || :
update-mime-database %{_datadir}/mime &> /dev/null || :
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :

%postun
update-desktop-database &> /dev/null || :
update-mime-database %{_datadir}/mime &> /dev/null || :
if [ $1 -eq 0 ] ; then
    touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi

%posttrans
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :

%files lang -f %{name}.lang

%files
%defattr (-, root, root)
%{_bindir}/*
%{_mandir}/man1/*
%{_datadir}/%{name}
%{_datadir}/applications/blender.desktop
%{_datadir}/applications/x-blend.desktop
%{_datadir}/icons/hicolor/*/apps/blender.png
%{_datadir}/icons/hicolor/scalable/apps/blender.svg
%{_datadir}/pixmaps/blender.svg
%{_datadir}/pixmaps/blender.xpm
%{_datadir}/pixmaps/blender.png
#%%exclude %%{_datadir}/%%{name}%%{rlversion}/datafiles/locale
%if %documentation == 0
%doc %{_docdir}/%{name}
%else

%files doc
%defattr (-, root, root)
%doc doc/
%endif

%changelog
openSUSE Build Service is sponsored by