File peertube.spec of Package peertube
#
# spec file for package peertube
#
# Copyright (c) 2022 Georg Pfuetzenreuter
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define appdir /srv/www/%{name}
%define modules_dir node_modules
%define appnameUpper PeerTube
Name: peertube
Version: 4.0.0
Release: 0
Summary: Decentralized and federated video platform
License: AGPL-3.0-only
URL: https://github.com/Chocobozzz/PeerTube
Source0: _service
Source1: node_modules.tgz
Source2: system-user-peertube.conf
Patch0: peertube-service.patch
#BuildArch: noarch
BuildRequires: fdupes
BuildRequires: rsync
BuildRequires: systemd-rpm-macros
BuildRequires: sysuser-tools
Requires: nodejs
Requires(pre): system-user-%{name}
Requires: user(peertube)
Requires: group(peertube)
%description
PeerTube is a free, decentralized and federated video platform developed as an
alternative to other platforms that centralize our data and attention, such as
YouTube, Dailymotion or Vimeo.
%prep
%autosetup -p1 -DTn %{_sourcedir}/%{appnameUpper}-%{version}
tar -xzf %{SOURCE1}
find . \( -name '.*' -o -name 'prebuilds' \) -type d -mindepth 1 -exec rm -r {} +
find . \( -name '.*' -o -name '*.bak' -o -name '*.h' -o -name '*.c' -o -name '*.cpp' -o -name '*.a' -o -name '*.o' -o -name '*.mli' -o -name '*\~' \) -type f -delete
grep -Elr '#!\s?/usr/bin/env|#!/bin/bash|#!/bin/sh' | xargs sed -i "1,2{\/bin/d}"
find . -type f -perm /007 -execdir chmod -x {} +
rm client/node_modules/open/xdg-open node_modules/open/xdg-open client/node_modules/chromedriver/lib/chromedriver/chromedriver client/node_modules/esbuild-linux-64/bin/esbuild client/node_modules/nice-napi/build/Release/obj.target/nice_napi.node
rm -r client/node_modules/geckodriver/geckodriver 'client/node_modules/postcss-initial/~/'
%build
%sysusers_generate_pre %{SOURCE2} %{name} system-user-%{name}.conf
%install
install -d %{buildroot}%{appdir}/{config,storage,versions,versions/%{name}-%{version}} %{buildroot}%{_sysusersdir} %{buildroot}/%{_unitdir} %{buildroot}%{_sbindir}
install -m0644 %{SOURCE2} %{buildroot}%{_sysusersdir}
install -m0644 support/systemd/%{name}.service %{buildroot}/%{_unitdir}
ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}
rsync --min-size=1 -r %{modules_dir} client config server server.ts shared yarn.lock %{buildroot}%{appdir}/versions/%{name}-%{version}/
pushd %{buildroot}%{appdir}/versions/
ln -s %{name}-%{version} %{name}-latest
popd
strip %{buildroot}%{appdir}/versions/%{name}-%{version}/node_modules/bcrypt/lib/binding/napi-v3/bcrypt_lib.node
%fdupes %{buildroot}%{appdir}
%pre
%service_add_pre %{name}.service
%post
%service_add_post %{name}.service
%preun
%service_del_preun %{name}.service
%postun
%service_del_postun %{name}.service
%files
%license LICENSE
%doc CREDITS.md CHANGELOG.md FAQ.md README.md
%dir %{appdir}
%dir %{appdir}/versions
%dir %{appdir}/storage
%dir %attr(0750, peertube, peertube) %{appdir}/config
%{appdir}/versions/%{name}-%{version}/
%{appdir}/versions/%{name}-latest
%{_unitdir}/%{name}.service
%{_sbindir}/rc%{name}
%package -n system-user-peertube
Summary: System user and group peertube
Group: System/Fhs
Provides: user(peertube)
Provides: group(peertube)
BuildArch: noarch
%sysusers_requires
%description -n system-user-peertube
This package provides the system account and group 'peertube'.
%pre -n system-user-peertube
/usr/sbin/sysusers2shadow system-user-%{name}.conf <<'EOF' || [ -f /.buildenv ]
u peertube - "PeerTube" /srv/www/peertube -
EOF
%files -n system-user-peertube
%{_sysusersdir}/system-user-peertube.conf
%changelog