File dba-postgresql-842.spec of Package dba-postgresql-842

#
# spec file for package postgresql (Version 8.4.2)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define maketest 0

%define real_name       postgresql
%define version         8.4.2
%define vers            842
%define prefix          /DBA/postgresql/%{version}
%define pg_minor_version %(echo %version | cut -f1-2 -d.)

Name:           dba-postgresql-%{vers}
Summary:       	The Programs Needed to Create and Run a PostgreSQL Server
Version:        %{version}
Release:        1
License:        BSD 3-clause (or similar)
Group:          Productivity/Databases/Tools
Url:            http://www.postgresql.org/
Source0:        postgresql-%version.tar.bz2
Source2:        postgresql-README.SuSE.de
Source3:        postgresql-README.SuSE.en
Source8:        postgresql-sysconfig
Source9:        postgresql-init
Source15:       postgresql-bashprofile
Source16:       postgresql-firewall
Source17:       postgresql-rpmlintrc
Source99:       postgresql-pl.spec
Patch1:         postgresql-conf.patch
Patch2:         postgresql-regress.patch
BuildRoot:      %{_tmppath}/%{real_name}-%{version}-build

BuildRequires:  bison flex gettext-devel libxslt-devel
BuildRequires:  openldap2-devel openssl-devel pam-devel readline-devel zlib-devel
BuildRequires:  ncurses-devel
PreReq:         sh-utils fileutils
Requires:       glibc-locale

%if 0%{?sles_version} != 9
BuildRequires:  krb5-devel
%endif

%if 0%{?suse_version} >= 1100
BuildRequires:          -post-build-checks
%endif


%description
PostgreSQL is an advanced object-relational database management system
that supports an extended subset of the SQL standard, including
transactions, foreign keys, subqueries, triggers, and user-defined
types and functions.

This package contains the basic utility and client programs necessary
to maintain and work with local or remote PostgreSQL databases as well
as manual pages for the SQL commands that PostgreSQL supports. Full
HTML documentation for PostgreSQL can be found in the postgresql-docs
package.



Authors:
--------
    Marc G. Fournier <scrappy@hub.org>
    Tom Lane <tgl@sss.pgh.pa.us>
    Vadim B. Mikheev <vadim4o@yahoo.com>
    Bruce Momjian <pgman@candle.pha.pa.us>
    Jan Wieck <JanWieck@Yahoo.com>


%prep
%setup -q -n %{real_name}-%{version}
%patch1
%patch2


%build
export CFLAGS="%optflags $SP"
# uncomment the following line to enable the stack protector
CFLAGS="$CFLAGS -fstack-protector"
./configure \
	--prefix=%prefix \
	--includedir=%_includedir/pgsql \
	--datadir=%_datadir/postgresql \
	--mandir=%_mandir \
	--with-docdir=%_docdir \
	--disable-rpath \
	--enable-nls \
	--enable-thread-safety \
	--enable-integer-datetimes \
	--without-python \
	--with-perl \
	--without-tcl \
	--with-openssl \
	--with-pam \
	--with-krb5 \
	--with-gssapi \
	--with-ldap \
	--with-libxml \
	--with-libxslt \
	--with-system-tzdata=/usr/share/zoneinfo
make %{?jobs:-j%jobs} all
make %{?jobs:-j%jobs} -C contrib all

%ifnarch %arm

%check
#
# Run the regression tests.
#
%if %maketest
make check || {
  for f in log/* regression.diffs; do
    if test -f $f; then
        echo ==== $f ====================
    fi
  done
  echo ==============================
  exit 1
}
%endif
%endif


%install
make DESTDIR=%buildroot install
%{__mkdir_p} %{buildroot}%{prefix}/doc
%{__mkdir_p} %{buildroot}%{prefix}/samples
%{__mkdir_p} %{buildroot}%{prefix}/man
%{__mkdir_p} %{buildroot}%{prefix}/include
# Don't ship static libraries.
rm -v %buildroot/%{prefix}/lib/*.a
#
# Install and collect the contrib stuff
#
touch flag; sleep 1 # otherwise we have installed files that are not newer than flag
make DESTDIR=%buildroot -C contrib install
find %buildroot -type f -cnewer flag -printf "/%%P\n" |
     grep -v %_docdir > files.contrib
rm flag

#for f in /etc/init.d /var/adm/fillup-templates /usr/sbin \
#         /etc/sysconfig/SuSEfirewall2.d/services
#do
#%{__install} -D -m 0644 $f %{buildroot}%{prefix}/samples
#done

install -m 755 %{SOURCE9} %{buildroot}%{prefix}/samples/postgresql.init
install -m 644 %{SOURCE8} %{buildroot}%{prefix}/samples/sysconfig.postgresql

%if 0%suse_version > 1020
install -m 644 %{SOURCE16} %{buildroot}%{prefix}/samples/postgresql.firewall
%endif

cp doc/KNOWN_BUGS doc/MISSING_FEATURES doc/README* COPYRIGHT \
   README HISTORY doc/bug.template %{buildroot}%{prefix}/doc

cp -a %SOURCE2 %{buildroot}%{prefix}/doc/README.SuSE.de
cp -a %SOURCE3 %{buildroot}%{prefix}/doc/README.SuSE.en

# move man pages
if test -d %{buildroot}%{_mandir}; then
  %{__mv} %{buildroot}%{_mandir}/man* %{buildroot}%{prefix}/man/
  %{__rm} -rf %{buildroot}%{_mandir}
fi

# move include files
if test -d %{buildroot}/usr/include/pgsql; then
  %{__mv} %{buildroot}/usr/include/pgsql %{buildroot}%{prefix}/include/
  %{__rm} -rf %{buildroot}/usr/include
fi

# doc files
if test -d %{buildroot}%{_docdir}/postgresql; then
  %{__mv} %{buildroot}%{_docdir}/postgresql/* %{buildroot}%{prefix}/doc/
  %{__rm} -rf %{buildroot}%{_docdir}
fi
if test -d %{buildroot}/usr/share/postgresql; then
  %{__cp} -rv %{buildroot}/usr/share/postgresql/* %{buildroot}%{prefix}/doc/
  %{__rm} -rf %{buildroot}/usr/share/postgresql
fi


%clean
rm -rf %buildroot
rm -f %my_provides


%files
%defattr(-,root,root)
%dir %{prefix}
%{prefix}/bin
%{prefix}/doc
%{prefix}/include
%{prefix}/lib
%{prefix}/man
%{prefix}/share
%{prefix}/samples


%changelog
* Fri Jan 22 2010 Holger Manthey <holger.manthey@bertelsmann.de>
- inital version
openSUSE Build Service is sponsored by