File perl-Email-MIME-Encodings.spec of Package perl-Email-MIME-Encodings
# norootforbuild
%define real_name Email-MIME-Encodings
%define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
%define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
%define perl_privlib %(eval "`perl -V:privlib`"; echo $privlib)
%define maketest 0
Name: perl-%{real_name}
Summary: A unified Interface to MIME Encoding and Decoding
Version: 1.313
Release: 1
License: Perl License
Group: Development/Libraries/Perl
URL: http://github.com/rjbs/email-mime-encodings
Source: %{real_name}-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl(Test::Pod::Coverage) >= 1.08
BuildRequires: perl(Test::Pod) >= 1.14
BuildRequires: perl(MIME::Base64)
Requires: perl(MIME::Base64)
BuildRequires: perl(ExtUtils::MakeMaker)
%if 0%{?fedora_version}
BuildRequires: perl-devel
%endif
%description
Email::MIME::Encodings - A unified interface to MIME encoding and decoding.
This module simply wraps "MIME::Base64" and "MIME::QuotedPrint" so that
you can throw the contents of a "Content-Transfer-Encoding" header at
some text and have the right thing happen.
%prep
%setup -q -n %{real_name}-%{version}
chmod -R u+rw %{_builddir}/%{real_name}-%{version}
%build
grep -rsl '^#!.*perl' . |
grep -v '.bak$' |xargs --no-run-if-empty \
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
CFLAGS="$RPM_OPT_FLAGS"
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.
9[1-6]|6\.0[0-5]/ '`
%{__make}
%check
%if %maketest
%{__make} test
%endif
%install
%if 0%{?suse_version}
%perl_make_install
%perl_process_packlist
%else
make DESTDIR=$RPM_BUILD_ROOT install_vendor
find $RPM_BUILD_ROOT/usr -type f -name perllocal.pod |xargs -i rm -f {}
find $RPM_BUILD_ROOT/usr -type d -depth -exec rmdir {} \; 2>/dev/null
%endif
find %{buildroot} -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" |xargs -i rm -f {}
find %{buildroot} -type f |xargs -i chmod 644 {}
%clean
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
%files
%defattr(-, root, root)
%doc Changes LICENSE README
%doc %{_mandir}/man?/*
%dir %{perl_vendorlib}/Email
%dir %{perl_vendorlib}/Email/MIME
%{perl_vendorlib}/Email/MIME/Encodings.pm
%if 0%{?suse_version}
/var/adm/perl-modules/%{name}
%endif
%changelog
* Thu May 31 2012 Holger Manthey <holger.manthey@bertelsmann.de>
- remove perl-version require
* Tue Jun 8 2010 Holger Manthey <holger.manthey@bertelsmann.de>
- Initial build.