File python3-distribute.spec of Package python-distribute

#
# spec file for package python3-distribute
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define modname distribute
%define mod2nam setuptools
Name:           python3-%{modname}
Version:        0.6.31
Release:        0
Url:            http://packages.python.org/distribute
Summary:        Easily download, build, install, upgrade, and uninstall Python packages
License:        Python-2.0 or ZPL-2.0
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/d/%{modname}/%{modname}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python3
BuildRequires:  python3-2to3
BuildRequires:  python3-devel
Provides:       python3-setuptools = %{version}
Obsoletes:      python3-setuptools < %{version}
BuildArch:      noarch
# rpm's autoreqprov should take care of this
#Requires:       python3 >= %{py3_ver}

%description
Distribute is a fork of the Setuptools project.

Distribute is intended to replace Setuptools as the standard method for working
with Python module distributions.

%prep
%setup -q -n %{modname}-%{version}

%build
python3 setup.py build
rm -f %{modname}.egg-info/*.orig
chmod -x {.,docs}/*.txt # Fix executable bits for documentation

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -rf %{buildroot}%{python3_sitelib}/%{mod2nam}/tests # Don't install tests
rm -rf %{buildroot}%{python3_sitelib}/%{mod2nam}/*.exe # Remove unneeded files
rm %{buildroot}%{_bindir}/easy_install # Remove the base file which is incompatible with the python2 package
if [ -d "%{buildroot}%{python3_sitelib}/__pycache__" ]; then
    rm -r %{buildroot}%{python3_sitelib}/__pycache__
fi

# not working with python 3
#%check
#python3 setup.py test

%files
%defattr(-,root,root,-)
%doc docs/*.txt CHANGES.txt CONTRIBUTORS.txt DEVGUIDE.txt README.txt
%{_bindir}/easy_install-%{py3_ver}
%{python3_sitelib}/easy_install.py*
%{python3_sitelib}/pkg_resources.py*
%{python3_sitelib}/%{mod2nam}.pth
%{python3_sitelib}/%{mod2nam}/
%{python3_sitelib}/site.py*
%{python3_sitelib}/%{modname}-%{version}-py%{py3_ver}.egg-info/
%{python3_sitelib}/%{mod2nam}-*-py%{py3_ver}.egg-info
%{python3_sitelib}/_markerlib

%changelog
openSUSE Build Service is sponsored by