File mnemosyne.spec of Package Mnemosyne
# Name: mnemosyne
# Summary: Flash-card learning tool
# Version: 1.1.1
# Release: 1
# Vendor: openSUSE-Education
# Source0: %{name}-%{version}-r1.tar.bz2
# Source1: %{name}.png
# Source2: %{name}.desktop
# Url: http://www.mnemosyne-proj.org/
# License: GPLv2 or later
# Group: Productivity/Other
# BuildRequires: python-devel python-setuptools
# %if 0%{?suse_version}
# BuildRequires: update-desktop-files
# %endif
# %{py_requires}
# Requires: pygame
# Requires: python-kde4
# BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-build
#
# %description
# Mnemosyne resembles a traditional flash-card program but with an
# important twist: it uses a sophisticated algorithm to schedule the best
# time for a card to come up for review.
#
# Author(s):
# ----------
# Jarno Elonen <elonen@iki.fi>
# Dirk Herrmann <dirk.herrmann-privat@gmx.de>
#
#
# %prep
# %setup -q
#
# %build
# env CFLAGS="%{optflags}" \
# %{__python} setup.py build
#
# %install
# %{__python} setup.py install \
# --root="%{buildroot}" \
# --prefix="%{_prefix}"
#
# install -Dm644 %{SOURCE1} %{buildroot}/%{_datadir}/pixmaps/%{name}.png
# install -Dm644 %{SOURCE2} %buildroot/%_datadir/applications/%{name}.desktop
# test -d %buildroot/%_datadir/icons && rm -rf %buildroot/%_datadir/icons
# %if 0%{?suse_version}
# %suse_update_desktop_file -i -n -r %{name} Education Languages
# %endif
#
# %clean
# rm -rf %{buildroot}
#
# %files
# %defattr(-,root,root,-)
# %doc AUTHORS ChangeLog LICENSE README
# %{_bindir}/%{name}
# %{py_sitedir}/%{name}
# %{py_sitedir}/Mnemosyne-%{version}-*.egg-info
# %{_datadir}/applications/%{name}.desktop
# %{_datadir}/pixmaps/%{name}.png
#
# %changelog