File u-boot-arndale.spec of Package u-boot-qemu-ppce500.16979

#
# spec file for package u-boot-arndale
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2010 Texas Instruments Inc by Nishanth Menon
# Copyright (c) 2007-2010 by Silvan Calarco <silvan.calarco@mambasoft.it>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define mvebu_spl 0
%define x_loader 0
%define rockchip_spl 0
%define sunxi_spl 0
%define arndale_spl 1
%define origen_spl 0
%define imx6_spl 0
%define socfpga_spl 0

%if "arndale" == "rpi" || "arndale" == "rpi2" || "arndale" == "rpi332b" || "arndale" == "rpi3"
%define is_rpi 1
%endif

# archive_version differs from version for RC version only
%define archive_version 2018.03

Name:           u-boot-arndale
Version:        2018.03
Release:        0
Summary:        The U-Boot firmware for the arndale platform
License:        GPL-2.0
Group:          System/Boot
Url:            http://www.denx.de/wiki/U-Boot
Source:         ftp://ftp.denx.de/pub/u-boot/u-boot-%{archive_version}.tar.bz2
Source1:        ftp://ftp.denx.de/pub/u-boot/u-boot-%{archive_version}.tar.bz2.sig
Source2:        arndale-bl1.img
Source3:        update_git.sh
Source300:      u-boot-rpmlintrc
Patch0001:      0001-XXX-openSUSE-XXX-Load-dtb-from-part.patch
Patch0002:      0002-Revert-Revert-omap3-Use-raw-SPL-by-.patch
Patch0003:      0003-Revert-rockchip-mkimage-remove-plac.patch
Patch0004:      0004-rpi-Use-firmware-provided-device-tr.patch
Patch0005:      0005-rpi3-Enable-lan78xx-driver.patch
Patch0006:      0006-net-Only-access-network-devices-aft.patch
Patch0007:      0007-rpi-Add-identifier-for-the-new-RPi3.patch
Patch0008:      0008-efi_loader-Fix-network-DP-with-DM_E.patch
Patch0009:      0009-rpi-Allow-to-boot-without-serial.patch
Patch0010:      0010-mmc-use-core-clock-frequency-in-bcm.patch
Patch0011:      0011-Temp-workaround-for-Chromebook-snow.patch
Patch0012:      0012-CVE-2019-13106-ext4-fix-out-of-boun.patch
Patch0013:      0013-CVE-2019-13104-ext4-check-for-under.patch
Patch0014:      0014-CVE-net-fix-unbounded-memcpy-of-UDP.patch
Patch0015:      0015-CVE-nfs-fix-stack-based-buffer-over.patch
Patch0016:      0016-CVE-2019-14194-CVE-2019-14198-nfs-f.patch
Patch0017:      0017-CVE-2019-14195-nfs-fix-unbounded-me.patch
Patch0018:      0018-CVE-2019-14196-nfs-fix-unbounded-me.patch
Patch0019:      0019-CVE-2019-13103-disk-stop-infinite-r.patch
Patch0020:      0020-cmd-gpt-Address-error-cases-during-.patch
Patch0021:      0021-Fix-ext4-block-group-descriptor-siz.patch
Patch0022:      0022-lib-uuid-Fix-unseeded-PRNG-on-RANDO.patch
Patch0023:      0023-image-Check-hash-nodes-when-checkin.patch
Patch0024:      0024-image-Load-the-correct-configuratio.patch
Patch0025:      0025-dwc2-USB-controller-hangs-with-lan7.patch
Patch0026:      0026-efi_loader-Rename-sections-to-allow.patch
Patch0027:      0027-efi_loader-Fix-GOP-32bpp-exposure.patch
Patch0028:      0028-arm-armv7-allow-unaligned-memory-ac.patch
Patch0029:      0029-efi_loader-allow-unaligned-memory-a.patch
Patch0030:      0030-video-sunxi-de2-Reserve-the-fb-regi.patch
Patch0031:      0031-efi_loader-fix-off-by-one-bug-in-ef.patch
Patch0032:      0032-mmc-Unirqify-bcm2835_sdhost-and-fix.patch
Patch0033:      0033-rpi-Complete-table-of-models-with-n.patch
Patch0034:      0034-efi_loader-Respect-DT-reserved-regi.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0
BuildRequires:  arm-trusted-firmware-pine64
%endif
BuildRequires:  bc
# Arndale board needs DTC >= 1.4
BuildRequires:  dtc >= 1.4.0
# u-boot-clearfog (tools/kwbimage.c) needs openssl to build
BuildRequires:  libopenssl-devel
BuildRequires:  python-devel
BuildRequires:  swig
%if "%{name}" == "u-boot-qemu-ppce500"
# Owns /usr/share/qemu directory
BuildRequires:  qemu
Provides:       qemu-ppc:%{_datadir}/qemu/u-boot.e500
%endif
%if 0%{?is_rpi}
# Owns /boot/vc directory
BuildRequires:  raspberrypi-firmware
# For mountpoint
Requires(post): util-linux
%endif
Provides:       u-boot-loader
Conflicts:      otherproviders(u-boot-loader)
%if %x_loader == 1
Obsoletes:      x-loader-arndale
Provides:       x-loader-arndale
%endif
ExclusiveArch:  armv7l armv7hl

%description
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains the firmware for the arndale platform.

%package doc
Summary:        Documentation for the U-Boot Firmware
Group:          Documentation/Other

%description doc
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains documentation for U-Boot firmware.

%prep
%setup -q -n u-boot-%{archive_version}
%patch0001 -p1
%patch0002 -p1
%patch0003 -p1
%patch0004 -p1
%patch0005 -p1
%patch0006 -p1
%patch0007 -p1
%patch0008 -p1
%patch0009 -p1
%patch0010 -p1
%patch0011 -p1
%patch0012 -p1
%patch0013 -p1
%patch0014 -p1
%patch0015 -p1
%patch0016 -p1
%patch0017 -p1
%patch0018 -p1
%patch0019 -p1
%patch0020 -p1
%patch0021 -p1
%patch0022 -p1
%patch0023 -p1
%patch0024 -p1
%patch0025 -p1
%patch0026 -p1
%patch0027 -p1
%patch0028 -p1
%patch0029 -p1
%patch0030 -p1
%patch0031 -p1
%patch0032 -p1
%patch0033 -p1
%patch0034 -p1

%build
export SOURCE_DATE_EPOCH=$(date -d "$(head -n 2 %{_sourcedir}/%{name}.changes | tail -n 1 | cut -d- -f1 )" +%s)
%if "%{name}" == "u-boot-pine64plus"
export BL31=/boot/bl31.bin
%endif

make %{?_smp_mflags} CROSS_COMPILE= HOSTCFLAGS="$RPM_OPT_FLAGS" arndale_defconfig
echo "Attempting to enable fdt apply command (.dtbo) support."
echo "CONFIG_OF_LIBFDT_OVERLAY=y" >> .config
make %{?_smp_mflags} CROSS_COMPILE= HOSTCFLAGS="$RPM_OPT_FLAGS" USE_PRIVATE_LIBGG=yes

%ifarch aarch64
%if %sunxi_spl == 1
cat spl/sunxi-spl.bin u-boot.itb > u-boot-sunxi-with-spl.bin
%endif
%endif

%if "%{name}" == "u-boot-snow" || "%{name}" == "u-boot-spring"
# Chromebook ARM (snow) and HP Chromebook 11 (spring) need a uImage format
export TEXT_START=$(awk '$NF == "_start" { printf "0x"$1 }' System.map)
./tools/mkimage -A arm -O linux -T kernel -C none -a $TEXT_START -e $TEXT_START -n uboot -d u-boot-dtb.bin u-boot.img
%endif

%if %rockchip_spl == 1
for t in ; do
    ./tools/mkimage -n  -d spl/u-boot-spl.bin -T $t u-boot-spl.$t
done
%endif

%install
export SOURCE_DATE_EPOCH=$(date -d "$(head -n 2 %{_sourcedir}/%{name}.changes | tail -n 1 | cut -d- -f1 )" +%s)
export NO_BRP_STRIP_DEBUG=true
export NO_DEBUGINFO_STRIP_DEBUG=true
%define uboot_dir /boot
%if 0%{?is_rpi}
%define uboot_dir /boot/vc
%endif
%if "%{name}" == "u-boot-qemu-ppce500"
%define uboot_dir %{_datadir}/qemu
%endif
%if "%{name}" == "u-boot-jetson-tk1"
# tegra-uboot-flasher needs several intermediate files, under their original name.
for f in u-boot u-boot.dtb u-boot-dtb-tegra.bin u-boot-nodtb-tegra.bin spl/u-boot-spl; do
    install -D -m 0644 $f %{buildroot}%{uboot_dir}/$f
done
%else
%if "%{name}" == "u-boot-p2371-2180"
# Jetson TX1 Driver Pack flash.sh needs several intermediate files, under their original name.
for f in u-boot u-boot.bin u-boot.dtb u-boot-dtb.bin; do
    install -D -m 0644 $f %{buildroot}%{uboot_dir}/$f
done
%else
install -D -m 0644 u-boot.bin %{buildroot}%{uboot_dir}/u-boot.bin
%if "%{name}" == "u-boot-qemu-ppce500"
mv %{buildroot}%{uboot_dir}/u-boot.bin %{buildroot}%{uboot_dir}/u-boot.e500
%endif
%endif
%endif
%if %x_loader == 1
install -D -m 0644 MLO %{buildroot}%{uboot_dir}/MLO
%endif
%if %origen_spl == 1
install -D -m 0644 spl/origen-spl.bin %{buildroot}%{uboot_dir}/origen-spl.bin
%endif
%if %arndale_spl == 1
install -D -m 0644 spl/arndale-spl.bin %{buildroot}%{uboot_dir}/arndale-spl.bin
install -D -m 0644 %{SOURCE2} %{buildroot}%{uboot_dir}/arndale-bl1.img
%endif
%if %mvebu_spl == 1
install -D -m 0644 u-boot-spl.kwb %{buildroot}%{uboot_dir}/u-boot-spl.kwb
%endif
%if %rockchip_spl == 1
install -D -m 0644 spl/u-boot-spl.bin %{buildroot}%{uboot_dir}/u-boot-spl.bin
for t in ; do
    install -D -m 0644 u-boot-spl.$t %{buildroot}%{uboot_dir}/u-boot-spl.$t
done
%endif
%if %sunxi_spl == 1
install -D -m 0644 spl/sunxi-spl.bin %{buildroot}%{uboot_dir}/sunxi-spl.bin
install -D -m 0644 u-boot-sunxi-with-spl.bin %{buildroot}%{uboot_dir}/u-boot-sunxi-with-spl.bin
%endif
%if %imx6_spl == 1
install -D -m 0644 SPL %{buildroot}%{uboot_dir}/imx6-spl.bin
%endif
%if %socfpga_spl == 1
install -D -m 0644 u-boot-with-spl.sfp %{buildroot}%{uboot_dir}/u-boot-with-spl.sfp
%endif

%if 0%{?is_rpi}
%post
# On the Raspberry Pi we chain-load u-boot.bin from bootcode.bin via config.txt.
# It needs to be on the first FAT partition, wherever we mounted it.
# a) Unmounted, then do nothing.
# b) Mounted as /boot/vc, then they're in the right place already.
# c) Mounted as /boot/efi, with /boot/vc as symlink, then nothing to be done.
# d) Mounted as /boot/efi, with /boot/vc a directory, then copy files over.
if mountpoint -q /boot/efi; then
  [[ "$(readlink -f /boot/efi)" -ef "$(readlink -f %{uboot_dir})" ]] || cp %{uboot_dir}/u-boot.bin /boot/efi/
fi
%endif

%files
%defattr(-,root,root)
%{uboot_dir}/*
%doc Licenses/gpl-2.0.txt README

%files doc
%defattr(-,root,root)
# Generic documents
%doc doc/README.JFFS2 doc/README.JFFS2_NAND doc/README.commands
%doc doc/README.autoboot doc/README.commands doc/README.console doc/README.dns
%doc doc/README.hwconfig doc/README.nand doc/README.NetConsole doc/README.serial_multi
%doc doc/README.SNTP doc/README.standalone doc/README.update doc/README.usb
%doc doc/README.video doc/README.VLAN doc/README.silent doc/README.POST
# Copy some useful kermit scripts as well
%doc tools/kermit/dot.kermrc tools/kermit/flash_param tools/kermit/send_cmd tools/kermit/send_image
# Now any h/w dependent Documentation
%doc doc/README.ARM-memory-map

%changelog
openSUSE Build Service is sponsored by