File python-pyOpenSSL.spec of Package python-pyOpenSSL.19472

#
# spec file for package python-pyOpenSSL
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define oldpython python
Name:           python-pyOpenSSL
Version:        17.5.0
Release:        0
Summary:        Python wrapper module around the OpenSSL library
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/pyca/pyopenssl
Source:         https://files.pythonhosted.org/packages/source/p/pyOpenSSL/pyOpenSSL-%{version}.tar.gz
Patch0:         bug-lp-1265482.diff
Patch1:         skip-networked-test.patch
Patch2:         rsa128-i586.patch
Patch3:         X509_STORE_add_cert.patch
# PATCH-FIX-OPENSUSE openSSL_111d.patch bsc#1149792 mcepl@suse.com
# Make tests compatible with OpenSSL 1.1.1c
Patch4:         openSSL_111d.patch
# PATCH-FIX-UPSTREAM fix-compilation-2020.patch bsc#1159989 mcepl@suse.com
# aka gh#pyca/pyopenssl#735 … expired certificate in tests
Patch5:         fix-compilation-2020.patch
BuildRequires:  %{python_module cryptography >= 2.1.4}
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module flaky}
BuildRequires:  %{python_module pretend}
BuildRequires:  %{python_module pytest >= 3.0.1}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  openssl-devel
BuildRequires:  python-rpm-macros
BuildRequires:  python3-Sphinx
Requires:       python-cryptography >= 2.1.4
Requires:       python-six >= 1.5.2
Provides:       pyOpenSSL = %{version}
BuildArch:      noarch
%ifpython2
Obsoletes:      %{oldpython}-openssl < %{version}
Provides:       %{oldpython}-openssl = %{version}
%endif
%python_subpackages

%description
pyOpenSSL is a set of Python bindings for OpenSSL.  It includes some low-level
cryptography APIs but is primarily focused on providing an API for using the
TLS protocol from Python.

pyOpenSSL is now a pure-Python project with a dependency on a new project,
cryptography (<https://github.com/pyca/cryptography>), which provides (among
other things) a cffi-based interface to OpenSSL.

%package -n %{name}-doc
Summary:        Documentation for %{name}
Group:          Documentation/HTML

%description -n %{name}-doc
Provides documentation for %{name}.

%prep
%setup -q -n pyOpenSSL-%{version}
%autopatch -p1

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
PYTHONPATH="%{buildroot}%{python3_sitelib}" python3 setup.py build_sphinx && rm build/sphinx/html/.buildinfo

%check
export LC_ALL=en_US.UTF-8
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitelib}
py.test-%{$python_bin_suffix} -m "not network" -k "not test_export_text"
}

%files %{python_files}
%doc *.rst
%license LICENSE
%{python_sitelib}/OpenSSL/
%{python_sitelib}/pyOpenSSL-%{version}-py*.egg-info

%files -n %{name}-doc
%doc build/sphinx/html/
%doc examples/

%changelog
openSUSE Build Service is sponsored by