File virt-manager.spec of Package virt-manager.15254

#
# spec file for package virt-manager
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define with_guestfs       0
%define askpass_package    "openssh-askpass"
%define qemu_user          "qemu"
%define libvirt_kvm_packages   ""
%define libvirt_xen_packages   ""
%define preferred_distros  "sles15,opensuse15"
%define kvm_packages       ""
%define _version           1.5.1
%define _release           0

Name:           virt-manager
Version:        1.5.1
Release:        0
Summary:        Virtual Machine Manager
License:        GPL-2.0-or-later
Group:          System/Monitoring
Url:            http://virt-manager.org/
Source0:        %{name}-%{version}.tar.bz2
Source1:        virt-install.rb
Source2:        virt-install.desktop
Source3:        virt-manager-supportconfig
# Upstream Patches
Patch1:         27d4b167-virtinst-update-location-for-opensuse.patch
Patch2:         d15b78ab-virtinst-read-CPU-model-from-domain-capabilities.patch
Patch3:         fd6a8154-virtinst-compare-host-and-domain-cpu-models.patch
Patch4:         5a7698c7-fix-select-network-vol.patch
Patch5:         e47b34c0-Fix-initrdinject-and-urltests-with-py3.patch
Patch6:         5bc847eb-virt-install-Do-not-warn-about-consoles-on-s390x.patch
Patch7:         8d9743d6-virt-install-Add-support-for-xenbus-controller.patch
# SUSE Only
Patch70:        virtman-desktop.patch
Patch71:        virtman-kvm.patch
Patch72:        virtman-keycombo.patch
Patch73:        virtman-show-suse-install-repos.patch
Patch74:        virtman-libvirtd-not-running.patch
Patch75:        virtman-dont-allow-grub.xen-to-be-deleted.patch
Patch76:        virtinst-pvgrub2-bootloader.patch
Patch77:        virtinst-nfs-install-sanitize.patch
# Features or Enhancements
Patch101:       virtman-default-guest-from-host-os.patch
Patch102:       virtman-default-to-xen-pv.patch
Patch103:       virtman-packages.patch
Patch104:       virtman-load-stored-uris.patch
Patch105:       virtman-add-connect-default.patch
Patch120:       virtinst-storage-ocfs2.patch
Patch121:       virtinst-default-xen-to-qcow2-format.patch
Patch122:       virtinst-detect-oes-distros.patch
Patch123:       virtinst-modify-gui-defaults.patch
Patch124:       virtinst-vol-default-nocow.patch
Patch125:       virtinst-set-cache-mode-unsafe-for-install.patch
Patch126:       virtinst-set-qemu-emulator.patch
Patch127:       virtinst-add-ppc64-arch-support.patch
Patch128:       virtinst-s390x-disable-graphics.patch
Patch129:       virtinst-add-caasp-support.patch
# Bug Fixes
Patch150:       virtman-prevent-double-click-starting-vm-twice.patch
Patch151:       virtman-increase-setKeepAlive-count.patch
Patch152:       virtman-allow-destroy-from-shutdown-menu-of-crashed-vm.patch
Patch153:       virtman-check-for-valid-display.patch
Patch154:       virtman-allow-creating-i686-vm.patch
Patch155:       virtman-dont-specify-vte-version.patch
Patch156:       virtman-fix-missing-translations.patch
Patch160:       virtinst-xen-drive-type.patch
Patch161:       virtinst-xenbus-disk-index-fix.patch
Patch162:       virtinst-refresh_before_fetch_pool.patch
Patch163:       virtinst-use-xenpae-kernel-for-32bit.patch
Patch164:       virtinst-use-qemu-for-cdrom-device.patch
Patch165:       virtinst-fix-sle-distro-parsing.patch
Patch166:       virtinst-check-date-format.patch
Patch167:       virtinst-no-usb-tablet-for-xenpv.patch
Patch168:       virtinst-add-sle15-detection-support.patch
Patch169:       virtinst-keep-install-iso-attached.patch
Patch170:       virtinst-osdict-get_supported.patch
Patch171:       virtinst-dont-use-special-copy-cpu-features.patch
Patch172:       virtinst-use-latest-opensuse-version-when-unknown-media.patch
Patch173:       virtinst-handle-tumbleweed-treeinfo-file.patch
# Python2 to Python3 patches
Patch200:       virtmisc-python2-to-python3-conversion.patch
Patch201:       virtcli-python2-to-python3-conversion.patch
Patch202:       virtconv-python2-to-python3-conversion.patch
Patch203:       virtinst-python2-to-python3-conversion.patch
Patch204:       virtman-python2-to-python3-conversion.patch
Patch205:       virttests-python2-to-python3-conversion.patch
Patch206:       0002-virtinst-python3-avoid-comparison-of-None-and-int.patch
Patch207:       0003-virtinst-python3-avoid-using-long-type.patch
Patch208:       0004-virtinst-python3-use-binary-mode-for-kernel.patch
Patch209:       virtman-register-delete-event-for-details-dialog.patch

BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%define verrel %{version}-%{release}
Requires:       dbus-1-x11
Requires:       dconf
Requires:       gtk3
Requires:       python3-gobject-Gdk
# For console widget
Requires:       python3-cairo
Requires:       python3-gobject-cairo
Recommends:     python3-SpiceClientGtk
Requires:       virt-install
Requires:       virt-manager-common = %{verrel}
%if 0%{?is_opensuse} == 1
# virtman-desktop.patch changes the icon to be yast-vm-management, which is provided by yast2-branding
Requires:       yast2-branding-openSUSE
%endif

%if %{with_guestfs}
Requires:       python3-libguestfs
%endif

BuildRequires:  glib2-devel
BuildRequires:  gtk3-tools
BuildRequires:  intltool
BuildRequires:  perl
BuildRequires:  python3

%description
Virtual Machine Manager provides a graphical tool for administering virtual
machines for KVM, Xen, and QEmu. Start, stop, add or remove virtual devices,
connect to a graphical or serial console, and see resource usage statistics
for existing VMs on local or remote machines. Uses libvirt as the backend
management API.


%package common
Summary:        Common files used by the different Virtual Machine Manager interfaces
Group:          System/Monitoring

# This version not strictly required: virt-manager should work with older,
# however varying amounts of functionality will not be enabled.
Requires:       libosinfo >= 0.2.10
Requires:       python3-ipaddr
Requires:       python3-libvirt-python >= 0.7.0
Requires:       python3-libxml2-python
Requires:       python3-pycurl
Requires:       typelib(LibvirtGLib)
Suggests:       python3-virt-bootstrap
BuildRequires:  gobject-introspection
# No AppIndicator package on SLE
%if 0%{?is_opensuse} == 0
%define __requires_exclude typelib\\(AppIndicator3\\)
%endif

%description common
Common files used by the different virt-manager interfaces, as well as
virt-install related tools.


%package -n virt-install
Summary:        Utilities for installing virtual machines
Group:          System/Monitoring

Requires:       virt-manager-common = %{verrel}

Requires:       python3-requests
Provides:       python3-virtinst
Provides:       virt-clone
Provides:       virt-convert
Obsoletes:      python-virtinst <= 0.600.4
Supplements:    virt-manager

%description -n virt-install
Package includes several command line utilities, including virt-install
(build and install new VMs) and virt-clone (clone an existing virtual
machine).


%prep
%setup -q
# Upstream Patches
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
# SUSE Only
%patch70 -p1
%patch71 -p1
%patch72 -p1
%patch73 -p1
%patch74 -p1
%patch75 -p1
%patch76 -p1
%patch77 -p1
# Enhancements
%patch101 -p1
%patch102 -p1
%patch103 -p1
%patch104 -p1
%patch105 -p1
%patch120 -p1
%patch121 -p1
%patch122 -p1
%patch123 -p1
%patch124 -p1
%patch125 -p1
%patch126 -p1
%patch127 -p1
%patch128 -p1
%patch129 -p1
# Bug Fixes
%patch150 -p1
%patch151 -p1
%patch152 -p1
%patch153 -p1
%patch154 -p1
%patch155 -p1
%patch156 -p1
%patch160 -p1
%patch161 -p1
%patch162 -p1
%patch163 -p1
%patch164 -p1
%patch165 -p1
%patch166 -p1
%patch167 -p1
%patch168 -p1
%patch169 -p1
%patch170 -p1
%patch171 -p1
%patch172 -p1
%patch173 -p1
# Python2 to Python3 patches
%patch200 -p1
%patch201 -p1
%patch202 -p1
%patch203 -p1
%patch204 -p1
%patch205 -p1
%patch206 -p1
%patch207 -p1
%patch208 -p1
%patch209 -p1

%build
%if %{qemu_user}
%define _qemu_user --qemu-user=%{qemu_user}
%endif

%if %{kvm_packages}
%define _kvm_packages --kvm-package-names=%{kvm_packages}
%endif

%if %{preferred_distros}
%define _preferred_distros --preferred-distros=%{preferred_distros}
%endif

%if %{libvirt_kvm_packages}
%define _libvirt_kvm_packages --libvirt-kvm-package-names=%{libvirt_kvm_packages}
%endif

%if %{libvirt_xen_packages}
%define _libvirt_xen_packages --libvirt-xen-package-names=%{libvirt_xen_packages}
%endif

%if %{askpass_package}
%define _askpass_package --askpass-package-names=%{askpass_package}
%endif

python3 setup.py configure \
    --prefix=%{_prefix} \
    --default-graphics="spice" \
    %{?_qemu_user} \
    %{?_kvm_packages} \
    %{?_libvirt_kvm_packages} \
    %{?_libvirt_xen_packages} \
    %{?_askpass_package} \
    %{?_preferred_distros} \
    %{?_default_graphics}

%install
python3 setup.py \
    --no-update-icon-cache \
    --no-compile-schemas install \
    --prefix=%{_prefix} \
    -O1 --root=%{buildroot}
mkdir -p %{buildroot}/%{_datadir}/YaST2/clients/
install -m644 %SOURCE1 %{buildroot}/%{_datadir}/YaST2/clients/virt-install.rb
mkdir -p %{buildroot}/%{_datadir}/applications/YaST2/
install -m644 %SOURCE2 %{buildroot}/%{_datadir}/applications/YaST2/virt-install.desktop
# Oddly, supportconfig doesn't execute plugins with '-' in the name, so use 'virt_manager'
mkdir -p %{buildroot}/usr/lib/supportconfig/plugins
install -m 755 %SOURCE3 %{buildroot}/usr/lib/supportconfig/plugins/virt_manager

%find_lang %{name}

%post
/bin/touch --no-create %{_datadir}/icons/hicolor >/dev/null 2>&1 || :
/usr/bin/update-desktop-database > /dev/null 2>&1 || :

%postun
if [ $1 -eq 0 ] ; then
    /bin/touch --no-create %{_datadir}/icons/hicolor >/dev/null 2>&1
    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor >/dev/null 2>&1 || :
    /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas > /dev/null 2>&1 || :
fi
/usr/bin/update-desktop-database > /dev/null 2>&1 || :

%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor >/dev/null 2>&1 || :
/usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas > /dev/null 2>&1 || :

%files
%defattr(-,root,root,-)
%{_bindir}/%{name}

%{_mandir}/man1/%{name}.1*

%dir %{_datadir}/virt-manager/ui
%{_datadir}/%{name}/ui/*.ui
%{_datadir}/%{name}/virt-manager
%{_datadir}/%{name}/virtManager

%dir %{_datadir}/icons/hicolor
%dir %{_datadir}/icons/hicolor/*/
%dir %{_datadir}/icons/hicolor/*/apps
%{_datadir}/%{name}/icons
%{_datadir}/icons/hicolor/*/apps/*

%{_datadir}/appdata/%{name}.appdata.xml
%{_datadir}/applications/%{name}.desktop
%{_datadir}/applications/YaST2/virt-install.desktop
%{_datadir}/glib-2.0/schemas/org.virt-manager.virt-manager.gschema.xml
%{_datadir}/GConf/gsettings/org.virt-manager.virt-manager.convert
%dir /usr/lib/supportconfig
%dir /usr/lib/supportconfig/plugins
/usr/lib/supportconfig/plugins/virt_manager

%files common -f %{name}.lang
%defattr(-,root,root,-)
%dir %{_datadir}/%{name}

%{_datadir}/%{name}/virtcli
%{_datadir}/%{name}/virtconv
%{_datadir}/%{name}/virtinst

%files -n virt-install
%defattr(-,root,root,-)
%{_mandir}/man1/virt-install.1*
%{_mandir}/man1/virt-clone.1*
%{_mandir}/man1/virt-convert.1*
%{_mandir}/man1/virt-xml.1*

%{_datadir}/%{name}/virt-install
%{_datadir}/%{name}/virt-clone
%{_datadir}/%{name}/virt-convert
%{_datadir}/%{name}/virt-xml
%dir %{_datadir}/YaST2
%dir %{_datadir}/YaST2/clients
%dir %{_datadir}/applications/YaST2
%dir %{_datadir}/GConf
%dir %{_datadir}/GConf/gsettings
%dir %{_datadir}/appdata
%{_datadir}/YaST2/clients/virt-install.rb

%{_bindir}/virt-install
%{_bindir}/virt-clone
%{_bindir}/virt-convert
%{_bindir}/virt-xml

%changelog
openSUSE Build Service is sponsored by