File ansible.spec of Package ansible

#
# spec file for package ansible
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright 2013 by Lars Vogdt
# Copyright 2014 by Boris Manojlovic
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%if 0%{?suse_version} && 0%{?suse_version} <= 1110 || 0%{?rhel} == 5
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%if 0%{?suse_version} >= 1500
%define __python python3
%define pyth python3
%define py_sitelib %{python3_sitelib}
%else
%define pyth python
%define py_sitelib %{python_sitelib}
%endif

Name:           ansible
Version:        2.5.1
Release:        0
Summary:        Software automation engine
License:        GPL-3.0-or-later
Group:          Development/Languages/Python
Url:            http://ansible.com/
Source:         https://releases.ansible.com/ansible/ansible-%{version}.tar.gz
Source99:       ansible-rpmlintrc
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

# SuSE/openSuSE
%if 0%{?suse_version}
BuildRequires:  %{pyth}-devel
BuildRequires:  %{pyth}-setuptools
Recommends:     %{pyth}-dnspython
Recommends:     %{pyth}-dopy
Recommends:     %{pyth}-pywinrm
Recommends:     sshpass
Recommends:     %{pyth}-httplib2
Recommends:     %{pyth}-keyczar
Recommends:     %{pyth}-six
Requires:       %{pyth}-setuptools
%if 0%{?suse_version} >= 01130
BuildRequires:  %{pyth}-Jinja2
BuildRequires:  %{pyth}-PyYAML
BuildRequires:  %{pyth}-paramiko
BuildRequires:  %{pyth}-pycrypto >= 2.6
Requires:       %{pyth}-Jinja2
Requires:       %{pyth}-PyYAML
Requires:       %{pyth}-paramiko
Requires:       %{pyth}-passlib
Requires:       %{pyth}-pycrypto >= 2.6
%endif
%endif

# RHEL <=5
%if 0%{?rhel} && 0%{?rhel} <= 5
BuildRequires:  python26-devel
BuildRequires:  python26-setuptools
Requires:       python26-PyYAML
Requires:       python26-httplib2
Requires:       python26-jinja2
Requires:       python26-keyczar
Requires:       python26-paramiko
Requires:       python26-setuptools
Requires:       python26-six
Requires:       sshpass
%endif
# RHEL > 5
%if 0%{?rhel} && 0%{?rhel} >= 5
BuildRequires:  python-setuptools
BuildRequires:  python2-devel
Requires:       PyYAML
Requires:       python-jinja2
Requires:       python-paramiko
Requires:       python-setuptools
Requires:       python-six
Requires:       sshpass
%endif
# RHEL == 6
%if 0%{?rhel} == 6
Requires:       python-crypto
%endif
# RHEL >=7
%if 0%{?rhel} >= 7
Requires:       python2-cryptography
BuildRequires:  perl(Exporter)
%endif
%if 0%{?fedora} >= 18
BuildRequires:  python-devel
BuildRequires:  python-setuptools
Requires:       PyYAML
Requires:       python-httplib2
Requires:       python-jinja2
Requires:       python-keyczar
Requires:       python-paramiko
Requires:       python-setuptools
Requires:       python-six
Requires:       sshpass
%define         __python %{__python2}
%endif

%description
Ansible is an IT automation system. It handles
configuration-management, application deployment, cloud provisioning, ad-hoc
task-execution, and multinode orchestration - including trivializing things
like zero downtime rolling updates with load balancers.

%prep
%setup -q -n ansible-%{version}
find . -name .git_keep -delete
find contrib/ -type f -exec chmod 644 {} +

%build
%{__python} setup.py build

%install
%{__python} setup.py install --prefix=%{_prefix} --root=%{buildroot}

mkdir -p %{buildroot}%{_sysconfdir}/ansible/
cp examples/hosts %{buildroot}%{_sysconfdir}/ansible/
cp examples/ansible.cfg %{buildroot}%{_sysconfdir}/ansible/
mkdir -p %{buildroot}/%{_mandir}/man1/
cp -v docs/man/man1/*.1 %{buildroot}/%{_mandir}/man1/
mkdir -p %{buildroot}/%{_datadir}/ansible

%files
%defattr(-,root,root,-)
%doc COPYING *.rst contrib examples changelogs
%{_bindir}/ansible
%{_bindir}/ansible-config
%{_bindir}/ansible-connection
%{_bindir}/ansible-console
%{_bindir}/ansible-doc
%{_bindir}/ansible-galaxy
%{_bindir}/ansible-inventory
%{_bindir}/ansible-playbook
%{_bindir}/ansible-pull
%{_bindir}/ansible-vault
%{py_sitelib}/*
%{_mandir}/man1/ansible.1*
%{_mandir}/man1/ansible-config.1*
%{_mandir}/man1/ansible-console.1*
%{_mandir}/man1/ansible-doc.1*
%{_mandir}/man1/ansible-galaxy.1*
%{_mandir}/man1/ansible-inventory.1*
%{_mandir}/man1/ansible-playbook.1*
%{_mandir}/man1/ansible-pull.1*
%{_mandir}/man1/ansible-vault.1*
%dir %{_sysconfdir}/ansible
%config(noreplace) %{_sysconfdir}/ansible/ansible.cfg
%config(noreplace) %{_sysconfdir}/ansible/hosts

%changelog
openSUSE Build Service is sponsored by