File gogoc.spec of Package gogoc

## --*- rpm-spec -*--

# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; version 3 of the License.
#  
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#  
# You should have received a copy of the GNU General Public License
# along with this program. If not, see http://www.gnu.org/licenses/.


%define uid		11

%define service		gogocd

%define installpath	/usr/lib/gogoc

%{!?release_func:%define release_func() %1}

Summary:	A gogo-client
Name:		gogoc
Version:	1.2
Release:	%release_func 0
Epoch:		0
License:	GPLv3
Group:		System/Daemons
URL:		http://www.go6.net
Source0:	http://gogo6.com/downloads/gogoc-1_2-RELEASE.tar.bz2
BuildRoot:	%_tmppath/%name-%version-%release-root
Requires:		init(gogo-client-daemon)
BuildRequires:	gcc-c++ libopenssl-devel libgcrypt-devel

%package gogocd
Summary:		SysV initscripts for gogoc
Group:			System/Base
Provides:		init(gogo-client-daemon) = gogocd
Requires:		%name = %epoch:%version-%release
%if 0%{?opensuse_bs}
Requires(preun):	%name
Requires(postun):	%name
%else
Requires(preun):	%name initscripts
Requires(postun):	%name initscripts
%endif
Requires(post):		/sbin/chkconfig
Requires(preun):	/sbin/chkconfig
BuildRequires:	gcc-c++ libopenssl-devel libgcrypt-devel

%description
gogoCLIENT - Basic version
The basic version of the gogoCLIENT offers IPv6 connectivity as well 
as IPv4 over IPv6 tunneling (DSTM and DS-lite) on the Windows version. 
If you want to get a static IPv6 address or get a /56 network you 
need an account on the Freenet6 server.

%description gogocd 
gogoc offers offers IPv6 connectivity as well as IPv4 over IPv6 tunneling.

This package provides the scripts which can be used to start gogoc
with the SysV initconcept.


##---------------------------------------------


%prep
%setup -q


##---------------------------------------------


%build
%__make platform=linux all


##---------------------------------------------


%install
rm -rf $RPM_BUILD_ROOT

%__make platform=linux installdir=$RPM_BUILD_ROOT%installpath install
# move the manual pages
mkdir -p $RPM_BUILD_ROOT%{_mandir}
rm -rf $RPM_BUILD_ROOT%{_mandir}/man5
rm -rf $RPM_BUILD_ROOT%{_mandir}/man8
mv $RPM_BUILD_ROOT%installpath/man/man5 $RPM_BUILD_ROOT%{_mandir}/man5
mv $RPM_BUILD_ROOT%installpath/man/man8 $RPM_BUILD_ROOT%{_mandir}/man8
rmdir $RPM_BUILD_ROOT%installpath/man

rm -f $RPM_BUILD_ROOT%installpath/bin/gogoc.conf.sample
rm -f $RPM_BUILD_ROOT%installpath/bin/gogoc.conf

mkdir -p $RPM_BUILD_ROOT%_initrddir
cp contrib/gogoc.init $RPM_BUILD_ROOT%_initrddir/gogocd
mkdir -p $RPM_BUILD_ROOT/var/adm/fillup-templates
cp contrib/gogoc.sysconfig $RPM_BUILD_ROOT/var/adm/fillup-templates/sysconfig.gogocd

cp contrib/gogoc.conf.sample $RPM_BUILD_ROOT%_sysconfdir/gogoc.conf
chmod 664 $RPM_BUILD_ROOT%_sysconfdir/gogoc.conf
mkdir -p $RPM_BUILD_ROOT%installpath/conf
cp contrib/gogoc.conf.sample $RPM_BUILD_ROOT%installpath/conf/gogoc.conf.sample
chmod 664 $RPM_BUILD_ROOT%installpath/conf/gogoc.conf.sample
chmod 755 $RPM_BUILD_ROOT%installpath/template/linux.sh
rm -f $RPM_BUILD_ROOT%installpath/template/README


##---------------------------------------------


%check


##---------------------------------------------


%clean
rm -rf $RPM_BUILD_ROOT


%pre

%postun
%insserv_cleanup

%post gogocd
%if 0%{?opensuse_bs}
## DO NOTHING
%else
/sbin/chkconfig --add %service
%endif
ln -sf %_initrddir/%service %_sbindir/rc%service
%{fillup_and_insserv gogocd}



%preun gogocd
if test "$1" = "0"; then
	%_initrddir/%service stop >/dev/null
	/sbin/chkconfig --del %service
fi

%postun gogocd
%if 0%{?opensuse_bs}
## DO NOTHING
%else
test "$1" = 0 || %_initrddir/%service condrestart &>/dev/null
%endif
rm -f %_sbindir/rc%service

%files
%defattr(-,root,root,-)
%doc README CLIENT-LICENSE.TXT GUI-LICENSE.TXT INSTALL
%installpath/bin/gogoc
%config(noreplace) %_sysconfdir/gogoc.conf
/usr/lib/gogoc/template/linux.sh
%{_mandir}/*/*
%dir %installpath
%dir %installpath/bin
%dir %installpath/conf
%dir %installpath/template
%installpath/conf/gogoc.conf.sample
/var/adm/fillup-templates/sysconfig.gogocd


%files gogocd
%defattr(-,root,root,-)
%config %_initrddir/*

%changelog
* Sat Apr 9 2011 Hunter McGhoo <hmcghoo@googlemail.com> - 0:1.2.1-1
- added dir directives in files section
- renamed sysv to gogocd
* Sat Dec 25 2010 Hunter McGhoo <hmcghoo@googlemail.com> - 0:1.2.1-0
- initial build
openSUSE Build Service is sponsored by