File rust-font-kit.spec of Package rust-font-kit
#
# spec file for package rust-font-kit
#
# Copyright (c) 2024 Your Name <you@example.com>.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate font-kit
Name: rust-font-kit
Version: 0.13.0
Release: 0
Summary: Cross-platform font loading library
Group: Development/Libraries/Rust
License: MIT OR Apache-2.0
URL: https://crates.io/crates/font-kit
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
# Automatically generated patch to strip dependencies and normalize metadata
Patch: font-kit-fix-metadata-auto.diff
# PATCH-FIX-OPENSUSE font-kit-fix-metadata.diff — Manually created patch for downstream crate metadata changes
Patch: font-kit-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%if %{with check}
%endif
%global _description %{expand:
A cross-platform font loading library.}
%description %{_description}
%package devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+freetype-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+freetype-devel %{_description}
This package contains library source intended for building other packages which
use the "freetype" feature of the "%{crate}" crate.
%files -n %{name}+freetype-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+loader-freetype-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+loader-freetype-devel %{_description}
This package contains library source intended for building other packages which
use the "loader-freetype" feature of the "%{crate}" crate.
%files -n %{name}+loader-freetype-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+loader-freetype-default-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+loader-freetype-default-devel %{_description}
This package contains library source intended for building other packages which
use the "loader-freetype-default" feature of the "%{crate}" crate.
%files -n %{name}+loader-freetype-default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+source-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+source-devel %{_description}
This package contains library source intended for building other packages which
use the "source" feature of the "%{crate}" crate.
%files -n %{name}+source-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+source-fontconfig-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+source-fontconfig-devel %{_description}
This package contains library source intended for building other packages which
use the "source-fontconfig" feature of the "%{crate}" crate.
%files -n %{name}+source-fontconfig-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+source-fontconfig-default-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+source-fontconfig-default-devel %{_description}
This package contains library source intended for building other packages which
use the "source-fontconfig-default" feature of the "%{crate}" crate.
%files -n %{name}+source-fontconfig-default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+source-fontconfig-dlopen-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+source-fontconfig-dlopen-devel %{_description}
This package contains library source intended for building other packages which
use the "source-fontconfig-dlopen" feature of the "%{crate}" crate.
%files -n %{name}+source-fontconfig-dlopen-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+yeslogic-fontconfig-sys-devel
Summary: %{summary}
Group: Development/Libraries/Rust
BuildArch: noarch
%description -n %{name}+yeslogic-fontconfig-sys-devel %{_description}
This package contains library source intended for building other packages which
use the "yeslogic-fontconfig-sys" feature of the "%{crate}" crate.
%files -n %{name}+yeslogic-fontconfig-sys-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%build
%install
dir=%{buildroot}/%{crate_instdir}; mkdir -pv "$dir"; cp -R ./* $dir/; echo "{\"files\":{},\"package\":\"\"}" > "$dir/.cargo-checksum.json"
%if %{with check}
%check
%endif
%changelog
* Tue Apr 23 16:42:16 EAT 2024 Your Name <you@example.com>
- Version 0.13.0
- Initial package