File lms.spec of Package lms

#
# spec file for package lms
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%bcond_without pam
Name:           lms
Version:        3.53.1
Release:        0
Summary:        Lightweight Music Server to access music using a web interface
License:        GPL-3.0-and-later
URL:            https://github.com/epoupon/lms
Source:         https://github.com/epoupon/lms/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires:  c++_compiler
BuildRequires:  cmake >= 3.12
BuildRequires:  libboost_iostreams-devel
BuildRequires:  libboost_program_options-devel
BuildRequires:  libboost_system-devel
BuildRequires:  pkgconfig
BuildRequires:  (pkgconfig(stb) or pkgconfig(GraphicsMagick++))
BuildRequires:  cmake(taglib)
BuildRequires:  cmake(wt) >= 4
BuildRequires:  pkgconfig(libarchive)
BuildRequires:  pkgconfig(libavcodec)
BuildRequires:  pkgconfig(libavformat)
BuildRequires:  pkgconfig(libavutil)
BuildRequires:  pkgconfig(libconfig++)
%if %{with pam}
BuildRequires:  pkgconfig(pam)
%endif

%description
Self-hosted music streaming software which allows users to access their
music collections from anywhere using a web interface.

Main features:
  * Recommendation engine
  * Audio transcode for maximum interoperability and low bandwith requirements
  * Multi-value tags: artist, genre, composer, lyricist, mood, performer, ...
  * MusicBrainz Identifier support to handle duplicated artist and release names
  * ListenBrainz support for:
    - Scrobbling and synchronizing listens
    - Synchronizing 'love' feedbacks
  * ReplayGain support
  * User management, with several authentication backends, see Deployment
  * Subsonic API

%prep
%autosetup -p1

%build
%cmake
%cmake_build

%install
%cmake_install

%check
%ctest

%files
%license COPYING
%doc README.md SUBSONIC.md

%changelog
openSUSE Build Service is sponsored by