File python-normality.spec of Package python-normality

#
# spec file for package python-normality
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-normality
Version:        2.4.0
Release:        0
Summary:        Micro-library to normalize text strings
License:        MIT
URL:            https://github.com/pudo/normality
Source:         https://files.pythonhosted.org/packages/source/n/normality/normality-%{version}.tar.gz
BuildRequires:  python-rpm-macros
BuildRequires:  %{python_module pip}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module wheel}
# SECTION test requirements
BuildRequires:  %{python_module banal >= 1.0.1}
BuildRequires:  %{python_module chardet}
BuildRequires:  %{python_module charset-normalizer >= 2.0.0}
BuildRequires:  %{python_module text-unidecode}
BuildRequires:  %{python_module pytest}
# /SECTION
BuildRequires:  fdupes
Requires:       python-banal >= 1.0.1
Requires:       python-chardet
Requires:       python-charset-normalizer >= 2.0.0
Requires:       python-text-unidecode
Suggests:       python-pyicu >= 1.9.3
Suggests:       python-mypy
Suggests:       python-pytest
Suggests:       python-types-chardet
Suggests:       python-pyicu >= 1.9.3
BuildArch:      noarch
%python_subpackages

%description
Micro-library to normalize text strings.

%prep
%setup -q -n normality-%{version}

%build
%pyproject_wheel

%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check
%pytest -k 'not (test_ahmad or test_azeri or test_georgian or test_petro)'

%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/normality*/

%changelog
openSUSE Build Service is sponsored by