File python-pyexcel.spec of Package python-pyexcel

#
# spec file for package python-pyexcel
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/

%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-pyexcel%{psuffix}
Version:        0.6.4
Release:        0
License:        BSD-3-Clause
Summary:        An API to read, manipulate and writedata in different excel formats
Url:            https://github.com/pyexcel/pyexcel
Group:          Development/Languages/Python
Source:         https://pypi.python.org/packages/source/p/pyexcel/pyexcel-%{version}.tar.gz
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
%if %{with test}
BuildRequires:  %{python_module pyexcel-xlsx}
BuildRequires:  %{python_module pyexcel-text}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module mock}
BuildRequires:  %{python_module lml >= 0.0.1}
BuildRequires:  %{python_module pyexcel-io >= 0.5.6}
BuildRequires:  %{python_module pyexcel-xls}
BuildRequires:  %{python_module texttable >= 0.8.1}
# test requirements
BuildRequires:  %{python_module psutil}
BuildRequires:  %{python_module SQLAlchemy}
BuildRequires:  %{python_module Flask}
%endif
Requires:       python-lml >= 0.0.1
Requires:       python-pyexcel-io >= 0.5.11
Requires:       python-texttable >= 0.8.2
Suggests:       python-pyexcel-xlsx >= 0.5.0
Suggests:       python-pyexcel-ods3 >= 0.5.0
Suggests:       python-pyexcel-xls >= 0.5.0
BuildArch:      noarch

%description
An extensible library that provides one API to read, manipulate and writedata in
different data formats.

1. One application programming interface(API) to handle multiple data sources:
   * physical file
   * memory file
   * SQLAlchemy table
   * Django Model
   * Python data structures: dictionary, records and array
2. One API to read and write data in various excel file formats.
3. For large data sets, data streaming are supported. A genenerator can be returned to you.
   Checkout iget_records, iget_array, isave_as and isave_book_as. 

%python_subpackages

%prep
%setup -q -n pyexcel-%{version}

%build
%python_build

%install
%if !%{with test}
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif

%if %{with test}
%check
%python_expand nosetests-%{$python_bin_suffix} -e '(test_svg_representation|test_save_handsontable_html)'
%endif

%files %{python_files}
%if !%{with test}
%doc CHANGELOG.rst README.rst
%license LICENSE
%{python_sitelib}/*
%endif

%changelog
openSUSE Build Service is sponsored by