File ChowKick.spec of Package ChowKick

#
# spec file for package ChowKick
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           ChowKick
Version:        1.2.0
Release:        0
Summary:        Kick synthesizer based on old-school drum machine circuits
License:        BSD-3-Clause
Group:          Productivity/Multimedia/Sound/Midi
URL:            https://github.com/Chowdhury-DSP/ChowKick
Source0:        %{name}-%{version}.tar.xz
BuildRequires:  JUCE7_04-source
BuildRequires:  Mesa-libGL-devel
BuildRequires:  cmake
BuildRequires:  gcc-c++
BuildRequires:  libXcursor-devel
BuildRequires:  libXrandr-devel
BuildRequires:  libcurl-devel
BuildRequires:  libjack-devel
BuildRequires:  lv2-devel
BuildRequires:  pkgconfig
BuildRequires:  pkgconfig(alsa)
BuildRequires:  pkgconfig(freetype2)
BuildRequires:  pkgconfig(x11)
BuildRequires:  pkgconfig(xext)
BuildRequires:  pkgconfig(xinerama)

%description

ChowKick is a kick drum synthesizer plugin based on creative modelling of old-school drum machine circuits.
MIDI input to the plugin triggers a pulse with a parameterized size and shape.
The pulse is then passed into a resonant filter which can be tuned to a specific frequency, or matched to the frequency of the incoming MIDI notes.

%package -n vst-%{name}
Summary:        Kick synthesizer based on old-school drum machine circuits (VST)

%description -n vst-%{name}

ChowKick is a kick drum synthesizer plugin based on creative modelling of old-school drum machine circuits.
MIDI input to the plugin triggers a pulse with a parameterized size and shape.
The pulse is then passed into a resonant filter which can be tuned to a specific frequency, or matched to the frequency of the incoming MIDI notes.

%package -n vst3-%{name}
Summary:        Kick synthesizer based on old-school drum machine circuits (VST3)

%description -n vst3-%{name}

ChowKick is a kick drum synthesizer plugin based on creative modelling of old-school drum machine circuits.
MIDI input to the plugin triggers a pulse with a parameterized size and shape.
The pulse is then passed into a resonant filter which can be tuned to a specific frequency, or matched to the frequency of the incoming MIDI notes.

%package -n lv2-%{name}
Summary:        Kick synthesizer based on old-school drum machine circuits (LV2)

%description -n lv2-%{name}

ChowKick is a kick drum synthesizer plugin based on creative modelling of old-school drum machine circuits.
MIDI input to the plugin triggers a pulse with a parameterized size and shape.
The pulse is then passed into a resonant filter which can be tuned to a specific frequency, or matched to the frequency of the incoming MIDI notes.

%package -n clap-%{name}
Summary:        Kick synthesizer based on old-school drum machine circuits (CLAP)

%description -n clap-%{name}

ChowKick is a kick drum synthesizer plugin based on creative modelling of old-school drum machine circuits.
MIDI input to the plugin triggers a pulse with a parameterized size and shape.
The pulse is then passed into a resonant filter which can be tuned to a specific frequency, or matched to the frequency of the incoming MIDI notes.

%prep
%setup -q

ln -s %{_prefix}/src/JUCE7_04 modules/JUCE
sed -i -e 's~# juce_set_vst2_sdk_path(C:/SDKs/VST_SDK/VST2_SDK)~juce_set_vst2_sdk_path(%{_prefix}/include)~' CMakeLists.txt
sed -i -e 's/    add_subdirectory(headless)//' src/CMakeLists.txt

%build
mkdir -p build
cd build
cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
%cmake_build

%install
mkdir -p %{buildroot}%{_bindir}
install build/%{name}_artefacts/RelWithDebInfo/Standalone/%{name} %{buildroot}%{_bindir}/
mkdir -p %{buildroot}%{_libdir}/vst
install build/%{name}_artefacts/RelWithDebInfo/VST/*.so %{buildroot}%{_libdir}/vst/
mkdir -p %{buildroot}%{_libdir}/vst3
cp -r build/%{name}_artefacts/RelWithDebInfo/VST3/*.vst3 %{buildroot}%{_libdir}/vst3/
mkdir -p %{buildroot}%{_libdir}/lv2
cp -r build/%{name}_artefacts/RelWithDebInfo/LV2/*.lv2 %{buildroot}%{_libdir}/lv2/
mkdir -p %{buildroot}%{_libdir}/clap
cp -r build/%{name}_artefacts/RelWithDebInfo/CLAP/*.clap %{buildroot}%{_libdir}/clap/

%files
%{_bindir}/*
%license LICENSE
%doc README.md

%files -n vst-%{name}
%dir %{_libdir}/vst
%{_libdir}/vst/
%doc README.md
%license LICENSE

%files -n vst3-%{name}
%{_libdir}/vst3/
%doc README.md
%license LICENSE

%files -n lv2-%{name}
%{_libdir}/lv2/
%doc README.md
%license LICENSE

%files -n clap-%{name}
%{_libdir}/clap/
%doc README.md
%license LICENSE

%changelog
openSUSE Build Service is sponsored by