File python-black_22.8.0-1.spec of Package psf-black-22.8.0

%global debug_package %{nil}

Name: python-black
Epoch: 100
Version: 22.8.0
Release: 1%{?dist}
BuildArch: noarch
Summary: The uncompromising code formatter
License: MIT
URL: https://github.com/psf/black/tags
Source0: %{name}_%{version}.orig.tar.gz
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildRequires: python3-devel
BuildRequires: python3-setuptools

%description
Black is the uncompromising Python code formatter. By using it, you
agree to cede control over minutiae of hand-formatting. In return, Black
gives you speed, determinism, and freedom from pycodestyle nagging about
formatting. You will save time and mental energy for more important
matters.

%prep
%autosetup -T -c -n %{name}_%{version}-%{release}
tar -zx -f %{S:0} --strip-components=1 -C .

%build
%py3_build

%install
%py3_install
find %{buildroot}%{python3_sitelib} -type f -name '*.pyc' -exec rm -rf {} \;
fdupes -qnrps %{buildroot}%{python3_sitelib}

%check

%package -n black
Summary: The uncompromising code formatter
Requires: python3
Requires: python3-click >= 8.0.0
Requires: python3-dataclasses >= 0.6
Requires: python3-mypy-extensions >= 0.4.3
Requires: python3-pathspec >= 0.9.0
Requires: python3-platformdirs >= 2
Requires: python3-tomli >= 1.1.0
Requires: python3-typed-ast >= 1.4.2
Requires: python3-typing-extensions >= 3.10.0.0
Provides: python3-black = %{epoch}:%{version}-%{release}
Provides: python3dist(black) = %{epoch}:%{version}-%{release}
Provides: python%{python3_version}-black = %{epoch}:%{version}-%{release}
Provides: python%{python3_version}dist(black) = %{epoch}:%{version}-%{release}
Provides: python%{python3_version_nodots}-black = %{epoch}:%{version}-%{release}
Provides: python%{python3_version_nodots}dist(black) = %{epoch}:%{version}-%{release}

%description -n black
Black is the uncompromising Python code formatter. By using it, you
agree to cede control over minutiae of hand-formatting. In return, Black
gives you speed, determinism, and freedom from pycodestyle nagging about
formatting. You will save time and mental energy for more important
matters.

%files -n black
%license LICENSE
%{_bindir}/*
%{python3_sitelib}/*

%changelog
openSUSE Build Service is sponsored by