File actionlib_tutorials.spec of Package actionlib_tutorials
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/noetic/.*$
%global __requires_exclude_from ^/opt/ros/noetic/.*$
Name: ros-noetic-actionlib-tutorials
Version: 0.2.0
Release: 1%{?dist}
Summary: ROS actionlib_tutorials package
License: BSD
Group: Development/Libraries
URL: http://www.ros.org/wiki/actionlib/Tutorials
Source0: actionlib_tutorials-release.tar.bz2
Source1: ros-rpmlintrc
Requires: ros-noetic
Requires: ros-noetic-actionlib
Requires: ros-noetic-message-runtime
Requires: ros-noetic-roscpp
BuildRequires: ros-noetic
BuildRequires: ros-noetic-actionlib
BuildRequires: ros-noetic-actionlib-msgs
BuildRequires: ros-noetic-catkin
BuildRequires: ros-noetic-message-generation
BuildRequires: ros-noetic-roscpp
BuildRequires: ros-noetic-std-msgs
%description
The actionlib_tutorials package
%prep
%autosetup -p0 -n actionlib_tutorials-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/noetic" \
-DCMAKE_PREFIX_PATH="/opt/ros/noetic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/noetic
%changelog