File stage.spec of Package stage
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
%global __provides_exclude_from ^/opt/ros/noetic/.*$
%global __requires_exclude_from ^/opt/ros/noetic/.*$
Name: ros-noetic-stage
Version: 4.3.0
Release: 1%{?dist}
Summary: ROS stage package
License: GPL
Group: Development/Libraries
URL: http://rtv.github.com/Stage
Source0: stage-release.tar.bz2
Source1: ros-rpmlintrc
Requires: Mesa-devel
Requires: fltk-devel
Requires: gtk2-devel
Requires: libjpeg8-devel
Requires: ros-noetic
Requires: ros-noetic-catkin
BuildRequires: Mesa-devel
BuildRequires: cmake
BuildRequires: fltk-devel
BuildRequires: glu-devel
BuildRequires: gtk2-devel
BuildRequires: libjpeg8-devel
BuildRequires: libltdl7
BuildRequires: libtool
BuildRequires: pkg-config
BuildRequires: ros-noetic
BuildRequires: ros-noetic-catkin
%description
Mobile robot simulator http://rtv.github.com/Stage
%prep
%autosetup -p0 -n stage-release
%build
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
mkdir -p obj-%{_target_platform} && cd obj-%{_target_platform}
cmake \
-UINCLUDE_INSTALL_DIR \
-ULIB_INSTALL_DIR \
-USYSCONF_INSTALL_DIR \
-USHARE_INSTALL_PREFIX \
-ULIB_SUFFIX \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_PREFIX="/opt/ros/noetic" \
-DCMAKE_PREFIX_PATH="/opt/ros/noetic" \
-DSETUPTOOLS_DEB_LAYOUT=OFF \
-DCATKIN_BUILD_BINARY_PACKAGE="1" \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
..
%make_build
%install
# In case we're installing to a non-standard location, look for a setup.sh
# in the install tree that was dropped by catkin, and source it. It will
# set things like CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
if [ -f "/opt/ros/noetic/setup.sh" ]; then . "/opt/ros/noetic/setup.sh"; fi
%make_install -C obj-%{_target_platform}
%files
/opt/ros/noetic
%changelog