File zfs.spec of Package zfs215

#
# spec file for package zfs
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%global kernel_version %(rpm -q kernel-syms | sed 's/^kernel-syms-//; s/\\.[0-9]\\+\\.%_arch//;')
%global kernel_build %(rpm -q kernel-syms | sed 's/^kernel-syms-[0-9.]\\+-[0-9]\\+.//; s/.%_arch//;')

%define rversion 2.1.5
Name:           zfs
Version:        2.1.5
Release:        0
Summary:        The ZFS filesystem and utilities
License:        CDDL-1.0 AND GPL-2.0-or-later
Group:          System/Filesystems
URL:            https://zfsonlinux.org/

#Github-URL:	https://github.com/zfsonlinux/zfs
Source:         https://github.com/zfsonlinux/zfs/releases/download/zfs-%rversion/zfs-%rversion.tar.gz
Source1:        https://github.com/zfsonlinux/zfs/releases/download/zfs-%rversion/zfs-%rversion.tar.gz.asc
Source2:        %name.keyring
Source3:        %name-preamble
Patch1:         kmod.diff
BuildRequires:  fdupes
BuildRequires:  kernel-devel
BuildRequires:  kernel-syms
BuildRequires:  libattr-devel
BuildRequires:  libelf-devel
BuildRequires:  libtirpc-devel
BuildRequires:  modutils
BuildRequires:  pkg-config
BuildRequires:  python
BuildRequires:  python3-devel
BuildRequires:  sudo
BuildRequires:  systemd-rpm-macros
BuildRequires:  pkgconfig(blkid)
BuildRequires:  pkgconfig(libcrypto)
BuildRequires:  pkgconfig(libselinux)
BuildRequires:  pkgconfig(uuid)
BuildRequires:  pkgconfig(zlib)
# Files collide, but zypper does not recognize that (bnc#673720)
Conflicts:      zfs-fuse
Provides:       openzfs = %version-%release

%define services zfs-import-cache.service zfs-import-scan.service zfs-mount.service zfs-share.service zfs-zed.service zfs.target zfs-import.target
%kernel_module_package -n zfs -p %name-preamble -x xen

%description
ZFS is a combined file system and logical volume manager designed by
Sun Microsystems. The features of ZFS include protection against data
corruption, support for high storage capacities, integration of the
concepts of filesystem and volume management, snapshots and
copy-on-write clones, continuous integrity checking and automatic
repair, RAID-Z and native NFSv4 ACLs.

ZFS on Linux, which is also known as ZoL, includes fully functional
and stable SPA, DMU, ZVOL, and ZPL layers.

%package -n libnvpair3
Summary:        A tools library for manipulating <name, value> pairs
License:        CDDL-1.0
Group:          System/Libraries

%description -n libnvpair3
ZFS is a file system and volume manager which was
originally developed by Sun Microsystems.

The nvpair library provides routines packing an unpacking nv pairs
for transporting data across process boundaries, transporting between
kernel and userland, and possibly saving onto disk files.

%package -n libuutil3
Summary:        ZFS utility library
License:        CDDL-1.0
Group:          System/Libraries

%description -n libuutil3
ZFS is a file system and volume manager which was
originally developed by Sun Microsystems.

The uutil library contains various utility and wrapper functions used
by the ZFS userland.

%package -n libzfs4
Summary:        ZFS filesystem access library
License:        CDDL-1.0
Group:          System/Libraries

%description -n libzfs4
ZFS is a file system and volume manager which was
originally developed by Sun Microsystems.

%package -n libzfsbootenv1
Summary:        ZFS boot environment library
License:        CDDL-1.0
Group:          System/Libraries

%description -n libzfsbootenv1
ZFS is a file system and volume manager which was
originally developed by Sun Microsystems.

%package -n libzfs_core3
Summary:        ZFS filesystem access library
License:        CDDL-1.0
Group:          System/Libraries

%description -n libzfs_core3
libzfs_core is intended to replace libzfs, and has the following
characteristics:
Thread safety, committed interface (stable API), programmatic
error handling and clear atomicity.

%package -n libzpool5
Summary:        Zpool interface
License:        CDDL-1.0
Group:          System/Libraries

%description -n libzpool5
ZFS is a file system and volume manager which was
originally developed by Sun Microsystems.

The zpool library contains
- Emulation of kernel services in userland
- Routines needed by more than one client of libzpool

%package sudo
Summary:        Sudo configuration for the ZFS userspace utilities
License:        CDDL-1.0
Group:          System/Management
Requires:       %name = %version
Supplements:    packageand(zfs:sudo)
BuildArch:      noarch

%description sudo
zfs-sudo includes sudoers configuration files to allow for easier
delegation of ZFS administrative tasks to unprivileged users (at a finer
level of granularity than giving full root access).

%package devel
Summary:        Development files for the ZFS userspace utilities
License:        CDDL-1.0
Group:          Development/Libraries/C and C++
Requires:       libnvpair1 = %version
Requires:       libuutil3 = %version
Requires:       libzfs4 = %version
Requires:       libzfsbootenv1 = %version
Requires:       libzpool5 = %version

%description devel
ZFS is a combined file system and logical volume manager designed by
Sun Microsystems. The features of ZFS include protection against data
corruption, support for high storage capacities, integration of the
concepts of filesystem and volume management, snapshots and
copy-on-write clones, continuous integrity checking and automatic
repair, RAID-Z and native NFSv4 ACLs.

This subpackage contains the development header files and libraries.
needed for compilation of third-party programs.

%prep
%setup -q
%if 0%{?suse_version} >= 1550
%patch -P 1 -p1
%endif

%build
%if 0%{?suse_version} > 1500
export CFLAGS="%optflags -I%_includedir/rpc"
sed -e "s|#include <tirpc/rpc/xdr\.h>|#include_next <rpc/xdr.h>|" \
    -i lib/libspl/include/rpc/xdr.h
%endif
for flavor in %flavors_to_build; do
	rm -Rf "../obj-$flavor"
	cp -a . "../obj-$flavor"
	pushd "../obj-$flavor/"
	%configure --with-config=kernel --with-linux="/usr/src/linux" \
		--with-linux-obj="/usr/src/linux-obj/%_target_cpu/$flavor" \
		--sbindir="%_sbindir" ||
		{ cat config.log; exit 1; }
	make %{?_smp_mflags} V=1
	popd
done
%configure --with-config=user \
	--disable-sysvinit \
	--enable-systemd \
	--disable-static
%if !%{defined make_build}
%define make_build make %{?_smp_mflags}
%endif
%make_build V=1

%install
b="%buildroot"
for flavor in %flavors_to_build; do
	pushd "../obj-$flavor/"
	%make_install
	popd
done
%make_install
rm -f "$b/%_libdir"/*.la
rm -Rf "$b/usr/src"
# all dracut
rm -Rf "$b/%_datadir/initramfs-tools"
rm -Rf "$b/%_datadir/zfs/zfs-tests"
mkdir -p "$b/%_sbindir"
for s in %services; do
	ln -s service "$b/%_sbindir/rc${s%.service}"
done
# udev location different for SLES 15 and later
if [ -d "$b/lib/udev" ]; then
        mv "$b/lib/udev" "$b/usr/lib/udev/"
fi

%fdupes %buildroot/%_prefix

%pre
%service_add_pre %services

%post
%service_add_post %services

%preun
%service_del_preun %services

%postun
%service_del_postun %services

%post   -n libnvpair3 -p /sbin/ldconfig
%postun -n libnvpair3 -p /sbin/ldconfig
%post   -n libuutil3 -p /sbin/ldconfig
%postun -n libuutil3 -p /sbin/ldconfig
%post   -n libzfs4 -p /sbin/ldconfig
%postun -n libzfs4 -p /sbin/ldconfig
%post   -n libzfsbootenv1 -p /sbin/ldconfig
%postun -n libzfsbootenv1 -p /sbin/ldconfig
%post   -n libzfs_core3 -p /sbin/ldconfig
%postun -n libzfs_core3 -p /sbin/ldconfig
%post   -n libzpool5 -p /sbin/ldconfig
%postun -n libzpool5 -p /sbin/ldconfig

%files
%config %_sysconfdir/default/zfs
%dir %_sysconfdir/zfs
%config %_sysconfdir/zfs/vdev*
%config %_sysconfdir/zfs/zfs-functions
%dir %_sysconfdir/zfs/zed.d
%config %_sysconfdir/zfs/zed.d/*.sh
%config(noreplace) %_sysconfdir/zfs/zed.d/zed.rc
%dir %_sysconfdir/zfs/zpool.d
%config %_sysconfdir/zfs/zpool.d/*
%_bindir/arcstat
%_bindir/arc_summary
%_bindir/dbufstat
%_bindir/raidz_test
%_bindir/z*
%_sbindir/fsck.zfs
%_sbindir/rc*
%_sbindir/z*
%_mandir/man?/*.*
%_datadir/zfs/
/sbin/mount.zfs
%_prefix/lib/dracut/
%_prefix/lib/udev/
%_libexecdir/zfs/
%_unitdir/zfs*
%_presetdir/50-zfs.preset
/usr/lib/systemd/system-generators/
/usr/lib/modules-load.d/

%files -n libnvpair3
%_libdir/libnvpair.so.3*

%files -n libuutil3
%_libdir/libuutil.so.3*

%files -n libzfs4
%_libdir/libzfs.so.4*

%files -n libzfsbootenv1
%_libdir/libzfsbootenv.so.1*

%files -n libzfs_core3
%_libdir/libzfs_core.so.3*

%files -n libzpool5
%_libdir/libzpool.so.5*

%files devel
%_includedir/libspl/
%_includedir/libzfs/
%_libdir/libnvpair.so
%_libdir/libuutil.so
%_libdir/libzfs.so
%_libdir/libzfsbootenv.so
%_libdir/libzfs_core.so
%_libdir/libzpool.so
%_libdir/pkgconfig/*.pc

%files sudo
%config %_sysconfdir/sudoers.d/zfs

%changelog
openSUSE Build Service is sponsored by