File PKGBUILD of Package kate
# Maintainer: Matteo De Carlo <matteo dot dek at gmail>
pkgname=kate-git
_pkgname=kate
pkgdesc="Advanced Text Editor"
pkgver=0.60.61
pkgrel=0
arch=('x86_64')
url="https://kate-editor.org"
license=(GPL LGPL FDL)
depends=(knewstuff ktexteditor kactivities kuserfeedback hicolor-icon-theme)
optdepends=('konsole: open a terminal in Kate'
'clang: C and C++ LSP support'
'python-lsp-server: Python LSP support'
'texlab: LaTeX LSP support'
'rust: Rust LSP support'
'git: git-blame plugin')
makedepends=(extra-cmake-modules kdoctools)
conflicts=("${_pkgname}")
provides=("${_pkgname}")
replaces=("${_pkgname}")
source=("${_pkgname}-${pkgver}.tar.xz")
sha256sums=('SKIP')
build() {
cmake -B build -S "${_pkgname}-${pkgver}" \
-DBUILD_TESTING=OFF
cmake --build build
}
package() {
DESTDIR="$pkgdir" cmake --install build
}