File fuzzylite.spec of Package fuzzylite

#
# spec file for package fuzzylite
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define major 6
%define minor 0
%define so_ver %{major}_%{minor}
Name:           fuzzylite
Version:        %{major}.%{minor}
Release:        0
Summary:        A fuzzy logic control library in C++
License:        GPL-3.0-only
Group:          Development/Libraries/C and C++
URL:            https://fuzzylite.com/
Source:         https://github.com/fuzzylite/fuzzylite/archive/v%{version}.tar.gz
# PATCH-FIX-UPSTREAM -- fuzzylite-fix-deprecated-unexpected-handler.patch -- https://github.com/fuzzylite/fuzzylite/pull/108
Patch0:         fuzzylite-fix-deprecated-unexpected-handler.patch
BuildRequires:  cmake >= 2.8.8
BuildRequires:  gcc-c++
BuildRequires:  pkgconfig

%description
The goal of the FuzzyLite Libraries is to easily design and efficiently operate
fuzzy logic controllers following an object-oriented programming model without
relying on external libraries.

%package -n libfuzzylite%{so_ver}
Summary:        Fuzzylite shared library
Group:          System/Libraries

%description -n libfuzzylite%{so_ver}
The goal of the FuzzyLite Libraries is to easily design and efficiently operate
fuzzy logic controllers following an object-oriented programming model without
relying on external libraries.

%package devel
Summary:        Development files for fuzzylite
Requires:       libfuzzylite%{so_ver} = %{version}

%description devel
The goal of the FuzzyLite Libraries is to easily design and efficiently operate
fuzzy logic controllers following an object-oriented programming model without
relying on external libraries.

%prep
%autosetup -p1

%build
cd fuzzylite
# FL_VERSION is defined here, because of
# https://github.com/fuzzylite/fuzzylite/issues/84
%cmake \
    -DFL_CPP11=ON \
    -DFL_BUILD_STATIC=OFF \
    -DFL_BUILD_TESTS=OFF \
    -DFL_VERSION="%{version}"
%make_build

%install
cd fuzzylite
%cmake_install
install -m 644 -D fuzzylite.1 %{buildroot}/%{_mandir}/man1/fuzzylite.1

%post -n libfuzzylite%{so_ver} -p /sbin/ldconfig
%postun -n libfuzzylite%{so_ver} -p /sbin/ldconfig

%files
%{_bindir}/fuzzylite
%{_mandir}/man1/fuzzylite.1%{?ext_man}

%files -n libfuzzylite%{so_ver}
%{_libdir}/libfuzzylite.so.%{major}.%{minor}

%files devel
%{_includedir}/fl/
%{_libdir}/libfuzzylite.so
%{_libdir}/pkgconfig/fuzzylite.pc

%changelog
openSUSE Build Service is sponsored by