File mingw32-krunner.spec of Package mingw32-krunner

#
# spec file for package mingw32-krunner
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define lname   libKF5Runner5
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw32_kf5_version: %global _mingw32_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw32_kf5_bugfix_version: %define _mingw32_kf5_bugfix_version %(echo %{_mingw32_kf5_version} | awk -F. '{print $1"."$2}')}
# Only needed for the package signature condition
%bcond_without lang
%define _name   krunner
Name:           mingw32-%{_name}
Version:        5.103.0
Release:        0
Summary:        Plugins responsible for better integration of Qt applications in KDE Workspace
License:        LGPL-2.1-or-later
Group:          System/GUI/KDE
URL:            https://www.kde.org
Source:         https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz
%if %{with lang}
Source1:        https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz.sig
Source2:        frameworks.keyring
%endif
BuildRequires:  mingw32-cross-cmake
BuildRequires:  mingw32-cross-gcc-c++
BuildRequires:  mingw32-extra-cmake-modules >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32-kf5-filesystem
BuildRequires:  mingw32(cmake:KF5Config) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5CoreAddons) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5I18n) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5KIO) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5Plasma) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5Service) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5Solid) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5ThreadWeaver) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:KF5WindowSystem) >= %{_mingw32_kf5_bugfix_version}
BuildRequires:  mingw32(cmake:Qt5Gui) >= 5.11.0
BuildRequires:  mingw32(cmake:Qt5Quick) >= 5.11.0
BuildRequires:  mingw32(cmake:Qt5Test) >= 5.11.0
%_mingw32_package_header_debug
BuildArch:      noarch

%description
Framework Integration is a set of plugins responsible for better
integration of Qt applications when running on a
KDE Plasma workspace.

Applications do not need to link to this directly.

%package -n mingw32-%{lname}
Summary:        Plugins responsible for better integration of Qt applications in KDE Workspace
Group:          System/GUI/KDE

%description -n mingw32-%{lname}
Framework Integration is a set of plugins responsible for better
integration of Qt applications when running on a
KDE Plasma workspace.

Applications do not need to link to this directly.

%package devel
Summary:        Plugins responsible for better integration of Qt applications in KDE Workspace
Group:          Development/Libraries/KDE
Requires:       mingw32-%{lname} = %{version}
Requires:       mingw32-extra-cmake-modules
Requires:       mingw32(cmake:KF5Plasma) >= %{_mingw32_kf5_bugfix_version}
Requires:       mingw32(cmake:Qt5Core) >= 5.11.0
Conflicts:      mingw32-kapptemplate <= 16.03.80

%description devel
Framework Integration is a set of plugins responsible for better
integration of Qt applications when running on a
KDE Plasma workspace.

Applications do not need to link to this directly. Development files

%_mingw32_debug_package

%prep
%setup -q -n %{_name}-%{version}

%build
  %_mingw32_cmake_kf5 -d build
  %_mingw32_cmake_build

%install
  %_mingw32_kf5_makeinstall -C build


%files -n mingw32-%{lname}
# no license yet
#doc LICENSES/* README*
%{_mingw32_kf5_bindir}/libKF5Runner.dll
%{_mingw32_kf5_qmldir}/
%exclude %{_mingw32_kf5_qmldir}/org/kde/*/*.debug
%exclude %{_mingw32_kf5_qmldir}/org/kde/*/*/*.debug
%{_mingw32_kf5_servicetypesdir}/plasma-runner.desktop
%{_mingw32_kf5_debugdir}/*.categories
%{_mingw32_kf5_debugdir}/*.renamecategories

%files devel
#doc LICENSES/* README*
%{_mingw32_kf5_libdir}/libKF5Runner.dll.a
%{_mingw32_kf5_libdir}/cmake/KF5Runner/
%{_mingw32_kf5_includedir}
%{_mingw32_kf5_mkspecsdir}/qt_KRunner.pri
%{_mingw32_kf5_sharedir}/kdevappwizard
%{_mingw32_kf5_dbusinterfacesdir}/kf5_org.kde.krunner1.xml

%changelog
openSUSE Build Service is sponsored by