File mingw64-Clp.spec of Package mingw64-Clp
#
# spec file for package mingw64-Clp
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define _basename Clp
Name: mingw64-%{_basename}
Version: 1.16.3
Release: 0
#!BuildIgnore: post-build-checks
Summary: Coin-or linear programming
License: EPL-1.0
Group: Applications/Engineering
Url: http://projects.coin-or.org/%{_basename}
Source0: http://www.coin-or.org/download/pkgsource/%{_basename}/%{_basename}-%{version}.tgz
Patch0: %{_basename}-docdir.patch
Patch1: %{_basename}-no-compilation-time.patch
BuildRequires: mingw64-Osi-devel
BuildRequires: mingw64-cross-binutils
BuildRequires: mingw64-cross-gcc
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-cross-pkg-config
BuildRequires: mingw64-filesystem
%_mingw64_package_header_debug
BuildArch: noarch
%description
Clp (Coin-or linear programming) is an open-source linear programming
solver written in C++. It is primarily meant to be used as a callable
library, but a basic, stand-alone executable version is also available.
%package devel
Summary: %{_basename} development files
Group: Development/Libraries/C and C++
%description devel
Clp (Coin-or linear programming) is an open-source linear programming
solver written in C++. It is primarily meant to be used as a callable
library, but a basic, stand-alone executable version is also available.
%_mingw64_debug_package
%prep
%setup -q -n %{_basename}-%{version}
%patch -P 0 -p1
%patch -P 1 -p1
%build
%{_mingw64_configure} \
--enable-shared \
coin_skip_warn_cflags=yes \
coin_skip_warn_cxxflags=yes \
lt_cv_deplibs_check_method=pass_all
%{_mingw64_make} %{?_smp_mflags}
%install
%{_mingw64_make} DESTDIR=%{buildroot} install
%files
%defattr(-,root,root,-)
%{_mingw64_bindir}/clp.exe
%{_mingw64_bindir}/lib%{_basename}-*.dll
%{_mingw64_bindir}/lib%{_basename}Solver-*.dll
%{_mingw64_bindir}/libOsi%{_basename}-*.dll
%dir %{_mingw64_docdir}/%{_basename}
%doc %{_mingw64_docdir}/%{_basename}/AUTHORS
%doc %{_mingw64_docdir}/%{_basename}/LICENSE
%doc %{_mingw64_docdir}/%{_basename}/README
%files devel
%defattr(-,root,root,-)
%{_mingw64_libdir}/lib%{_basename}.dll.a
%{_mingw64_libdir}/lib%{_basename}Solver.dll.a
%{_mingw64_libdir}/libOsi%{_basename}.dll.a
%{_mingw64_includedir}/coin/
%{_mingw64_libdir}/pkgconfig/
%doc %{_mingw64_docdir}/%{_basename}/*_addlibs.txt
%changelog