File mingw64-attica-qt5.spec of Package mingw64-attica-qt5
#
# spec file for package mingw64-attica-qt5
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define sonum 5
%define rname attica
%define _libname KF5Attica
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')}
# Only needed for the package signature condition
%bcond_without lang
%define _name attica-qt5
Name: mingw64-%{_name}
Version: 5.103.0
Release: 0
Summary: Open Collaboration Service client library
License: LGPL-2.1-or-later
Group: System/GUI/KDE
URL: https://www.kde.org
Source: https://download.kde.org/stable/frameworks/%{_tar_path}/%{rname}-%{version}.tar.xz
%if %{with lang}
Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/%{rname}-%{version}.tar.xz.sig
Source2: frameworks.keyring
%endif
BuildRequires: mingw64-cross-cmake
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64-kf5-filesystem
BuildRequires: mingw64(cmake:Qt5Core) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Network) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Widgets) >= 5.11.0
%_mingw64_package_header_debug
BuildArch: noarch
%description
Attica is a library to access Open Collaboration Service servers.
%package -n mingw64-lib%{_libname}%{sonum}
Summary: Open Collaboration Service client library - development files
Group: System/GUI/KDE
Requires: %{name} >= %{_mingw64_kf5_bugfix_version}
%requires_ge mingw64-libQt5Core5
%requires_ge mingw64-libQt5Network5
%description -n mingw64-lib%{_libname}%{sonum}
Attica is a library to access Open Collaboration Service servers.
%package -n mingw64-attica-qt5-devel
Summary: Open Collaboration Service client library - development files
Group: Development/Libraries/C and C++
Requires: mingw64-lib%{_libname}%{sonum} = %{version}
Requires: mingw64(cmake:Qt5Core) >= 5.11.0
Requires: mingw64(cmake:Qt5Network) >= 5.11.0
Requires: mingw64(cmake:Qt5Widgets) >= 5.11.0
%description -n mingw64-attica-qt5-devel
Development files for attica, Attica a library to access Open Collaboration Service servers.
%_mingw64_debug_package
%prep
%autosetup -p1 -n %{rname}-%{version}
%build
%_mingw64_cmake_kf5 -d build
%_mingw64_cmake_build
%install
%_mingw64_kf5_makeinstall -C build
%files
%license LICENSES/*
%doc README*
%{_mingw64_kf5_debugdir}/attica.categories
%{_mingw64_kf5_debugdir}/*.renamecategories
%files -n mingw64-lib%{_libname}%{sonum}
%license LICENSES/*
%doc README*
%{_mingw64_libqt5_bindir}/lib%{_libname}*.dll
%files -n mingw64-attica-qt5-devel
%{_mingw64_kf5_libdir}/cmake/KF5Attica/
%{_mingw64_libqt5_libdir}/lib%{_libname}*.dll.a
%{_mingw64_kf5_includedir}/
%{_mingw64_kf5_mkspecsdir}/qt_Attica.pri
%changelog