File mingw64-gst-plugins-base.spec of Package mingw64-gst-plugins-base
#
# spec file for package mingw64-gst-plugins-base
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%_mingw64_package_header_debug
Name: mingw64-gst-plugins-base
Version: 1.14.5
Release: 0
Summary: GStreamer Streaming-Media Framework Plug-Ins
License: LGPL-2.0-or-later
# FIXME: use correct group or remove it, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group: Development/Libraries
URL: https://gstreamer.freedesktop.org/
Source0: https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
Source1000: %{name}-rpmlintrc
Patch0: make43.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: glib2-devel
BuildRequires: gtk-doc
BuildRequires: libtool
BuildRequires: mingw64-cross-binutils
BuildRequires: mingw64-cross-gcc
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-cross-pkg-config
BuildRequires: mingw64-filesystem >= 23
BuildRequires: mingw64-glib2-devel >= 2.8.3
BuildRequires: mingw64-gnome-vfs2-devel
BuildRequires: mingw64-gstreamer-devel >= 1.14.0
BuildRequires: mingw64-libgnurx-devel
BuildRequires: mingw64-libogg-devel
BuildRequires: mingw64-liboil-devel >= 0.3.14
BuildRequires: mingw64-libtheora-devel
BuildRequires: mingw64-libvorbis-devel
BuildRequires: mingw64-libxml2-devel >= 2.0
BuildRequires: mingw64-pango-devel
BuildRequires: python
BuildRequires: xz
#!BuildIgnore: post-build-checks
BuildArch: noarch
%description
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data. Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related. Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
%package devel
Summary: GStreamer Streaming-Media Framework Plug-Ins (development files)
# FIXME: use correct group or remove it, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group: Development/Libraries
%description devel
GStreamer is a streaming-media framework, based on graphs of filters
which operate on media data. Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related. Its plug-in-based architecture
means that new data types or processing capabilities can be added by
installing new plug-ins.
This package contains all necessary include files and libraries needed
to develop applications that require these.
%package -n mingw64-libgstinterfaces
Summary: GStreamer Streaming-Media Framework Plug-Ins
# FIXME: use correct group or remove it, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group: Development/Libraries
%description -n mingw64-libgstinterfaces
GStreamer is a streaming-media framework, based on graphs of filters
which operate on media data. Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related. Its plug-in-based architecture
means that new data types or processing capabilities can be added by
installing new plug-ins.
%lang_package
%_mingw64_debug_package
%prep
%setup -q -n gst-plugins-base-%{version}
%patch -P 0 -p1
%build
libtoolize --force --copy --install
autoreconf -fi
echo "lt_cv_deplibs_check_method='pass_all'" >> %{_mingw64_cache}
PATH="%{_mingw64_bindir}:$PATH"; export PATH; \
%_mingw64_configure \
--enable-shared --disable-static \
--disable-vorbistest --disable-freetypetest \
--disable-examples --enable-experimental \
--disable-zlib
# TODO: don't disable zlib, just make sure that mingw64 one is used (not system-provided one)
%{_mingw64_make} %{?_smp_mflags} || %{_mingw64_make}
%install
%{_mingw64_make} DESTDIR=%{buildroot} install
rm -f %{buildroot}%{_mingw64_libdir}/gstreamer-1.0/*.dll.a
rm -f %{buildroot}%{_mingw64_datadir}/gst-plugins-base/1.0/license-translations.dict
# Remove silly target prefix from binaries
for prefixed_file in %{buildroot}%{_mingw64_bindir}/%{_mingw64_target}-*.exe \
%{buildroot}%{_mingw64_mandir}/*/%{_mingw64_target}-*.*
do
f=$(echo $prefixed_file | sed -e 's/%{_mingw64_target}-//')
mv $prefixed_file $f
done
%find_lang gst-plugins-base-1.0
%files
%{_mingw64_libdir}/gstreamer-1.0/libgstadder.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstapp.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstaudioconvert.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstaudiomixer.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstaudiorate.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstaudioresample.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstaudiotestsrc.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstencoding.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstgio.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstogg.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstopengl.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstpango.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstpbtypes.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstplayback.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstrawparse.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstsubparse.dll
%{_mingw64_libdir}/gstreamer-1.0/libgsttcp.dll
%{_mingw64_libdir}/gstreamer-1.0/libgsttheora.dll
%{_mingw64_libdir}/gstreamer-1.0/libgsttypefindfunctions.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvideoconvert.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvideorate.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvideoscale.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvideotestsrc.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvolume.dll
%{_mingw64_libdir}/gstreamer-1.0/libgstvorbis.dll
%{_mingw64_bindir}/gst-device-monitor-1.0.exe
%{_mingw64_bindir}/gst-discoverer-1.0.exe
%{_mingw64_bindir}/gst-play-1.0.exe
%{_mingw64_mandir}/man1/gst-device-monitor-1.0.1*
%{_mingw64_mandir}/man1/gst-discoverer-1.0.1*
%{_mingw64_mandir}/man1/gst-play-1.0.1*
%files lang -f gst-plugins-base-1.0.lang
%files -n mingw64-libgstinterfaces
%{_mingw64_bindir}/libgstallocators-1.0-0.dll
%{_mingw64_bindir}/libgstapp-1.0-0.dll
%{_mingw64_bindir}/libgstaudio-1.0-0.dll
%{_mingw64_bindir}/libgstfft-1.0-0.dll
%{_mingw64_bindir}/libgstgl-1.0-0.dll
%{_mingw64_bindir}/libgstpbutils-1.0-0.dll
%{_mingw64_bindir}/libgstriff-1.0-0.dll
%{_mingw64_bindir}/libgstrtp-1.0-0.dll
%{_mingw64_bindir}/libgstrtsp-1.0-0.dll
%{_mingw64_bindir}/libgstsdp-1.0-0.dll
%{_mingw64_bindir}/libgsttag-1.0-0.dll
%{_mingw64_bindir}/libgstvideo-1.0-0.dll
%files devel
%{_mingw64_libdir}/libgstapp-1.0.dll.a
%{_mingw64_libdir}/libgstaudio-1.0.dll.a
%{_mingw64_libdir}/libgstfft-1.0.dll.a
%{_mingw64_libdir}/libgstgl-1.0.dll.a
%{_mingw64_libdir}/libgstpbutils-1.0.dll.a
%{_mingw64_libdir}/libgstriff-1.0.dll.a
%{_mingw64_libdir}/libgstrtp-1.0.dll.a
%{_mingw64_libdir}/libgstrtsp-1.0.dll.a
%{_mingw64_libdir}/libgstsdp-1.0.dll.a
%{_mingw64_libdir}/libgsttag-1.0.dll.a
%{_mingw64_libdir}/libgstvideo-1.0.dll.a
%{_mingw64_libdir}/libgstallocators-1.0.dll.a
%{_mingw64_libdir}/pkgconfig/gstreamer-app-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-audio-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-fft-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-gl-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-pbutils-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-plugins-base-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-riff-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-rtp-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-rtsp-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-sdp-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-tag-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-video-1.0.pc
%{_mingw64_libdir}/pkgconfig/gstreamer-allocators-1.0.pc
%{_mingw64_includedir}/gstreamer-1.0/gst
%{_mingw64_libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h
%{_mingw64_datadir}/gtk-doc/html/gst-plugins-base-libs-1.0
%{_mingw64_datadir}/gtk-doc/html/gst-plugins-base-plugins-1.0
%changelog