File mingw64-kcompletion.spec of Package mingw64-kcompletion
#
# spec file for package mingw64-kcompletion
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname libKF5Completion5
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')}
%bcond_without lang
%define _name kcompletion
Name: mingw64-%{_name}
Version: 5.103.0
Release: 0
Summary: Widgets with advanced completion support
License: LGPL-2.1-or-later
Group: System/GUI/KDE
URL: https://www.kde.org
Source: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz
%if %{with lang}
Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz.sig
Source2: frameworks.keyring
%endif
BuildRequires: mingw64-cross-cmake
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64-kf5-filesystem
BuildRequires: mingw64(cmake:KF5Config) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5WidgetsAddons) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:Qt5UiPlugin) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Widgets) >= 5.11.0
%_mingw64_package_header_debug
BuildArch: noarch
%description
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets.
%package -n mingw64-%{lname}
Summary: Widgets with advanced completion support
Group: System/GUI/KDE
%if %{with lang}
Recommends: mingw64-%{lname}-lang = %{version}
%endif
%description -n mingw64-%{lname}
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets.
%package devel
Summary: Header files for kcompletion, a widget collection with completion support
Group: Development/Libraries/KDE
Requires: mingw64-%{lname} = %{version}
Requires: mingw64-extra-cmake-modules
Requires: mingw64(cmake:Qt5Widgets) >= 5.11.0
%description devel
Development files for KCompletion, a widget collection with advanced
completion support as well as a lower-level completion class which
can be used with own widgets.
%lang_package -n mingw64-%{lname}
%_mingw64_debug_package
%prep
%setup -q -n %{_name}-%{version}
%build
%_mingw64_cmake_kf5 -d build
%_mingw64_cmake_build
%install
%_mingw64_kf5_makeinstall -C build
%if %{with lang}
%_mingw64_find_lang %{_name}5 --all-name --with-qt --without-mo
%endif
%if %{with lang}
%files -n mingw64-%{lname}-lang -f %{_name}5.lang
%endif
%files -n mingw64-%{lname}
%license LICENSES/*
%doc README*
%{_mingw64_kf5_bindir}/libKF5Completion.dll
%{_mingw64_kf5_debugdir}/*.categories
%files devel
%{_mingw64_kf5_libdir}/libKF5Completion.dll.a
%{_mingw64_kf5_libdir}/cmake/KF5Completion/
%{_mingw64_kf5_includedir}
%{_mingw64_kf5_mkspecsdir}/qt_KCompletion.pri
%changelog