File mingw64-kwallet.spec of Package mingw64-kwallet
#
# spec file for package mingw64-kwallet
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname libKF5Wallet5
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')}
%bcond_without lang
%define _name kwallet
Name: mingw64-%{_name}
Version: 5.103.0
Release: 0
Summary: Safe desktop-wide storage for passwords
License: LGPL-2.1-or-later
Group: System/GUI/KDE
URL: https://www.kde.org
Source: https://download.kde.org/stable/frameworks/%{_tar_path}/kwallet-%{version}.tar.xz
%if %{with lang}
Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/kwallet-%{version}.tar.xz.sig
Source2: frameworks.keyring
%endif
Patch0: fix-building-with-gpgme.patch
BuildRequires: mingw64-cross-cmake
BuildRequires: mingw64-boost-devel
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64-kf5-filesystem
BuildRequires: mingw64-libgcrypt-devel >= 1.5.0
BuildRequires: mingw64(cmake:KF5Config) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5ConfigWidgets) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5CoreAddons) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5DBusAddons) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5DocTools) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5I18n) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5IconThemes) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5Notifications) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5Service) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5WidgetsAddons) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:KF5WindowSystem) >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64(cmake:QGpgme)
BuildRequires: mingw64(cmake:Qca-qt5)
BuildRequires: mingw64(cmake:Qt5DBus) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Test) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Widgets) >= 5.11.0
%_mingw64_package_header_debug
BuildArch: noarch
%description
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.
* The kwalletd used to safely store the passwords on KDE work spaces.
%package -n mingw64-%{lname}
Summary: Safe desktop-wide storage for passwords
Group: System/GUI/KDE
%description -n mingw64-%{lname}
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.
* The kwalletd used to safely store the passwords on KDE work spaces.
%package -n mingw64-libkwalletbackend5-5
Summary: Safe desktop-wide storage for passwords
Group: System/GUI/KDE
%description -n mingw64-libkwalletbackend5-5
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.
* The kwalletd used to safely store the passwords on KDE work spaces.
%package -n mingw64-kwalletd5
Summary: Safe desktop-wide storage for passwords
Group: System/GUI/KDE
Recommends: %{name}-tools
%if %{with lang}
Recommends: mingw64-kwalletd5-lang
%endif
%description -n mingw64-kwalletd5
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.
* The kwalletd used to safely store the passwords on KDE work spaces.
%package tools
Summary: Safe desktop-wide storage for passwords
Group: System/GUI/KDE
%if %{with lang}
Recommends: mingw64-kwallet-tools-lang
%endif
%description tools
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.%{_mingw64_kf5_applicationsdir}/org.kde.kwalletd5.desktop
* The kwalletd used to safely store the passwords on KDE work spaces.
%package tools-lang
# FIXME: consider using %%lang_package macro
Summary: Safe desktop-wide storage for passwords
Group: System/GUI/KDE
Requires: %{name}-tools = %{version}
%description tools-lang
Provides translations to the package %{name}-tools-lang
%package devel
Summary: Safe desktop-wide storage for passwords
Group: Development/Libraries/KDE
Requires: mingw64-%{lname} = %{version}
Requires: mingw64-extra-cmake-modules
Requires: mingw64-libkwalletbackend5-5 = %{version}
Requires: mingw64(cmake:Qt5Gui) >= 5.11.0
# Was shortly present in K:F5
Obsoletes: mingw64-kwallet-framework-devel <= %{version}
Provides: mingw64-kwallet-framework-devel = %{version}
%description devel
This framework contains two main components:
* Interface to KWallet, the safe desktop-wide storage for passwords on KDE workspaces.
* The kwalletd used to safely store the passwords on KDE work spaces.
Development files.
%lang_package -n mingw64-kwalletd5
%_mingw64_debug_package
%prep
%autosetup -p1 -n %{_name}-%{version}
%build
%_mingw64_cmake_kf5 -d build
%_mingw64_cmake_build
%install
%_mingw64_kf5_makeinstall -C build
%if %{with lang}
%_mingw64_find_lang kwalletd5 kwalletd5.lang
%_mingw64_find_lang kwallet-query kwallet-query.lang
%endif
%if %{with lang}
%files -n mingw64-kwalletd5-lang -f kwalletd5.lang
%files -n mingw64-kwallet-tools-lang -f kwallet-query.lang
%endif
%files -n mingw64-kwalletd5
%license LICENSES/*
%{_mingw64_kf5_bindir}/kwalletd5.exe
%{_mingw64_kf5_servicesdir}/kwalletd5.desktop
%{_mingw64_kf5_applicationsdir}/org.kde.kwalletd5.desktop
%{_mingw64_kf5_notifydir}/
%{_mingw64_kf5_sharedir}/dbus-1/services/org.kde.kwalletd5.service
%files -n mingw64-%{lname}
%license LICENSES/*
%{_mingw64_kf5_bindir}/libKF5Wallet.dll
%{_mingw64_kf5_debugdir}/*.categories
%{_mingw64_kf5_debugdir}/*.renamecategories
%files -n mingw64-libkwalletbackend5-5
%license LICENSES/*
%{_mingw64_kf5_bindir}/libkwalletbackend5.dll
%files tools
%{_mingw64_kf5_bindir}/kwallet-query.exe
%{_mingw64_kf5_mandir}/man1/kwallet-query.1*
%files devel
%{_mingw64_kf5_libdir}/libKF5Wallet.dll.a
%{_mingw64_kf5_libdir}/libkwalletbackend5.dll.a
%{_mingw64_kf5_libdir}/cmake/KF5Wallet/
%{_mingw64_kf5_includedir}
%{_mingw64_kf5_mkspecsdir}/qt_KWallet.pri
%{_mingw64_kf5_dbusinterfacesdir}/kf5_org.kde.KWallet.xml
%changelog