File mingw64-libqt5-qtscript.spec of Package mingw64-libqt5-qtscript
#
# spec file for package mingw64-libqt5-qtscript
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define qt5_snapshot 1
%global qt_module qtscript
#%%global pre beta1
%global source_folder %{qt_module}-everywhere-src-%{version}%{?pre:-%pre}
# first two digits of version
%global release_version %(echo %{version} | awk -F. '{print $1"."$2}')
Name: mingw64-libqt5-%{qt_module}
Version: 5.15.14+kde0
Release: 0
Summary: Qt5 for Windows - QtTools component
License: GPL-3.0-only or SUSE-LGPL-2.1-with-digia-exception-1.1
Group: Development/Libraries
Url: http://qt-project.org/
Source0: %{source_folder}.tar.xz
BuildRequires: mingw64-libqt5-qtbase-devel >= %{version}
# Disabled for now because of compilation issues
# BuildRequires: mingw64-qt5-qtactiveqt
%_mingw64_package_header_debug
BuildArch: noarch
%description
This package contains the Qt software toolkit for developing
cross-platform applications.
This is the Windows version of Qt, for use in conjunction with the
MinGW cross-compiler.
%package devel
Summary: Qt5 for Windows - QtScript component (development)
Group: Development/Libraries
Provides: %{name}-private-headers-devel
Requires: %{name} = %{version}-%{release}
%description devel
This package contains the Qt software toolkit for developing
cross-platform applications.
This is the Windows version of Qt, for use in conjunction with the
MinGW cross-compiler.
%_mingw64_debug_package
%prep
%setup -q -n %{source_folder}
%build
%if %{qt5_snapshot}
#force the configure script to generate the forwarding headers (it checks whether .git directory exists)
mkdir .git
%endif
mingw64-qmake-qt5 %{qt_module}.pro
%{_mingw64_make} %{?_smp_mflags}
%install
%{_mingw64_make} install INSTALL_ROOT=%{buildroot}
# .prl files aren't interesting for us
find %{buildroot} -name "*.prl" -delete
# The .dll's are installed in both %%{_mingw64_bindir} and %%{_mingw64_libdir}
# One copy of the .dll's is sufficient
rm -f %{buildroot}%{_mingw64_libdir}/*.dll
%files
%defattr(-, root, root)
%{_mingw64_bindir}/libQt5Script.dll
%{_mingw64_bindir}/libQt5ScriptTools.dll
%files devel
%defattr(-, root, root)
%{_mingw64_includedir}/qt5/QtScript/
%{_mingw64_includedir}/qt5/QtScriptTools/
%{_mingw64_libdir}/libQt5Script.dll.a
%{_mingw64_libdir}/libQt5ScriptTools.dll.a
%{_mingw64_libdir}/cmake/Qt5Script/
%{_mingw64_libdir}/cmake/Qt5ScriptTools/
%{_mingw64_libdir}/pkgconfig/Qt5Script.pc
%{_mingw64_libdir}/pkgconfig/Qt5ScriptTools.pc
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_script.pri
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_script_private.pri
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_scripttools.pri
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_scripttools_private.pri
%changelog