File mingw64-libqt5-qtxmlpatterns.spec of Package mingw64-libqt5-qtxmlpatterns
#
# spec file for package mingw64-libqt5-qtxmlpatterns
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define qt5_snapshot 1
%global qt_module qtxmlpatterns
%global source_folder %{qt_module}-everywhere-src-%{version}%{?pre:-%pre}
Name: mingw64-libqt5-%{qt_module}
Version: 5.15.14+kde0
Release: 0
Summary: Qt5 for Windows - QtXmlPatterns component
License: GPL-3.0-only or SUSE-LGPL-2.1-with-digia-exception-1.1
Group: Development/Libraries
Url: http://www.qt-project.org/
Source0: %{source_folder}.tar.xz
# Host
BuildRequires: binutils
BuildRequires: gcc
BuildRequires: gcc-c++
# Target tools on host
BuildRequires: mingw64-cross-binutils
BuildRequires: mingw64-cross-gcc
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-cross-libqt5-qmake >= %{version}
BuildRequires: mingw64-cross-pkgconf
BuildRequires: mingw64-filesystem >= 96
BuildRequires: mingw64-gcc-c++
BuildRequires: mingw64-libpng-devel
BuildRequires: mingw64-libqt5-qtbase >= %{version}
BuildRequires: mingw64-libqt5-qtbase-devel >= %{version}
BuildRequires: mingw64-pcre-devel
BuildRequires: mingw64-zlib-devel
BuildRequires: xz
%_mingw64_package_header_debug
BuildArch: noarch
%description
This package contains the Qt software toolkit for developing
cross-platform applications.
This is the Windows version of Qt, for use in conjunction with the
MinGW cross-compiler.
%package devel
Summary: Qt5 for Windows - QtWinExtras component (development)
Group: Development/Libraries
Provides: %{name}-private-headers-devel
Requires: %{name} = %{version}-%{release}
%description devel
This package contains the Qt software toolkit for developing
cross-platform applications.
This is the Windows version of Qt, for use in conjunction with the
MinGW cross-compiler.
%_mingw64_debug_package
%prep
%setup -q -n %{source_folder}
%build
%if %{qt5_snapshot}
#force the configure script to generate the forwarding headers (it checks whether .git directory exists)
mkdir .git
%endif
mingw64-qmake-qt5 %{qt_module}.pro
%{_mingw64_make} %{?_smp_mflags}
%install
%{_mingw64_make} install INSTALL_ROOT=%{buildroot}
# .prl files aren't interesting for us
find %{buildroot} -name "*.prl" -delete
# move executables into Qt5 dir to avoid conflicts
mkdir -p %{buildroot}%{_mingw64_bindir}/qt5
mv %{buildroot}%{_mingw64_bindir}/xmlpatterns.exe %{buildroot}%{_mingw64_bindir}/qt5/
mv %{buildroot}%{_mingw64_bindir}/xmlpatternsvalidator.exe %{buildroot}%{_mingw64_bindir}/qt5/
# The .dll's are installed in both %%{_mingw64_bindir} and %%{_mingw64_libdir}
# One copy of the .dll's is sufficient
rm -f %{buildroot}%{_mingw64_libdir}/*.dll
%files
%defattr(-,root,root)
%{_mingw64_bindir}/libQt5XmlPatterns.dll
%dir %{_mingw64_bindir}/qt5
%{_mingw64_bindir}/qt5/xmlpatterns.exe
%{_mingw64_bindir}/qt5/xmlpatternsvalidator.exe
%files devel
%defattr(-,root,root)
%{_mingw64_includedir}/qt5/QtXmlPatterns/
%{_mingw64_libdir}/libQt5XmlPatterns.dll.a
%{_mingw64_libdir}/pkgconfig/Qt5XmlPatterns.pc
%dir %{_mingw64_libdir}/cmake/Qt5XmlPatterns/
%{_mingw64_libdir}/cmake/Qt5XmlPatterns/Qt5XmlPatternsConfig.cmake
%{_mingw64_libdir}/cmake/Qt5XmlPatterns/Qt5XmlPatternsConfigVersion.cmake
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_xmlpatterns.pri
%{_mingw64_datadir}/qt5/mkspecs/modules/qt_lib_xmlpatterns_private.pri
%changelog