File mingw64-syntax-highlighting.spec of Package mingw64-syntax-highlighting
#
# spec file for package mingw64-syntax-highlighting
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname libKF5SyntaxHighlighting5
%define _tar_path 5.103
# Full KF5 version (e.g. 5.33.0)
%{!?_mingw64_kf5_version: %global _mingw64_kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_mingw64_kf5_bugfix_version: %define _mingw64_kf5_bugfix_version %(echo %{_mingw64_kf5_version} | awk -F. '{print $1"."$2}')}
%bcond_without lang
%define _name syntax-highlighting
Name: mingw64-%{_name}
Version: 5.103.0
Release: 0
Summary: Syntax highlighting engine and library
License: LGPL-2.1-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-3.0-only AND MIT AND BSD-3-Clause AND Artistic-1.0
Group: System/GUI/KDE
URL: https://www.kde.org
Source: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz
%if %{with lang}
Source1: https://download.kde.org/stable/frameworks/%{_tar_path}/%{_name}-%{version}.tar.xz.sig
Source2: frameworks.keyring
%endif
# for building native katehighlightingindexer
BuildRequires: mingw64-cross-extra-cmake-modules
BuildRequires: cmake(Qt5Core) >= 5.6.0
BuildRequires: cmake(Qt5Gui) >= 5.6.0
BuildRequires: cmake(Qt5LinguistTools) >= 5.6.0
BuildRequires: cmake(Qt5Network) >= 5.6.0
BuildRequires: cmake(Qt5Test) >= 5.6.0
BuildRequires: mingw64-cross-cmake
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-extra-cmake-modules >= %{_mingw64_kf5_bugfix_version}
BuildRequires: mingw64-kf5-filesystem
BuildRequires: mingw64(cmake:Qt5Core) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Gui) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Network) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Test) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5Widgets) >= 5.11.0
BuildRequires: mingw64(cmake:Qt5XmlPatterns) >= 5.11.0
%_mingw64_package_header_debug
BuildArch: noarch
%description
This is a tier1/functional version of the Kate syntax highlighting engine.
It's not tied to a particular output format or editor engine.
%package -n mingw64-%{lname}
Summary: Syntax highlighting engine and library
Group: System/GUI/KDE
Recommends: %{name} = %{version}
%if %{with lang}
Recommends: mingw64-%{lname}-lang = %{version}
%endif
%description -n mingw64-%{lname}
This is a tier1/functional version of the Kate syntax highlighting engine.
It's not tied to a particular output format or editor engine.
%package devel
Summary: Syntax highlighting engine and library
Group: Development/Libraries/KDE
Requires: mingw64-%{lname} = %{version}
Requires: mingw64-extra-cmake-modules
Requires: mingw64(cmake:Qt5Core) >= 5.11.0
Requires: mingw64(cmake:Qt5Gui) >= 5.11.0
%description devel
This is a tier1/functional version of the Kate syntax highlighting engine.
It's not tied to a particular output format or editor engine.
%lang_package -n mingw64-%{lname}
%_mingw64_debug_package
%prep
%setup -q -n %{_name}-%{version}
%build
cmake -B native-build -DCMAKE_INSTALL_PREFIX=/usr/%{_mingw64_target}
cmake --build native-build -t katehighlightingindexer
OPTIONS="-DKATEHIGHLIGHTINGINDEXER_EXECUTABLE=$PWD/native-build/bin/katehighlightingindexer"
%_mingw64_cmake_kf5 -d build -- $OPTIONS
%_mingw64_cmake_build
%install
%_mingw64_kf5_makeinstall -C build
%if %{with lang}
%_mingw64_find_lang syntaxhighlighting5 --all-name --with-qt --without-mo
%endif
%if %{with lang}
%files -n mingw64-%{lname}-lang -f syntaxhighlighting5.lang
%endif
%files
%license LICENSES/*
%doc README*
%{_mingw64_kf5_bindir}/kate-syntax-highlighter.exe
%{_mingw64_kf5_debugdir}/*.categories
%{_mingw64_kf5_debugdir}/*.renamecategories
%files -n mingw64-%{lname}
%license LICENSES/*
%doc README*
%{_mingw64_kf5_bindir}/libKF5SyntaxHighlighting.dll
%files devel
%{_mingw64_kf5_libdir}/libKF5SyntaxHighlighting.dll.a
%{_mingw64_kf5_libdir}/cmake/KF5SyntaxHighlighting/
%{_mingw64_kf5_mkspecsdir}/qt_KSyntaxHighlighting.pri
%{_mingw64_kf5_includedir}/
%changelog