File PKGBUILD of Package qsynth
pkgname=qsynth
pkgver=1.0.2.7git.630d0d
pkgrel=3.1
pkgdesc="A fluidsynth Qt GUI Interface"
arch=('x86_64')
url="https://qsynth.sourceforge.io/"
license=('GPL2')
groups=('pro-audio')
makedepends=('cmake' 'gzip' 'dbus-broker-units')
depends=('gcc-libs' 'glibc' 'hicolor-icon-theme' 'mesa'
'fluidsynth' 'alsa-lib' 'jack2' 'pipewire'
'qt6-base' 'qt6-tools' 'qt6-translations' 'qt6-svg')
source=("${pkgname}-${pkgver}.tar.gz")
sha512sums=('SKIP')
build() {
cd "${pkgname}-${pkgver}"
cmake -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev -B build -S .
cmake --build build --parallel 7
}
package() {
cd "${pkgname}-${pkgver}"
DESTDIR="${pkgdir}" cmake --install build
install -t "${pkgdir}/usr/share/doc/${pkgname}" \
-vDm 644 {README,LICENSE,TRANSLATORS,ChangeLog}
}