File perl-File-Temp.spec of Package test

#
# spec file for package perl-File-Temp
# 
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

#Distribution:   %dist
#Packager:       %packager
#Vendor:         %vendor

Name:           perl-File-Temp
%define cpan_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:        return name and handle of a temporary file safely
Version:        0.21
Release:        1
License:        artistic
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/perldoc?File::Temp
Source0:        %{cpan_name}-%{version}.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::More)
BuildRequires:  perl(File::Spec) >= 0.8
BuildRequires:  perl(Fcntl) >= 1.03
BuildRequires:  perl(File::Path)
#BuildRequires:  perl(Module::Build)
Requires:  perl(File::Spec) >= 0.8
Requires:  perl(Fcntl) >= 1.03
Requires:  perl(File::Path)

%description
 %{cpan_name} module for perl

  File::Temp can be used to create and open temporary files in a safe way.
   There is both a function interface and an object-oriented interface.
   The File::Temp constructor or the tempfile() function can be used to return
   the name and the open filehandle of a temporary file. The tempdir() function
   can be used to create a temporary directory.

  Author:	Tim Jenness <tjenness (at) cpan.org>


%prep
%setup -q -n %{cpan_name}-%{version}

%build
perl Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean 
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
%defattr(-,root,root)
%doc ChangeLog README

%changelog
* Thu Aug 21 2008 - rpm@scorpio-it.net - 0.20
- initial Package
- Building it for OpenSuSE 12.1
openSUSE Build Service is sponsored by