File perl-IO-AIO.spec of Package perl-IO-AIO
#
# spec file for package perl-IO-AIO
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name IO-AIO
Name: perl-IO-AIO
Version: 4.79
Release: 0
#Upstream: CHECK(Artistic-1.0 or GPL-1.0-or-later)
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Asynchronous/Advanced Input/Output
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/%{cpan_name}-%{version}.tar.gz
Source1: cpanspec.yml
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Canary::Stability) >= 2001
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.52
BuildRequires: perl(common::sense)
Requires: perl(common::sense)
%{perl_requires}
%description
This module implements asynchronous I/O using whatever means your operating
system supports. It is implemented as an interface to 'libeio'
(http://software.schmorp.de/pkg/libeio.html).
Asynchronous means that operations that can normally block your program
(e.g. reading from disk) will be done asynchronously: the operation will
still block, but you can do something else in the meantime. This is
extremely useful for programs that need to stay interactive even when doing
heavy I/O (GUI programs, high performance network servers etc.), but can
also be used to easily do operations in parallel that are normally done
sequentially, e.g. stat'ing many files, which is much faster on a RAID
volume or over NFS when you do a number of stat operations concurrently.
While most of this works on all types of file descriptors (for example
sockets), using these functions on file descriptors that support
nonblocking operation (again, sockets, pipes etc.) is very inefficient. Use
an event loop for that (such as the EV module): IO::AIO will naturally fit
into such an event loop itself.
In this version, a number of threads are started that execute your requests
and signal their completion. You don't need thread support in perl, and the
threads created by this module will not be visible to perl. In the future,
this module might make use of the native aio functions available on many
operating systems. However, they are often not well-supported or restricted
(GNU/Linux doesn't allow them on normal files currently, for example), and
they would only support aio_read and aio_write, so the remaining
functionality would have to be implemented using threads anyway.
In addition to asynchronous I/O, this module also exports some rather
arcane interfaces, such as 'madvise' or linux's 'splice' system call, which
is why the 'A' in 'AIO' can also mean _advanced_.
Although the module will work in the presence of other (Perl-) threads, it
is currently not reentrant in any way, so use appropriate locking yourself,
always call 'poll_cb' from within the same thread, or never call 'poll_cb'
(or other 'aio_' functions) recursively.
%prep
%autosetup -n %{cpan_name}-%{version}
find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -name "configure" -print0 | xargs -0 chmod 644
%build
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes README
%license COPYING
%exclude %{_bindir}/treescan
%package -n treescan-aio
Summary: File Tree Scanner that uses Asynchronous I/O
Group: System/Base
Requires: perl(IO::AIO) = %{version}
BuildArch: noarch
%description -n treescan-aio
Scans a tree of files for changes, using AIO (Asynchronous I/O).
%files -n treescan-aio
%defattr(-,root,root)
%{_bindir}/treescan
%changelog