File gcp.spec of Package gcp
# vim: set ts=4 sw=4 et:
# Copyright (c) 2010-2013 Pascal Bleser <pascal.bleser@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
%define _prefix /
%define _mandir %{_usr}/share/man
Name: gcp
Version: 0.5
%define cu_version 8.21
Release: 0
Summary: Advanced Copy
# http://ftp.gnu.org/gnu/coreutils/coreutils-%{cu_version}.tar.xz
Source: coreutils-%{cu_version}.tar.bz2
Source1: http://www.beatex.org/web/advcopy/advcpmv-%{version}-%{cu_version}.patch
URL: http://www.beatex.org/web/advancedcopy.html
Group: System/Base
License: GPL-3.0
BuildRoot: %{_tmppath}/build-%{name}-%{version}
BuildConflicts: libselinux-devel
BuildRequires: gcc make glibc-devel
BuildRequires: autoconf automake libtool
%description
Advanced Copy is a mod for the GNU cp tool. Currently it adds a progress bar to
show you what's going on while you're waiting for the process to finish.
%package -n gmv
Summary: Advanced Move
Group: System/Base
%description -n gmv
Advanced Move is a mod for the GNU mv tool. Currently it adds a progress bar to
show you what's going on while you're waiting for the process to finish.
%prep
%setup -q -n "coreutils-%{cu_version}"
%__patch -p1 < "%{SOURCE1}"
%build
%configure
#__make -C src version.h
%__make %{?_smp_flags} V=1
%install
%__install -D -m0755 src/cp "%{buildroot}%{_bindir}/gcp"
%__install -D -m0644 man/cp.1 "%{buildroot}%{_mandir}/man1/gcp.1"
%__install -D -m0755 src/mv "%{buildroot}%{_bindir}/gmv"
%__install -D -m0644 man/mv.1 "%{buildroot}%{_mandir}/man1/gmv.1"
%clean
%{?buildroot:%__rm -rf "%{buildroot}"}
%files
%defattr(-,root,root)
%doc COPYING
%{_bindir}/gcp
%{_mandir}/man1/gcp.1*
%files -n gmv
%defattr(-,root,root)
%doc COPYING
%{_bindir}/gmv
%{_mandir}/man1/gmv.1*
%changelog