File python-opengl.changes of Package python-opengl

-------------------------------------------------------------------
Tue Mar 19 08:55:23 UTC 2024 - Ben Greiner <code@bnavigator.de>

- Add PyOpenGL-pr100-py312.patch gh#mcfletch/pyopengl#100
- Build PEP517 wheel
- Clean old python36 flavor specfile commands

-------------------------------------------------------------------
Wed Dec 27 13:49:54 UTC 2023 - Dirk Müller <dmueller@suse.com>

- update to 3.1.7:
  * refreshed bindings

-------------------------------------------------------------------
Sat Jun 10 09:49:18 UTC 2023 - ecsos <ecsos@opensuse.org>

- Add %{?sle15_python_module_pythons}

-------------------------------------------------------------------
Sat Mar 26 19:20:43 UTC 2022 - Dirk Müller <dmueller@suse.com>

- update to 3.1.6:
  * python 3.8-3.10 support

-------------------------------------------------------------------
Tue Mar 23 21:49:55 UTC 2021 - Ben Greiner <code@bnavigator.de>

- Don't test with pygame for python36. Pygame requires NumPy which
  is not available for python36 on TW.

-------------------------------------------------------------------
Thu Apr 30 18:15:00 UTC 2020 - Benjamin Greiner <code@bnavigator.de>

- Update to 3.1.5
- move to pytest-xvfb for tests
- the runtime requirement of Mesa-dri was not picked up automatically

-------------------------------------------------------------------
Mon Sep  9 09:30:18 UTC 2019 - Tomáš Chvátal <tchvatal@suse.com>

- Switch to multibuild to avoid buildcycle

-------------------------------------------------------------------
Sun Aug 18 05:11:27 UTC 2019 - John Vandenberg <jayvdb@gmail.com>

- Remove CFLAGS for noarch package
- Use setuptools to build the package
- Expand scope of fdupes to include egg-info
- Activate test suite, disabled using bcond check on platforms
  without test dependency pygame, and with test_buffer_api_basic
  disabled on platforms other than x86_64 and aarch64 due to
  failures caused by the installation of opengel-accelerate
- Change optional dependencies tk and numpy to Recommends
  instead of mandatory run time dependencies
- Add missing python-tk to Recommends to complement tk
- Change mtime adjustment algorithm to be more reflective of the
  source date, based on OpenGL/__init__.py instead of .changes
- Upgrade to 3.1.3b2
  - Python 3.7 compatibility fixes

-------------------------------------------------------------------
Tue Dec  4 12:51:01 UTC 2018 - Matej Cepl <mcepl@suse.com>

- Remove superfluous devel dependency for noarch package

-------------------------------------------------------------------
Thu Oct 25 12:43:03 UTC 2018 - Tomáš Chvátal <tchvatal@suse.com>

- Update to 3.1.3b1:
  * no obvious changelog

-------------------------------------------------------------------
Mon Jun  5 11:26:10 UTC 2017 - aloisio@gmx.com

- Update to version 3.1.1a1
- Added python-opengl.changes as source
- Converted to single-spec

-------------------------------------------------------------------
Mon Jul 14 12:13:36 UTC 2014 - toddrme2178@gmail.com

- Update to 3.1.0
  * no changelog

-------------------------------------------------------------------
Fri Apr 19 12:50:33 UTC 2013 - toddrme2178@gmail.com

- Update to 3.0.2
  * no changelog
- Add python 3 version

-------------------------------------------------------------------
Tue Sep 14 10:50:25 UTC 2010 - coolo@novell.com

- update to 3.0.1
  * tons of changes, but no upstream documentation beside
    ChangeLog.txt

-------------------------------------------------------------------
Tue Aug 11 19:29:18 CEST 2009 - matejcik@suse.cz

- removed non-applied patches
- switched to noarch (accelerator is not present, so no
  platform-dependent parts)

-------------------------------------------------------------------
Thu Aug  6 14:52:13 CEST 2009 - matejcik@suse.cz

- update to 3.0.0
  * big under-the-hood rewrite while using backwards-compatible API
  * support for entire OGL3.0 api and most extensions
  * plug-in API
  * lower performance (accelerator module is not done yet)
  * package-level configuration flags

-------------------------------------------------------------------
Wed Jun 10 17:04:15 CEST 2009 - ro@suse.de

- buildreq: replace gle by libgle-devel for >= 11.2

-------------------------------------------------------------------
Mon May  4 12:09:40 CEST 2009 - ro@suse.de

- buildrequires: replace python-numeric by python-numpy
  for >= 11.2

-------------------------------------------------------------------
Fri Jan 26 19:40:54 CET 2007 - jmatejek@suse.cz

- removed strict-aliasing warnings
- removed invalid operations

-------------------------------------------------------------------
Tue Nov 21 13:09:23 CET 2006 - prusnak@suse.cz

- changes according to PEP353 (pep353.diff)

-------------------------------------------------------------------
Mon Sep 11 19:50:00 CEST 2006 - jmatejek@suse.cz

- replaced a mistyped unicode nonbreakspace with a
  regular space, thus fixing build with python2.5

-------------------------------------------------------------------
Tue Feb 28 16:46:03 CET 2006 - jmatejek@suse.cz

- updated to reflect python changes due to #149809

-------------------------------------------------------------------
Wed Jan 25 21:40:50 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Mon Jan 23 16:47:21 CET 2006 - jmatejek@suse.cz

- added build dependency on tk-devel
- fixed build not to require X server

-------------------------------------------------------------------
Mon Jun 20 16:10:57 CEST 2005 - ltinkl@suse.cz

- added freeglut* packages to fix dependencies (#80605), plus
  optional (but recommended) dependency on python-imaging (pil)

-------------------------------------------------------------------
Tue Nov 23 16:25:43 CET 2004 - mcihar@suse.cz

- update to 2.0.1.09
- simplified filelist generating

-------------------------------------------------------------------
Wed Aug 04 16:09:55 CEST 2004 - mcihar@suse.cz

- update to 2.0.1.08

-------------------------------------------------------------------
Wed Apr 21 12:22:58 CEST 2004 - mcihar@suse.cz

- fix gcc warning
- fixed python requires
- use sed instead of patch for lib64

-------------------------------------------------------------------
Sat Jan 10 22:36:23 CET 2004 - adrian@suse.de

- build as user

-------------------------------------------------------------------
Mon Jun 16 16:49:02 CEST 2003 - mcihar@suse.cz

- added some magic to generate correct filelist

-------------------------------------------------------------------
Mon Jun 09 16:43:38 CEST 2003 - mcihar@suse.cz

- documentation isn't executable

-------------------------------------------------------------------
Thu Jun 05 09:58:00 CEST 2003 - mcihar@suse.cz

- rather move documentation than symlink, as otherwise upgrade
  doesn't work correctly

-------------------------------------------------------------------
Tue May 27 19:55:53 CEST 2003 - mcihar@suse.cz

- install documentation only once

-------------------------------------------------------------------
Fri Jan 10 11:29:54 CET 2003 - mcihar@suse.cz

- fixed build for lib64 arches

-------------------------------------------------------------------
Mon Jan 06 12:02:31 CET 2003 - mcihar@suse.cz

- initial package version

openSUSE Build Service is sponsored by